Using Amazon S3 Service as a Course Platform

Help! Anyone...

I have read Tom K.'s blog post on using Amazon S3 (as well as Dropbox, Google, etc) and Ashley T.'s reply to a forum thread on the use of S3 with another Articulate product (not SL2). I downloaded Cloudberry and installed it, set up an Amazon S3 account, created a bucket, and uploaded a test course to S3 and tried to run it using the web link from Cloudberry-- nothing happened.

FYI, I published the course to Web and checked the "Include HTML5 Output", "Use AMP for Android/iOS" and "Allow downloading for off-line viewing" boxes.

I used Cloudberry to upload the entire Story Output file (mobile and story_content folders plus the 7 environment files). I selected the "story.html" file as the launch point and obtained the URL with Cloudberry.

I tried running the program with that URL and only get a blank screen on my browser (Firefox). (But I get the same behavior with Internet Explorer.)

Although Tom's instructions in his blog post were good, there were apparently a lot of missing steps as when I tried to replicate his instructions, I found options arising that were not mentioned in his blog.

I don't know whether my problem is with permissions (I set Amazon S3 Anyone for reading and for the story.html file set permissions to Everyone Open/Download).

Any ideas, team?

47 Replies
Dale Thorpe

Hello Richard -

Thank you so much for your post. I could really identify with your experiences. After following instructions from several Articulate blogs and other YouTube videos, I will still getting a clock when I tried to launch my Storyline courses. Your blog helped me realize the problem (that I had not made my root bucket public)! Once I made it public, everything finally worked. Thank you, thank you!!

Condoleeza T.

Beginner here!  I followed Tom K.'s instructions on set up and got stuck.  As you can see in my screenshots, Tom has his root pointing towards his courses.  Unfortunately, once I click on Users I get the arrow and public.  I cannot access my name, then documents, then Articulate programs.  Can somewhat help?!

Ashley Terwilliger

Hi Alanna,

Are your files saved locally to your C drive? I don't know a ton about using Cloudberry (outside what that article shows) but I'd want to make sure your files were saved and mapped to the C drive in your user profile (vs. a network/shared drive). 

I'd suggest starting there and if you need to get your content up and out the door quickly you can use Tempshare as a patch. It's easy to upload and it'll keep your content live for 10 days.

Condoleeza T.

Hi, Yes my files are under C. I've tried tempshare but unfortunately it gets to 99% and then stops loading. It's all driving me crazy!  I am trying to find someone who can come on my computer remotely to assist me. Willing to pay!   Sent from my Android BlackBerry - via the Rogers Network

John Curran

I got Amazon S3 working but it's not for the faint hearted! Just finding the S3 Console was a challenge. Amazon AWS is not meant for simple occasional use but for proper web dev projects. 

Thanks Elizabeth for your instructions - I think the Console has changed a bit recently and you can now upload to it using simple drag and drop (no need to install an FTP app like Cloudberry).

Still, not nearly as simple as good old Tempshare!

Mustafa Yucelgen

Hi all!

We use AWS & S3 as our hosting platforms for our LMS and intranet cloud services. 

We've reconfigured S3 as stated here by dear Tom http://bit.ly/2DMbZcY, and it just works fine.

Here is a new elearning content we've designed for our own library: http://bilgikurdu.s3.amazonaws.com/demo/Bes/story.html 

I'll be glad to help you sort it out if anyone still needs help.

 

Best of wishes to you all!

PS: Pls. do watch this new animation we've created for a customer as our new year wishes: https://youtu.be/cZFpU5AdmHE 

 

Prakash Menon

I need some help please. I have set up the AmazonS3 account and then tried to get the Cloudberry Explorer but only to realise that was for Windows and I am a Mac user for which Cloudberry doesnt have a version as yet. 

Can anyone please help guide me what do I do now? Thanks for your help in advance.