variable reference causing course to not play

Apr 08, 2019

Hi all, I hope someone can help me. I've been struggling with this for weeks. Articulate support is unable to help me - and trust me, those wonderful, smart, friendly, professional people have tried!!! We have tried everything from reinstalling all of my Articulate programs, a bunch of other techy stuff that I don’t understand (spent 3 hours on the phone with one guy trying a variety of things), deleting slides and rebuilding them. I’ve completely changed the way the course scores for the learner. Ugh, we/I have spent hours and hours and hours trying to figure out why it’s not working for me. It works for Articulate support … doesn’t work for me … it even works for someone else in my company. I’m reaching out to all of you gurus because maybe one of you has a workaround that I can try. It doesn't have to be the way I am trying it but I need for this to work.

Here's my issue: Each time I add a reference for a particular variable my course/game doesn't work properly - it freezes just before the slide that contains the variable reference (this happens both in Articulate Review and ScormCloud). If I remove the variable reference, it works fine. But I need the variable referenced so the learner knows their score at the end of the game. It is the most frustrating thing. Again, I’m looking for a workaround – if the way the score is shown ends up looking different than what I have, I’m ok with that. I just need the learner to see their final score. What's the point of a game if you don't know if you've won or lost?!

It's a game similar to Jeopardy - there is a main game slide (1.4) where the learner can select questions from categories - each question has a value attached to it. The question slides are all in scenes 2-6. There are 25 questions in total. 

When the learner clicks on a value button from slide 1.4 it takes them to a question slide – if they answer the question properly they go to the CORRECT FEEDBACK layer which contains a trigger to add the value for that particular question to a NUMBER variable called “1A_YOUR_SCORE”. For example, if the question is worth 600 points, and they answered correctly, a trigger on the CORRECT FEEDBACK layer says to add 600 to the variable called 1A_YOUR_SCORE.

(Note: It’s a weird variable name because I’ve actually deleted the original one and deleted all of the related triggers on each question slide; then I created a new variable and added back in the triggers…on each question slide).

 Once the learner is finished answering all 25 questions (or earlier if they want to bail out) they end up on a slide that shows them their score (1.3). Their score is the sum of all of the points they have collected when they answer the questions correctly … i.e. their score is the value of the variable called “1A_YOUR_SCORE”.

Theoretically this should work…right?! Am I missing something?

I have tried using the insert reference feature, I have tried typing it in manually %1A_YOUR_SCORE%. No go – no difference. I’ve tried so many things I don’t have time to go into them all.

I have tried using a Results Slide from the content library. I’ve built a slide from scratch and inserted the reference. Nothing works. This deliverable is now 2 months late because I have been fiddling with it for that long.

 Help! I've attached the file if you care to take a stab at this beast. 

By the way, the .story file is located locally on my desktop. :)

I do have the latest version of Storyline 360. I’m using the modern player.

Articulate support has ensured I have all of the basics covered. They even reviewed log files to see if there was some sort of corruption. Nada.

9 Replies
Zsolt Olah

Hi Cynthia,

I published your file and it works for me. What I suggest is trying is open your course in a browser and turn on the Developer window (right-click and select Inspect in Chrome). It should display errors (red) and warnings (yellow), and see if there's something suspicious. 

When you say it doesn't work for you but it works for someone else in the company, are you accessing the same published files on ScormCloud for example? 

Or, do you mean someone else can open up the .story files (like me) and publish it, and it works? In that case, does the publish version work for you? 


Cynthia Klassen

Hi Zsolt, Thanks for trying my file. Regarding your last question - I sent the .story file to my colleague and she is able to publish it from her computer. As are you. So it's obviously just me which is very strange.

Regarding your suggestion of opening the course in a browser ...  I did that. There are some red/pink and yellow/orange colored fonts. But it's greek to me. I'm not very techy and don't read HTML other than basic stuff. I've attached a screen shot if you feel like taking a look at it.

Dorota Langner

Hi Cynthia, were you able to resolve your issue? 

I'm having exactly the same problem now and can't find a solution to it :( When I add a reference to a score variable %ScoreBank% to a slide/layer, and then preview the course - the course freezes once I go to the slide and/or layer where this reference appears.

Let me know if someone was able to help you out.


Vincent Scoma

Hi Dorota,

Thank you for reaching out! 

I am sorry that you are running into a similar snag here. Cynthia may not be subscribed to this thread anymore, but it looks like they needed to remove that slide and layer for the course to work. 

If you are comfortable sharing your course with us, we are more than happy to help troubleshoot! You can share files with our team using this private upload link. We'll let you know our findings and will delete it after having a closer look!

Dorota Langner

Hi everyone, just an update in case someone has a similar issue. I was in touch with the Articulate support team and exchanged many emails with them.

Final solution was - I had been using Futura font as a %reference% font (I had downloaded it from Google fonts a while back). When I changed the font style to one of the standard ones, initially installed in my system (I've chosen Calibri) - the slides and reference variable worked for me! 

They also recommended to reinstall Futura Lt BT font into my system and see if it helps. I haven't tried that yet as I can easily stick to Calibri for a reference.

This discussion is closed. You can start a new discussion or contact Articulate Support.