Video Controls Black Line & Story Size

Hi Folks.  I recently discovered many posts about video controls and how to enable them.  This is a great feature that really helps us with showing the "time" in the seekbar, we use this sometime instead of the inherit SL player when we have just a video tutorial. 

We record videos at 1024 x 768, and then increase the Story size to keep my video at its recorded size, but make sure the video controls can be seen.  However, when doing that I seem to still get a bit of "black" right below the video and above the video control bar.   Any idea if its just not quite the right Story size or if there is something else I'm missing?

Thank you Heroes!

-Kristin

9 Replies
Kristin Shantz

Hey Ashley - of course, sorry about that! 

So, its eye sore in this one because the background is set to black....it was done so to fade/transition in from black at the start of the course.  Video is recorded at 1024x768, story size is 1024x799 to accommodate the video control.  I apparently don't have the patience to figure out the exact pixels needed!   I guess the real question is: Why is there a space in-between the video and the video control?  There is no space between the slide and the player window.

In a different vid, the story background is white so you can barely notice it, and it even gives it a nice little space.  In that case the easy answer is "use white" as the background color! :)

Thanks so much for your response!

Ashley Terwilliger

Hi Kristin, 

Thanks for sharing the image - based on what you share, those video controls don't look like the standard Storyline controls, are they connected to the video itself? The slides themselves and the player window are connected when you set the Story size - one changes with the other. The video, depending on how you've inserted it, can be included at a different size to allow you the most customization. I can't tell the exact pixels needed either, but it does look quite close! Is white as a background an option? Have you tried it on this video to see how it displays?

Kristin Shantz

Yes, I'll use white in the future if we use this formatting again because its not so off-putting.  Either way...there is still a space between the video and the control bar.  Those video controls are what I see when I click the "Show Video Controls" option with a video selected.   I can't submit the video via the forum, but I can upload via the support site.  Thanks for the reply Ashley.

Ashley Terwilliger

Hi Pam,

This discussion is quite a bit older, so it seems unlikely you're running into the same issue or even using the same version of Storyline. Let's start from the beginning with more details: 

  • What version and update of Storyline are you using? You can check by going to the "Help" Tab -> "About Articulate Storyline".
  • When you publish the course, what publishing option did you use: Web, LMS, etc.?
  • Did you upload the content to that environment or are you testing it locally? 
  • What browser(s) are you viewing the course in? 
  • Is the seekbar missing in all of your courses with video, or just this one?

Thanks for those details, and that'll help us continue troubleshooting the gap you're seeing! 

Pam Pappenheim

Hi Ashley,

Thanks for coming back to me.  It appears to be the same problem though.  I use Articulate 360, the browser is the most recent version of Chrome, I published to review and previewed the page in SL and the same thing happens. 

I haven't come across the problem before.  The two new factors are the modern player and the slide size 16:9.  The controls do play but you just can't see them unless you make the video really small on screen.

WORKAROUND.  I did find a way around it by switching off the video controls, switching on the seekbar in the player just for that slide and setting the video to play automatically.  I am working with this for now.

Crystal Horn

Hi Pam. Thanks for clarifying! There is a small space between the video controls and the actual video on the slide:

However, your image "published view" looked as though the video controls disappeared entirely. Is that what's happening?

  • If so, can you let me know what browser you're using to view the output?
  • Also, is the browser window very large? I'm curious if scaling the browser window down has any effect.