Video does not autoplay

I have a video that is set to play automatically on a timeline, which does not do so in the published "story_html5" output file.  It shows up in the timeline as an image and will play if clicked, but not automatically.  It autoplays like it should in preview in Storyline 2, and there are other videos in the module (though not on this slide/layer) that perform as they should.

15 Replies
Mike Tesh

I have this exact same problem constantly and I'm pulling my hair out. 
If the video is on a base layer it will play fine. If the video is on a layer other than base it will not, you need to click it to play it, if it even shows up at all. Sometimes it just works. Who knows why.

I really need a solution to this.  

Alyssa Gomez

Hey Mike,

That does sound frustrating! I'm glad you reached out. Let's see if we can narrow down the cause of this problem.

  • What version of Storyline are you using?
  • Does this problem happen when you preview the course, or after the course is published?
  • If the course is published, where did you host the output file before testing it?
Meaghan Lister

Is there a solution to this? We are encountering the same problem. I hate to have to strip out all of the videos and move them to separate slides --- I have several courses with this same problem.

Viewing the course in IE or Chrome yield the same results. It is an html5 output.

It previews normally in Storyline, and the triggers are set to autoplay.

Mike Tesh

Nope, just rebuilt the layer. 
For context, I didn't do the initial build. I was doing edits on a course someone else had built when I ran into this problem. So I don't know if the issue is in transferring the course from one machine to another or what. We both have the same version of Storyline however. Once I rebuilt the layer from scratch myself, it worked. Who knows why. 

Rais Omar

Hi everyone,

I'd like to share what I've done.

http://raisavenue.com/demo/ravtest02-SL2/story_html5.html (SL2)

http://raisavenue.com/demo/ravtest01/story_html5.html (SL3)

Total of 4 videos on a slide - 1 on main and 3 on layers. Each video layer plays automatically at start of the timeline.

Normally, for html5 versions, when you hit the replay button, all 4 videos will play - video and audio overlap.

I've managed to create a workaround. I'm still testing this. So any feedback is greatly appreciated.

Thank you.

Leslie McKerchie

Hi Mulfanizam,

This conversation is a bit dated and I'm not sure if Rais is still subscribed here.

Can you share some details about what you are experiencing so that we can help you here? If you have a .story project file, that will help us to investigate what's happening. You can share it publicly here, or send it to me privately by uploading it here. I'll delete it when I'm done troubleshooting.