Video encoding during publish

A .story file with 4 mp4 videos.  Usually, when I publish, the entire course publishes in about 30 seconds.

Occasionally, the publish dialog takes much longer and shows "encoding video ..." for each video.

Strange thing though, deleting the temp folder, closing Storyline and relaunching seems to have no bearing on whether we get the "Encoding mp4 video".

So... sometimes the course publishes in 30 seconds, other times 5 minutes, and it all boils down to the "Encoding video" surprise when I publish.

Any ideas?

Sam

10 Replies
Susi B

Hi Sam,

I work with mp4-files too, usually more than 4 and I can confirm that it takes more time with media files in it. Audio and video files in your project extend the output time. But I wouldn´t delete the temp files. Sometimes you publish your course, take a look through it and you find a mistake. Once there is a temp file for your project it (seems to me tho) publishes faster. But still it takes a lot more time with media files in it.

And little "pro" tip: Save your file before publishing, with our very big files (up to 1-2 gb) we have sometimes the issue of publishing the file and during this it closes spontaneously. But I think we really push storyline to its limits sometimes. :D

Greetings,

Susi

Sam Carter

There's a side issue that publishing with mp4 video will occasionally abort Storyline. The fix I found elsewhere in the forum was if you're running DropBox desktop, Pause it. Something about DropBox locking the output folder can cause Storyline to abort.

Still, I'd like to know why the publish time sometimes takes so much longer when the mp4s need to be encoded and not other times.

Sam

Ashley Terwilliger

Hi Dragos,

What version of Storyline are you using? 

Could you share more about the specs of your system? Also is anything else running while Storyline is trying to publish? Are you publishing to your local drive or a network/shared drive? 

If you'd like to share a copy of your .story file with us, we can also give it a try and test publishing it on our end. You can upload it using the “ADD ATTACHMENT” button at the bottom of the reply window.

If you’d prefer to not share in the public forums you’re always welcome to share with our Support Engineers here. They’re available 24/7 to assist! 

Leslie McKerchie

Hi Jason,

It's been a while since we've seen any conversation around this topic here.

It looks like Pausing Dropbox worked for a couple of users and we did not get a case from Dragos to take a closer look.

  • Are you consistently running into an issue?
  • Is it with all video files in all projects?
  • What version of Storyline are you using?