Video in SCORM not playing in Chrome using Mobile Data

Hi,

I have a situation whereby SCORM modules cease to continue when it arrives at a video (the video just sits on the screen and 'thinks').  It only happens when using Chrome and Mobile Data.

The video plays without issue when using Chrome and WiFi.

The video also plays without issue when using the native android 'Internet' browser, using WiFi and Mobile Data.

Other information that you may find helpful:

  • Samsung Galaxy S5 V5.0
  • Chrome V 49.0.2623.91
  • Mobile Data - have tried different service areas (from poor to great coverage areas) and different telco providers
  • The module is SCORM 1.2 and is only 4.3MB in size
  • The LMS is Totara V 2.9

To help determine whether it's an LMS issue, I uploaded the module to SCORM Cloud and the same problem happens.

I'm finding it strange that it only seems to be a problem when viewing via Chrome on Mobile Data.

Any ideas or suggestions?

Thanks, Michelle

18 Replies
Christie Pollick

Hi all,

I wanted to provide an update here, as Storyline 2 Update 8 was just released, and included a number of fixes which you can see in the release notes available here. The item you all may be particularly interested in is how it fixed the issue where videos wouldn't play in HTML5 output in Google Chrome 48 and later when viewed over a cellular connection on Android devices. You can download the latest update here, and after downloading and installing the latest update you’ll want to republish any existing content to ensure that the updates and fixes are applied.

Let us know if you have any questions, either here or by reaching out to our Support Engineers directly.

Michelle Lamont

Thank you, thank you, thank you!  What a great way to start Friday.

After downloading and installing the SL update - 2.8, I republished a couple of modules, uploaded them to our LMS and did some testing.  I had success with the republished modules in Chrome Beta V51.  Regarding Chrome V 50 and 49, I had success when viewing a republished module the first time, but the video wouldn't play when viewed a second time - the timeline progressed when it reached the MP4 as shown on the seekbar, but the video and audio didn't play .  I tried everything I could think of.

Anyway, we're planning to move forward with the beta version of Chrome.

Just thought I would share my experience. 

Thanks again

Michelle

Michelle Lamont

Hi Ashley,

I tried / performed the following (some things multiple times):

  • cleared the cache in Chrome from the 'beginning of time'
  • reloaded the republished courses in our LMS
  • When I republished I tried saving the SCORMs with a completely new name
  • recreated the entire activity in our LMS, i.e. not just save the new SCORM over the existing SCORM
  • even tried changed the player setting in Storyline to 'Never Resume'.

Happy to share the course with you.  Do you have a shared location where I can save a copy of it?

Thanks, Michelle

Ashley Terwilliger-Pollard

Hi Michelle,

You can upload it here to the forum thread by using the "Add Attachment" button to share the .story file and then link to the published output hosted on your LMS by including the hyperlink in your reply. 

If you need to share privately, please send it along to our Support Engineers here letting them know that you've republished with Update 8 and that you're still having difficulty with the videos when they play over a cellular connection on an Android device. That way we'll be able to get the link into the hands of a few team members who have that particular device. 

Vinod Dudeja

I tried to play the LMS course in some  web browsing software like safari , internet explorer.It is played well. But  it is not played in the google chrome in android phone . While i played published LMS in android phone using google chrome, audio file is not playing. And after that, video (MP4) is also not playing until and unless we don't refresh at once.

Please help me by  sending  the story line open file to solve out the same problem.

Leslie McKerchie

Hello Vinod!

Sorry to hear that you are having difficulty viewing your content on your mobile device in your LMS. What version of Storyline are you using?

Do you experience the same issue viewing if you upload the content to SCORM Cloud? This helps determine if the issue lies within the project or the LMS.

If you are able to replicate, please feel free to attach the .story file to your forum reply or you can share here privately.

Vinod Dudeja

Dear Leslie

We are using SL2 and publishing in SCORM 1.2 along with HTML5 output.

We have many MP4 videos which we are inserting on our slides in the
automatic run settings. The course works alright on desktops but we are
facing following issue when we access the courseware by using chrome
browser on android or safari on iOS

Android Devices
The inserted MP4 (which does not have any audio) does not play
automatically.
The audio inserted on the slide does not play
If we refresh the slide by clicking on the refresh button on the right side
of seek bar the video and audio start working.

iOS
The video starts in full screen mode and it covers the slide contents. If
we press the done button on the video it reduces its size and fits on the
slide but video stops playing to run it we need to click on the video but
it covers the content agan and runs in full screen mode.
There is no problem in automatic running of video or audio

Thanks and Regards
Vinod

Crystal Horn

Hello Vinod! 

For iOS devices, videos in your Storyline 2 courses always fill iPhone screens, even if they're running iOS 10 or later.  Have a look at this article for more information.

For Android, we have some specific issues that we've documented about how video and audio plays in Storyline 2 output on Android devices, and I'd like to try to match what you're seeing. 

  • Can you confirm what version of Chrome is being used?  
  • Is there any difference if you set the video to open in a new window?
  • Do you have video with muted sound and an audio file on the same slide?
  • For audio, a suggested workaround has been to move the audio down slightly on the timeline (by less than a second, for example).  Let me know if that produces any changes.

Thanks for the extra information!