Video not playing on iPad, just freezes at begining of clip

hi,

I have a course where all the content is in the video clip.  When published it works fine for some (pc and ipad), but for others it just freezes on the first frame of the video (which is the entire course).  The freezing only occurs on iPad.

I've taken the exact same video clip and had these same users access it outside of Storyline and it worked fine. I've also created a link within storyline (ie, youtube) to the video on an external site and it worked from there, but that's not an option it was just a test. 

There seems to be a loading issue with videos embedded within Storyline and low bandwidth users.  Users have said they see an incomplete pre loading image (the circle with the lines) before the video appears and then it freezes. 

Any suggestions?

14 Replies
Christine Hendrickson

Hi CK1,

You mentioned that some users are able to view it on the PC and iPad, but it's freezing with others on the iPad. For the users that are freezing, do you know if they have anything in common? What iOS version are they using and are they using, etc.?

Also, are you publishing for the Articulate Mobile Player app, or HTML5?

CK1 CK1

Thanks for the quick response.  Here are some more details.  It's driving me crazy.

  • I'm using iOS 6.1 and it works fine. The other users have iOS 6.1 as well and it's not working the same way.
  • They are all on iPad2 (which is what I have too). 
  • The user's bandwidth is between 25 Mbps and 5Mbps.  Both the highend and lowend experienced the same problem.
  • The exported video file (published) in the course is only 4megs.
  • I'm publishing to HTML5.  The mobile player wasn't an option for this.
Christine Hendrickson

Hi CK1,

Thanks for getting back to me! I know you've already checked a lot, but I just want to make sure that you haven't missed this. Since you're using HTML5, I'm wondering if this may be why it seems to be effecting different users. Can you have a couple of users experiencing this issue check and make sure that the option isn't enabled in Safari?

If that doesn't seem to do the trick, would you mind sending the files or link over to us, so we can check it out?

CK1 CK1

I checked with a couple of them and it's set to Off (like mine).  BTW, for the problematic users the video eventually plays sometimes when they click the refresh button in the seekbar. 

For others they have to wait over a few minutes and it eventually plays, whereas the same video file plays pretty quickly (a few seconds) when launched outside of Storyline.

I'll send you the file.   Thanks.

CK1 CK1

Here's another detail.

When running the screen, the seekbar indicator continues to advance even though the video clip that's at the start of the timeline doesn't play...the video just freezes.  Again, it's a situation where it seems like the video is not triggered to play, and/or get's hung up while loading or all of the above.  I've tried setting the video to 'play when clicked' and it's the same result.

Just to clarify, the video is only 2.7 megs.  I've tested it compressed at 2.2 megs and it's still the same result. 

Some of the users thought the seekbar was a 'loading bar' indicator btw.

Christine Hendrickson

Hi CK1,

I was able to find the case (#00319757 for my reference). 

So, the video is the only element of the course that's freezing? I'll be sure to make a note of this in the case, so our support staff can see it. I'm sure they'll check the thread, but I'll share it with them, just for troubleshooting purposes (maybe it will save some time!). 

I'll check in again soon, to see if we have any updates. Someone should be in contact with you soon.

Thanks again!

Christine Hendrickson

Good morning CK1. I hope you're doing well

I just wanted to stop by and check in with you on your case. I see that the last update on the case is from John, who sent a message to you on the 18th. Were you able to resolve the issue with the video with his suggestions? If not, please respond to the email so we can continue working with you.

If you haven't seen the email, please be sure to check your spam folders or filters. If you're still unable to find the email, just let me know, and I can try to send it to you again.

Thanks!

CK1 CK1

It still isn't resolved, but I'm glad you wrote because I wouldn't have looked in my spam folder for the response email otherwise. 

Basically, a possible solution was to re-encode the video using handbrake.  However, this didn't make sense to me because it's storyline that encodes the video when it's published.

CK1 CK1

Christine, thanks for the following up.

Yes, I tried that and it didn't change anything. Frankly, if it did work, we couldn't tell 100s-1000s of users to change their browser settings to accommodate one course.

However, this problem appeared to be loading and/or layered related. When I moved the video clip further down the timeline (approx 15 seconds) and didn't use layers to transition from one sequence to another it worked. I think there's something not right with how Storyline preloads assets and this showed that. I wish there was a way to control this more from the developer's side.

Anyway, thanks again for getting back to me.

Christine Hendrickson

Good morning Rachel,

First, you may want to make sure that the YouTube video isn't restricted:

Restricted YouTube videos will not play in Storyline

How long is the video and what are the rights for the video? If you have permission to use the video in your course, you could try using the screen recording option and record the original video into your Storyline project. 

Have you tested the HTML5 content on your PC, as well as the iPad? Does it play properly on your PC? 

Thanks!

Christine