Video playback issue in Storyline

Hi everybody - I've been a member for a year now and this is my first post :o)

I NEED HELP! My issue is with my video playback in published storyline files - I have spent hours searching previous threads to avoid this post but everything I have tried doesn't seem to work so I am reaching out....

In a nutshell my MP4's simply do not playback for my end user. PERIOD. I have tested my content via the following:

  • Published locally - works on my PC (fairly standard)
  • Published to network drives for end user via CD and Web formats (including & excluding HTLM5) - works for me but for nobody else?
  • Published to tempshare in various formats - works for me, nobody else? 
  • I have also tested the tempshare files on my home PC - worked fine
  • I also tested them via the mobile app - does not playback
  • I cannot test in the intended environment as we do not have our LMS yet (it's coming soon)

The MP4's are inserted as a file (not streamed or web objects).I have checked their files names so they follow articulate's guidlines regarding special characters and I have also checked that the end user has IE8 or above, adobe flash 10 or above and they all do. 

The one thing I have not checked is our company's server Mime settings. However, as it works for me whilst connected to our network I can't see this being the case. 

Am I missing something glaringly obvious ??? 

6 Replies
Christie Pollick

Hi, Chris, thanks for submitting your first post! :)

For good measure, could you please see the information below:

MP4 Videos Require a MIME Type on Your Server to Play Properly

If MP4 videos don't display when your Articulate content is hosted on a server, it's likely that the server isn't configured to play MP4 files.

Some servers don't have an associated MIME type to support MP4 files. To correct it, do the following on your server:

  1. Right-click the site in IIS and select Properties.
  2. Select the HTTP Headers Tab.
  3. Select File Types.
  4. Under the MIME Map section, select New Type.
  5. Type ".mp4" as the associated extension and "video/mpeg" as the content type.
  6. Click OK.

Your MP4 videos should now play when viewed from the server. If you use a hosting company to host your files, it's best to check with them about adding MP4 as a supported MIME type.

See also:

I hope that helps, and if issues persist and you would like us to take a closer look at your file, you are welcome to share it! Please use the ADD ATTACHMENT button in the bottom left corner of the reply box in the thread, and you can browse for the file from there. Please also note that if you reply via email, your attachment will not appear here in the thread. Thanks! :)

Chris Hartley

Thank you for the reply Christie

MIME Type could be an issue (but strange as if I am on the server I can see the video). I will contact my IT department today to eliminate or prove that theory.

In the mean time, here is a link to a tempshare file - a couple of videos I whacked into storyline to test. It works for me but for nobody else in the organisation and works from my home PC.

Could you let me know if you could see the videos playing back?

CD Published

WEB HTML published


Christie Pollick

Hi, Chris -- Thanks for providing your tempshare links, and like Bruce, I saw no issues with your videos, either. If it is only your users who cannot see the videos, but you are able, perhaps it could be a security setting with their internet browsers. Would it be possible for you to check into that also, please?

If issues persist, you are also welcome share your .story file with our Support Engineers using this form, and they may have other suggestions to assist.