79 Replies
Alyssa Gomez

Hi there Martin and Christoph,

Did you insert the video as an MP4 file, or did you add the video from a website? Website videos play independently of the slide and aren’t controlled by the timeline. Here's a sample file that includes a video inserted as MP4. I tested this link in Chrome v.56, and I was able to scrub forwards and backwards using the seekbar and the video control bar. Please let me know how that video behaves on your end.

If you're still seeing this issue, would you mind sharing your file with me so I can take a closer look?

Christoph Krieger

Dear Alyssa.

Your example works for me.

Here are screencasts (of 3 different modules) of IE11, Chrome and Firefox at my end with my examples (all videos inserted as mp4)

Firefox

https://360.articulate.com/review/content/f96ad60b-6c05-4c07-808d-80abdebca12e/review

Scrubbing does work, but progress in the bar not visible and the lenght of the video is shown NaN

Chrome

https://360.articulate.com/review/content/b46e436d-7aa4-42b3-a030-09a009e05722/review

Scrubbing does not work

IE11

https://360.articulate.com/review/content/6ecca40d-5492-4cd4-a1e8-532a8ec31b58/review

Scrubbing does not work

 

Also PLEASE rework the controls. It is not really usable on a mobile device.

 

Alyssa Gomez

Hi Christoph,

Thanks for sharing those videos. It looks as if you're viewing the published output locally. Have you tried uploading the zip file to its intended environment to test? For example, if you publish for Web, try uploading it to Tempshare to test. Another option is to publish to Articulate 360 and test there. 

Could you please try one of those options I mentioned and send me the link, so I can test it in a few browsers?

Also, thanks for your feedback on the usability of the video controls on a mobile device. Storyline 360 is evolving everyday, so we appreciate hearing ways we can improve our product for our users. Could you tell us more about what you would like to see in a Feature Request? 

Daniel Beatty

Hi There, 

Lots of great information here that helped me. I wanted to reach out because I was experiencing the issues as well - but my host server is Articulate Online. I have a 1 slide example attached. I took a video, added CC and stripped down the menu and nav controls so the output file (destined for Articulate Online) would look like a video player with no nav controls or menu, just a simple video playing with pause, CC, and restart features. I put a 100% transparent rectangle shape over the video in the SL timeline, so learners could not pause the video by interacting with the screen and so that the seekbar and video timeline stay in sync. Our goal is to have people view the URL generated from Articulate Online on computers and mobile so people can watch our training videos. 

This is the QA result of the file attached.

http://rsta.articulate-online.com/0080703420

Whats interesting is none of these issues arise in preview mode within the desktop SL 360 program. 

computer playback. Chrome
- When scrubbing video along seekbar, it resets video to beginning rather than taking you to that place in the video.
Mobile playback - Android
- When scrubbing video along seekbar, it resets rather than taking you to that place in the video.
-if you pause for too long on mobile, when you try to play the video again it simply stays paused or restarts at beginning of video (even though timeline stays in same place).
-once video ends, can't navigate to anywhere else in the video. 

General
- Any plans to make the seekbar available in landscape view when viewed in mobile?
- Understand from other threads the restart button (on mobile) was removed because it took up too much space. Like others, feel this could be returned without any additional visual issue. It also allows a slide to go to a "reset" state, which has implications tied to triggers that (1) have lost functionality with the import from SL2 into SL 360 and (2) affect overall course design and layout capabilities.

Ashley Terwilliger

Hi Daniel,

Thanks for the link to your sample course - nice video! I think I've seen that guy somewhere... 😉

Do you only see this odd playback when you've uploaded to Articulate Online? I saw you shared the published output folder - could I get a look at the .story file too? Just want to double check all your settings and test publish that same file to a web server.  That'll help us determine if it's an Articulate Online bug or a Storyline bug and get it to the right team.

The seekbar is available in landscape - you'll see the small circle in the top right hand corner. It's grey going white as the timeline progresses. I could see how that's a bit harder to click on and advance. 

I haven't heard other plans about the replay button - but love the feedback you shared here and would like to know a bit more about the impact you're seeing. Can you share that with our team as a Feature requests here

Daniel Beatty

Hi Ashley. 

For sure I should have included the .story file the first time around. Attached now. 

The seekbar you mention in landscape - and this is semantic - but I feel that's more a progress indicator. You say it's a bit harder to click on and advance. I dont see how you can click on this to advance it as it doesn't appear to have that feature. I keep tring to advance the video using this small circle and i keep pausing the video. I appreciate how including this small circle does help indicate a slide's progress, but it would serve well to add a seekbar.

The workaround for the seekbar misbehaving that I tried was to hide seekbar from player view in the player options, then reduce the screen size of the video so the player controls can display underneath, but then the video has borders and overall is smaller so is not an ideal solution. Also, the video player's seekbar appears to produce the same error as the slide player's seekbar - when you try to scrub through the video, it restarts the video instead.

http://rsta.articulate-online.com/0080730457

I have also attached this .story file for you

Thanks for the reply! 

PS - I'm also experiencing issues with RISE and its SCORM 1.2 output playing in a LMS. I read the forums, uploaded it to the SCORM Cloud LMS and it works fine, so working with my LMS admins on a solution to the issue. 

 

 

Ashley Terwilliger

Hi Daniel,

Thanks again for sharing - easy to see the same behavior in Chrome desktop and Android. I had it tested in an Android 5.02 and that version played the same as you saw and described. Another colleague reported it also didn't work in Android 6.0.1 on a Nexus 7, and with your device being even newer than that - it's consistent in Android. 

One thing though, is the issue is specific to hosting the course in Articulate Online. I published a copy of the course here to Tempshare just for testing, and that one worked normally regardless of device. Can you give that one a try for me too? 

I have reported it to my team as a possible software bug for Articulate Online. From here, I’ll meet with my team to take a closer look so we can determine next steps. Sometimes my team catches errors in my logic and we don’t have a bug after all. Of course, if that’s the case, I’ll let you know! 

Depending on priority and risk, some bugs can be fixed quickly, while others take longer to resolve. Here's more information on how we identify and tackle bugs.

I’ll let you know as soon as we have an update on this issue. Thanks so much again for letting us know about this, and I’m sorry if it’s slowing you down.

Daniel Beatty

OK thanks for the diagnosis. And thanks for the outline to fix the issue. Good luck! 

From our POV we are seeing this as a catch 22: We like the new player interface and CC options with SL360 but if it can't work on Articulate Online, we need to keep using SL2 for our SCORM wraps and keep using the old features. I would strongly encourage you to try and get the SCORM wrap output to your own solution (Articulate Online) working ASAP otherwise we will probably look to another LMS host for our content as we're more inclined to "keep up to date" with the software (SL360) rather than stay with SL2. 

Was there any confirmation from you guys during review on mobile that the landscape mode 'seekbar' doesn't have the built in functionality to skip and is really just a visual progress indication of where you are along a timeline? We really do see value in adding a seekbar and not relying on the workaround method I described. Happy to make a formal dev request, just want to make sure it isn't something that already exists and is simply buggy on my end bc of the AO hosting issue. From the Tempshare example, it appears it is not scrubbable.

 

I reviewed my same file uploaded to Tempshare and it appears all the issues are not present, like you described and so appears isolated to AO. 

Thanks! 

 

Ashley Terwilliger

Hi Daniel,

I certainly understand and it's good feedback for our team as well about how you may have to switch hosting solutions. I'll be sure to pass that along.

Yes, the seekbar in the landscape doesn't scrub and is more of a visual indicator. That's detailed here - sorry for any confusion! An official feature request is always a good idea and you can send those along  here. If you’re wondering what happens when you submit a feature request, here’s our process.

Jennifer Morgan

Hi Alyssa,

I'm using Storyline360.  I was having the same issue that as soon as I upload my file to my LMS, the video would restart any time I would rewind/fast forward.  I had another Articulate Staff help me as well as my LMS admin and they didn't run into the issue.  Come to find out, it was my company's firewall that was preventing me from scrubbing the video.  Ha! Just glad I was able to find a solution. I'm also leaving this post in case anyone else runs into this issue in the future. 

Thanks for your response!

 

Amy Adair-Gregory

Hi Alyssa!  Yes, utilizing Articulate 360 although some of the content was developed in previous versions of Storyline and "converted" to Storyline 360.  We use Google Chrome almost exclusively in all of our locations, we verify updated browser versions when fielding issues or conflict calls.  

Leslie McKerchie

Hi Amy! 

I took a look at your Breakfast quiz and did not experience any freezing. The score was reported, but was marked as incomplete as I did not make 100% as the result slide requires for completion.

Here is my published course if you'd like to take a look.

Also, I wanted to make sure that you are aware that you can change the reporting status if needed. Perhaps Passed/Failed is more what you are looking for?

Just let me know if I've totally missed the mark and what I can do to further assist :)

Jamila Breese

Jennifer, what was the solution you found? I think we are experiencing the same issue in our SABA LMS, from Chrome browsers. Embedded video (MP4) files, published to SCORM Package, have a behavior of starting over if a user tries to scrub in the seekbar, or uses the Pause button and then tries to continue using the Play button in the nav.