VIdeo quality problems in Storyline

Hi,

I have built a project in a program called  Videoscribe and now I want to export it as a video file and insert it into Storyline. The output I get from VS is a wmv and is of good qaulity as well as the quality of the video if I add it to Vimeo. But when I insert the video file into Storyline (or try to embedd the video from Viemo) the quality of the video gets much worse.


I have spent this entire work day trying to solve this issue and have tried multiple things:

1. To export the file as an avi from Videoscribe (givs worse quality)
2. To export the file as a mov from Videoscribe (takes more than 2 hours to export from VS so thats not an option)
3. Uploaded it so sho.com (their reccomended site for streaming)but with the same poor quality.
4. Converted the wmv to a mp4 before importing it to Storyline.
5. Uploaded the file to Vimeo and used both the URL link and embedded video option but with the same loss in quality.
6. And much more that I can't remember...

So the output from VS is good, but turns worse when inserted to SL. It really bothers me since the quality at e.g. Vimeo is great. Any suggestions? I feel like I have tried everything and I can't spend my whole work week on this issue :/


Regards,
Johanna Lafourcade

22 Replies
Alyssa Gomez

Hi Johanna! Really sorry you're having video trouble, and thanks so much for letting us know what you've already tried.

I see you shared your published Storyline files with us in a Support case. Would you also mind sharing the original (unpublished) Storyline file and the original video file so we can do some testing?

You can attach both of those files directly to your case by clicking this link. Thank you!

Brian Hendrix

Your MP4 video has to use the H.264 codec so that the compression options are available in Storyline. If you import an MP4 video using a different compression codec Storyline doesn't give you the compression options. Click on the frame of the video, select options, and see if the compression dropdown lets you select none.

Johanna Lafourcade

Hi Brian!

My video is a wmv and is re-formated to mp4 in Storyline. I have also converted it to mp4 and inserted it to Storyline. But where do I go to "click on the frame of the video" as you write? Do you mean to cliick on the video file in my folder structure or in Storyline? I can't find the options you are suggestion in any of these places :/

/Johanna

Katie Gokhshteyn

Hey, Mike. Welcome to the community!

Storyline doesn't support exporting videos that were previously imported at this time, but here's a nifty way of recovering a copy of the source file if you no longer have it:

  1. Publish your course for Web.
  2. When the Publish Successful window appears, click Open.
  3. Open the story_content folder. This is where you can find copies of your videos for this particular project. The file name for each video will start with video_. They won't have easily recognizable file names, so you may have to play each video to identify them.
Ryan Carlson

Hello,

I actually have the same issue described by the original author in this thread. Although, I do have a supported MP4 that I was able to select "none" for the compression settings. In addition to this, I have cranked the video quality publishing settings up. The video quality goes down dramatically after publishing. While previewing and the video is viewed in windows media player, the quality is dramatically different. 

Why would this be occurring? I seem to be following the Articulate guidelines for supportive videos, but there is a huge loss of quality. I've spent hours trying to troubleshoot, and media subject matter experts at my company have suggested the loss is occurring from the Articulate publishing.

Can someone please assist me?

Ashley Terwilliger

Hi Ryan,

What version of Storyline are you using? I'd make sure you're on the latest update of your version:

If you're still having issues with quality, I'd invite you to work directly with our Support Team to share the video and let them take a look and do some additional testing. 

Crystal Horn

Just an update for anyone following:  It looks like the issue was occurring in Internet Explorer when using a larger monitor size and the modern player, which always scales to fill the available space.  The video wasn't scaling up gracefully in that environment.

We are tracking a feature request to be able to lock the modern player at optimal size, so I'm adding this discussion to our report.  We can then update you here with any changes!

Ben Boozer

As a side note related to videos, I typically will use HandBrake to process videos before using them in any applications. I find that size can often be reduced with little to no loss of quality. I also use it to process videos that have been shot in portrait from a smartphone (so the don't rotate) and to crop videos. HandBrake

Ryan Carlson

Hi Crystal,

While I appreciate Articulate tracking the feature request you described, I do think it would help if both the classic and modern players had the ability to be responsive for end users without losing quality to video content. Changing the Modern player to support a "lock at optimal player size" isn't the ideal solution. The monitor size I tested with is a standard office monitor size . Many learners are not using their laptop monitors to view training material in my opinion.

I heavily support being able to use the "fill the available space" feature.  This enables the learner to not worry about adjusting resolution settings and allowing them to toggle their browser window sizes. Locking the player size can actually cut-off the navigational controls depending on what percentage display the learner is using on their computer.

While I appreciate that you have followed-up on this, I think that the responsive player should be compatible with the default browser on all Window Professional machines (IE). Typically, Articulate is very good about keeping up to date with this kind of thing.

Thank you,
Ryan