Videos won't play in published course on an ipad

We have had users of our LMS report that the scorm packages weren't displaying correctly or loading on ipads or iphones - even when using the ios mobile player app it wouldn't work. Currently the scorms were published with the ios/android mobile player box ticked.

I have since republished with this box unticked and the scorms now load and work correctly with the exception of videos. Videos play fine on the desktop but not on ipad. The button controls disappear altogether and even if I add a trigger button it still wont play.

I have reviewed the following help document which I saw listed on a similar discussion but to no success... https://articulate.com/support/article/videos-do-not-play-in-published-content

Any suggestions?!

Thanks

Hayley

32 Replies
Susi B

Hi Hayley,

which Storyline version do you use? Storyline 2, 3, 360? If you still use Storyline 2 it could be a flash based problem I think. We are currently upgrading our courses from SL2 to SL3/360 and everything works fine. I tested a course on Ipad and everything worked, even our videos. (We use html5 first with flash fallback.)

If you are using Storyline 3/360 with html5 output and it still doesn´t work, you might want to contact the Articulate Support and send them your file so they can take a look into it.

Greetings,

Susi

Alyssa Gomez

Hi there Hayley,

Have you tried testing the file in SCORM Cloud yet?  If so, do the videos play there? We generally compare the behavior in SCORM Cloud to your LMS experience to try to parse out file issues versus LMS issues.  We are happy to help you with that testing if you'd like to share your file!

Petronela Gdovinova

Hi Alyssa, 

I have similar problem - videos won't play correctly on iPad - html5 output. I used both S3 and S360 with the same result.

I have tested it with two videos in one slide - when I launch the course for the first time, the first video plays and second doesn't. When I access the course for the second time, none of the videos will play. What is wrong?

I experienced the same problems even on desktop in Safari, too, but now it works when I set the volume of videos to mute.  

I tried many workarounds with triggers, but without success.

I already contacted your support and sent them the file, but no success so far either.

Thank you for your help.

Best regards,
Petronela

Petronela Gdovinova

Hi again,

Just a small update:

I just tested the course on iPad again and now the first video didn't appear at all and the second video played correctly. This doesn't make any sense to me and I would really appreciate your help.

Thanks in advance!

Best regards,

Petronela

Caroline Mills

Hi Ashley/Petronela,

I am having similar problems the video should play automatically on my iPad (IOS 11) but when the course starts the bar moves at the bottom of the screen (which should play a short video) but the video does not play.  If I press the pause/play button the video plays. 

The same published storyline 3 file is behaving differently with a  problem running on IE, the first videos work perfect and halfway through it stops at a video.  I have googled this problem and it appears they're are plenty of people with the same problem but with no solutions.  I have tried rebuilding, moving videos up the timeline, publishing every which way, etc to know avail.  I have contacted Articulate and don't seem to be getting any solution there either.  Surely with so many people having this problem over a long period of time Articulate should have a solution.  At this point it is very frustrating and I am way behind my deadline for delivery.

Ashley Terwilliger

Thanks, Petronela and I see that you're working with Eloisa who was investigating your issues. I know you mentioned the auto play of the video too, and I wanted to share a reminder about the Safari issue too - as it may be connected to what you're experiencing. 

Caroline, I also saw you were working with Renato who has done some extensive testing and looped in our Senior Support Engineers as well. I see that most recently he shared some workarounds, and that it wasn't something he or our team could replicate yet on iOS 11.2.6. I'll let him know you're still stuck and we'll keep digging into the issue. 

Petronela Gdovinova

Hi Ashley and Caroline,

The last thing I heard from Eloisa is that you have logged the issue as a potential bug, but that does not help me at all, since I don't even know when to expect the problem to be fixed. Your link requires a login and I can't get in - was that a correct link? 

What are the workarounds you mentioned? Is there anything for S3 (ideally) or S360 except for telling our users to make adjustments in Safari? 

Thank you!

Caroline Mills

Hi Ashley/Petronela

Renato suggested a work around as follows take out the videos from my original story and import the remainder of the slides into a new story and then insert the videos again, unfortunately the work around did not work, I have uploaded the new file to Renato but still stuck.

 

 

Petronela Gdovinova

Hi Ashley and Caroline,

I haven't got any fix from the support and I tried using mov videos instead of mp4 (among many other things). It did work even on iPad on first two launches, but on the third launch one video played, but the other didn't.  Inconsistency of this behaviour is very frustrating. 

I have 2 short videos in my slide.

I reset the progress in the LMS, relaunched the course on iPad again and videos played correctly 5 out 7 times. After 7th attempt I can't get the second video play, first video plays correctly.

This is Storyline 3 HTML5 output.

What video format do you use?

Is there any audio in your video?

Was your project upgraded from older version? (let's say it was initially created in S2 and now there are issues in S3)

Did you use any animation for the video (for example fade in?) 

Caroline Mills

Hi Petronela /Ashley,

My videos are goanimate videos with audio and are mp4s.

I have a fade transition on each slide. It is very frustrating after all the work hope we find a solution soon.

Regards,

Caroline
An timpeallacht? - Smaoinigh air sula bpriontáileann tú an r-phost seo.
Please consider the Environment before printing this email.

* ** *** ** * ** *** ** * ** *** ** *
Tá an t-eolas sa ríomhphost seo agus in aon chomhad a ghabhann leis rúnda agus ceaptha le haghaidh úsáide an té nó an aonáin ar seoladh chuige iad agus na húsáide sin amháin.
Is tuairimí nó dearcthaí an údair amháin aon tuairimí nó dearcthaí ann, agus ní gá gurb ionann iad agus tuairimí nó dearcthaí ESB.
Má bhfuair tú an ríomhphost seo trí earráid, ar mhiste leat é sin a chur in iúl don seoltóir.
Scanann ESB ríomhphoist agus ceangaltáin le haghaidh víreas, ach ní ráthaíonn sé go bhfuil ceachtar díobh saor ó víreas agus ní glacann dliteanas ar bith as aon damáiste de dhroim víreas.
https://www.esb.ie/contact

This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed.
Any views or opinions presented are solely those of the author, and do not necessarily represent those of ESB.
If you have received this email in error please notify the sender.
Although ESB scans e-mail and attachments for viruses, it does not guarantee that either is virus-free and accepts no liability for any damage sustained as a result of viruses.
https://www.esb.ie/contact

* ** *** ** * ** *** ** * ** *** ** *

Ashley Terwilliger

Hi Petronela, 

Sorry about that link - I fixed it up and it's also visible here now. 

As Eloisa mentioned, we're not able to offer a timeframe in regards to a bug being fixed, but we'll let you know as soon as we can. I'm really sorry that's putting you in an uncomfortable spot with your course creation and clients. The same issue that Eloisa saw in your file is fixed in Storyline 360 (update 14 is the latest), so if you're able to use that and still see the behavior please let me know.

Alyssa Gomez

So sorry to hear that, Petronela. The bug should be fixed in Storyline 360, so I wouldn't expect the problem to happen there, even if the file was originally created in Storyline 3.

Are you on the latest update of Storyline 360? To check, click the Help tab, then click About Storyline. You should see 3.14.15225.0 in the bottom-right corner. 

Petronela Gdovinova

Hi Caroline,

I still haven't got a fix from the support, but I found that if I convert my videos in GIFs, they work properly. My videos are only "mood" background videos and have no audio, so GIF kind of works for me. It is, however, not ideal solution as the rest of the images and graphics in the course are in high quality and GIFs degrade the overall impression and the GIFs lag on older devices.

Andy Moorman

Hi, we have a SL3 course that is published Flash first/HTML5 fallback. Everything works on iPad except the opening video. It is set to autoplay without controls visible as a landing/splash animation. So iPad users are getting a 30-second blank screen before the Enter button appears. How do we fix this?

Crystal Horn

Hi Andy.  Can you let me know what version iOS your iPad is running?  I tested a small file with .mp4 video on the first slide set to play automatically, and it launched as expected on my iPad mini running iOS 11.3.  When it opened in Safari, I had the "play button."  Once I clicked the play button, the slide opened and the video played, followed by a button that appeared on screen after 7 seconds.

If you can share you .story file, or even your output link for testing, that would be great, too.