Vimeo Embed does not trigger / play - Did something change with IE / Chrome ... Was there an Update issue????

Hi All, I'm in Storyline 2, and I can not get a Vimeo streaming embed code to play in the published project nor does a separate very short MP4 uploaded into a layer trigger. For the Vimeo part, I am doing the exact same process of uploading a MP4 to Vimeo, grabbing the embed code with the iframe code included, I am using all the same saved Vimeo presets that have worked for two years, and the published course does not launch the Vimeo streaming video when played. I have tried everything. I have interested it at the start and the middle of the frame. I have included in-layer triggers to play media at the start or at a set time in the timeline, and inserted it without triggers. They iFrame shows up, the timeline indicator is playing, but the video does not stream and the iFrame is blank. The separate short uploaded clip plays within the timeline and when I preview the slides, but it does not play in the published project??????????? Was there an update or did IE / Chrome change something. Please help!! Thanks and Happy 4th!

8 Replies
Ashley Terwilliger-Pollard

Hi Bruce, 

Chrome recently changed how autoplay worked for videos or audio, and you can read a bit more about that here.  We included a fix in Update 13 of Storyline 2 to help ensure that your users would be able to play the courses once published and uploaded to your server/LMS. 

I haven't heard of any similar changes in IE11, but since it sounds like your course is playing as a whole and it's just the videos which are not appearing I don't think you're running into the issues with autoplay. 

Could you share a copy of your file or a link to that video so that we can take a look and do some testing around it?

Bruce Watkins

Hi Ashley, Thanks for getting back. I realized that I have changed email addresses, so my updates are behind. I sent a note to Support with my license key and new email and will get that taken care of ASAP.

Regarding IE – the course does play but the iframe does not launch as stated in my message. Here is the Vimeo embed code:

<iframe src="https://player.vimeo.com/video/278044388?autoplay=1&title=0&byline=0&portrait=0" width="1000" height="563" frameborder="0" webkitallowfullscreen mozallowfullscreen allowfullscreen></iframe>
<p>FLM 1 - Contiua+ Vid V2 20180628 1080 from <a href="https://vimeo.com/user74383820">Eddie Loussararian</a> on <a href="https://vimeo.com">Vimeo</a>.</p>

I have never submitted a story file for you to review, so please let me know where / how to upload that for your review. Thanks for your help. Bruce

Crystal Horn

Hi there, Bruce.  Thanks for sharing your embed code.  I wasn't able to preview the video within Storyline, but when I published a course using that video, it played as expected.  Check it out here and let me know if it plays for you in Chrome and IE.

You can attach your .story file here in the discussion using the Add Attachment button, and we'll be happy to have a look and try publishing your file.  I'm sorry this has been an issue for you, but we're here to help!

Bruce Watkins

Hi Crystal, sorry about the delay in getting back.  I have attached a .story file with the one slide in question (see the final comment below if you need to see the entire course).  FYI My client has Cornerstone on Demand.  When I publish the "web" version of the .story file for proofing purposes, the video works fine.  I see in your check in the link above it worked too.  However, when the client uploads the LMS published version of the same .story file (uploaded in the zip format as required by Cornerstone's LMS), everything works BUT the video on the slide 8.   I have tried this with the autoplay in the vimeo embed (see above) and variations with and  without a media play trigger in the slide 8 layer.  While the video in some configurations either works or doesn't work in the Web published file, none of the versions worked in the LMS file when uploaded to Cornerstone.  

The client is frustrated, and I have sunk a lot of time into this.  Any help would be greatly appreciated!  Thanks, BW 

BTW - Quick question ... when I post a .story file in a reply like this it is a private message or is it just sitting in the public forum?  My client does not want full courses and some specific content shared publicly.  I posted another question in the board asking if when I attach a .story file to a discussion post, is the .story public and accessible. If it is public, I wanted to know how to send a file directly to an Articulate tech support person?   Thanks.

 

Bruce Watkins

HI Phil. Thanks for the reply. I produced several courses with embedded vimeo autoplay links in the past that all played perfectly. For those past courses I used a version of SL2 that had not been updated in a year and a half. I recently updated my SL2 to the latest version before I produced this last course and the new course produced with the update has never worked.

I looked at the old coursed that worked and I noticed that I did not use an articulate media play trigger in the layer layer (there was only one layer).   I have tried it both ways and the client reports with and without the in-layer media play trigger  do not work.   

IMPORTANT - The only thing I DID notice that was different in the old course was the option in the player "other" settings had the box CHECKED for "When running in LMS, ignore flash cookies".   It DID NOT have this checked in the new saved version (but I think I published a version of the new course with that checked and it did not work  either..   All other setting appear to be the same.  Could this be the issue????

Phil Mayor

I don’t think it is the flash cookie I would suspect it is playing the html5 version.

Have you tried taking the embed off a layer and playing on the base layer. I recall an issue with videos on layers.

I did download and convert it to 360 and it played fine. So may be an SL2 issue.

Sent from my iPhone

Ashley Terwilliger-Pollard

Hi Bruce, 

First, I wanted to let you know anything shared here in ELH is public to others in the community, including if you respond to the email notification you receive about other comments/responses here. If you need to share things privately with our Support team, you can start a case, and that's a private way to share files and content. 

If you need to remove the file from ELH, look for the Edit option below your response.  Here’s a quick Peek video if you need help.

It sounds like these video embeds are only having problems when all the following conditions are met: 

  • Using the latest update of Storyline 2, Update 13
  • Publish for LMS and hosted in Cornerstone

Have you reached out to your Cornerstone team to see if they were aware of anything that could impact this? Also, have you checked a few different browsers to see if it's behaving differently there?