Vimeo videos not loading

HI...

I'm trying to use the vimeo videos in Storyline. If a use a Youtube video it works fine but when i put a video video (with the embed code copied from vimeo) in the preview does not load and online, after a while, the video objects shows a "page not found" or similar.

May be the embed code is not fine to the articulate or something like that?

Any suggestions to solve this?

Thanks

31 Replies
Juanjo Haro

Hi, thanks for help.

I've tested with different videos and that's whhat happens: the video is not loaded even if I use the video from Michael

And here is the code directly from video share button

And this is what I see when tested, the youtube video loads ok, vimeo does not

You can see this in the story file

Ashley Terwilliger

Hi Juanjo,

I published your .story file and once I did so the embedded Vimeo video played, although I do see the [collapse]original message that is there. I would try to insert it again, and ensure that you're testing the published version. Additionally, have you looked at setting a poster frame for the video so that there is any additional image prior to the video starting? 

[/collapse]
Juanjo Haro

Hi... I've tested the videos with poster frame and what happens is: the youtube video plays when i click on it and the vimeo video does not play on click, simple the poster frame appears and you must click again on the video to play it.

Additionally, in html5, the youtube video does not play at all, neither in the ipad and the vimeo scales down when you click on it on the ipad and it hangs the 99% of times.

Ashley Terwilliger

Hi Rob,

I looked into this again today, and it seems that our QA team is aware of a known issue where Vimeo videos are not playing when embedded using the embed code, but it is not affecting Youtube videos.  Is that how you're inserting your videos?  Are you able to try the method where you insert it as a web object (these directions are for Youtube, but you'd follow the same method with the exception of the parameters)?

Gail Hawkins

Hey there

Fairly new to storyline but not to technology:) I have tried all the methods I can find to embed a vimeo video in my storyline project and keep coming up with nothing. I can embed as web object and can test the link (successful) but when I publish, it's a blank slide - zip, zero, nothin.

When I embed as a video from website, I get a player on screen for about one second, then it goes blank, when I publish, it's also blank. I've tried various random videos - same issue. (preview shows same issue as Juanjo above)

It seems others are having some success so I must be doing something wrong here - any ideas, thoughts?

Help is appreciated.

Christine Hendrickson

Hi there Gail and welcome to the community!

First, can you tell us how you're viewing the published presentation, please? Are you viewing the published output files locally, or are you uploading to a web server or LMS?

If you're viewing your published files locally, this may be the problem with the Vimeo videos. If you view a published Storyline presentation on your local hard drive or send it to someone else to view on their local hard drive, you'll encounter security restrictions from the computer, web browser, Flash Player, and network that'll cause various features of your content to fail.

To properly test your published content and share it with others, upload it to the environment for which it was published. Please review the article below for more information:

Publishing and Sharing Articulate Storyline Content

If you do not have access to a web server or LMS for testing, you could try using SCORM Cloud.

Another option would be to use our Tempshare server. Just keep in mind that this server is only available for testing content - it is not officially supported by Articulate and all content will be removed automatically after 10 days.

You're always welcome to try out Articulate Online, as well - it's available for a free 30 day trial.

If you're uploading to a web server or LMS, please try clearing your browser cache. If that doesn't help, try viewing the project in a different web browser. 

Here are the download links for the most popular browsers, other than the ones you mentioned, just in case you don't have them:

Let me know if you still have trouble viewing your content after trying the suggestions above.

Thanks!

Richard Sharples

Hi

I appear to be having an issue with Vimeo. Videos are not playing in Storyline 2 published output when embed as 'video from website'. Seems to be showing a 404 error. Any ideas on a way to resolve? Video are set up as click to play but nothing is appearing.

Click open/watch/ then click any place holder image. http://goo.gl/PwVMcG 

Michael Hinze

@Richard, I wonder if it has something to do with your content running off GoogleDrive. See this story project here: http://dev.keypointlearn.com/xcl73_SL2/Christmas2014/EN/story.html It's hosted on my website and it is full of Vimeo videos, they all play fine. I would try to upload my content to some other server (or something like TempShare) to see if the problem persists.