Vimeo web object not playing

May 18, 2018

I am trying to use vimeo videos in my courses as web objects. These work locally when I test them, both the flash and HTML5 versions. However when I publish to my LMS I get a white screen on those slides and an error message in the upper right corner of Chrome. It says "This page is trying to run scripts from unauthenticated sources". I then click to load the unsafe scripts and get an error message from the LMS stating error initializing communications with the LMS. Press OK to view debug information.

Has anyone ran into this issue? I tried this on the scorm cloud and see the same results.

2 Replies
Joe Tansengco


Looks like the content is not being allowed through the network of both LMS and SCORM Cloud since you mentioned that this worked locally. LMS and SCORM Cloud providers have their own network policies that may be preventing the scripts embedded in your page to execute properly. I would troubleshoot this by using other video hosting services such as Youtube just to see if you can isolate this with Vimeo. If both Vimeo and Youtube do not work, then this may be due to something else, or the LMS network blocking video hosting services entirely. 

Alternatively, you can refer to a similar discussion here. Hope this helps!



This discussion is closed. You can start a new discussion or contact Articulate Support.