Volume Slider is Under Content (Safari)

Testing content today for a launch...got a report (and included screenshot) that the volume control was underneath the slide content. This isn't happening on my computer (PC, using Chrome) and there aren't any reports of similar issues here. 

I believe this user was on a Mac system, using Safari - but I am waiting back for confirmation.

Any ideas? I don't really even know where to start since it's basically the vanilla Storyline Player (with colors changed). 


Volume slider behind content

18 Replies
Pete Lewis

Hello! 

The user (one of our testers) was using Safari on a Mac. I'll check with him to see if he's still having the issue (the exported project was overwritten shortly before I found out about the glitch - so it's a new version up on our LMS currently) on the off-chance that it was an error in that one export process. I'll check with the clients to see about sharing the story file.

Thank you!

Leslie McKerchie

Hello Chiara,

This conversation is a bit dated, but we would love to understand what you are experiencing in your course.

What version of Storyline are you using?

With your permission, I'd like to take a look at your project file to investigate what's happening. You can share it publicly here, or send it to me privately by uploading it here. I'll delete it when I'm done troubleshooting.

Alyssa Gomez

Hey Calvin!

We were seeing the same issue on our end, and we've since fixed this issue in a recent update of Storyline 360.

Are you on the latest update of Storyline 360? To check, click the Help tab, then click About Storyline. You should see 3.26.18364.0 in the bottom-right corner. 

If you find you need to update your software,  just launch the Articulate 360 desktop app on your computer and click the Update button for Storyline 360. Details here.

Calvin Lo

The funny thing is it doesn't happen to everyone. We have a couple of guys, one in Windows, another in Mac... both using latest Chrome, and it's working fine on their end.  

I have the Storyline before that update. will test it with the new update.

UPDATE: I didn't update my Storyline and republished an old course. It solved the volume slider issue. I'm using Windows 10 + Chrome

However, it's weirder than I thought. I accessed an old course in our LMS (2015 so we could've used SL1 or SL2). One module (SCORM package), the slider issue is present, but on the next one, it's working fine. In my teammate's laptop (Mac + Chrome) there's no issue with the volume slider.

I tracked down the SCORM packages, extract them in my local drive, opened them in my browser, and both modules have the slider issue. 

To conclude, we don't know what's causing it. It's very erratic. Even in old SL, it would work, or it might not. Even in new SL, sometimes it works, sometimes it doesn't. Sometimes it works in Mac+Chrome, sometimes it doesn't. Same with Win+Chrome.

Dumbfounded here.

Alyssa Gomez

Hey Calvin,

You're likely seeing differences in each course due to the window size. If the window is smaller, the volume slider won't be hidden. But if you increase the size of that window, you'll notice the volume slider is hidden once the player reaches a larger dimension.

Ultimately, you'll want to republish your course with Update 26 to prevent this from happening in any player or window size. Let me know if you have questions about that!

Calvin Lo

looks like the new SL didn't fix this problem for us. but it is the window size... or to be more specific, the resolution of your display. scaling is messing things up. If you view it in a wide monitor or a wide display, this issue will show up. 
Zooming in will solve the problem. 
We also noticed that in Windows 10 -

- 1920 x 1080 resolution at 100% scaling the issue shows up
- 1920 x 1080 at 150% scaling, it fixes the issue

Locking the player at optimal size didn't solve this problem.

Update: Looks like locking the player at optimal size worked but make sure you clear your cache when testing.

Alyssa Gomez

Hey, Calvin. Thanks for the update, and I'm sorry to hear you're hitting this problem again.

I created a simple slide in Storyline 360 Update 26 with an image covering the background. The player is set to scale to fill the browser window.

Do you notice that the volume slider is hidden behind the image when you view this link?

Do you have a link you can share with me so I can test your file on my side?

Calvin Lo

hi alyssa, revisiting this. do you know what's causing it? why did the problem started showing up recently? do we have to republish all of our old courses with the latest storyline?

Just got another report of an old course (2017), aside from the volume, some elements on screen are not showing up. again it's happening to some people while others are seeing it ok. for example, using chrome on my office laptop i'm seeing the problem, but it's working fine on my home laptop using chrome. both laptop are on windows 10.

i made a video of a sample bug (not the volume slider but a text onscreen). When i zoom in to 110% i can see the text but below that, it disappears. again, this happened on my office laptop using chrome.   

Alyssa Gomez

Hi Calvin,

So sorry you're still dealing with this. We've seen two similar issues in Storyline 360, so let's tackle each one.

  • Slide objects with animation would sometimes be hidden in the published output. This bug crept up with a Chrome update, and we resolved it in a previous update of Storyline 360. If you're still seeing this behavior in a file, you'll want to republish that file with the most recent version of Storyline 360.
  • The volume slider sometimes appears behind slide content. This bug has been reported to us again recently, so we've opened it back up for investigation. I'll tag this discussion to be updated as we find out new information.

We're happy to give you a second pair of eyes on your file, if you'd like. You can send the file to us privately here, and we'll delete it when we're done troubleshooting. 

Alyssa Gomez

Hi KC,

We're still seeing an issue in Storyline 360 where the volume slider appears behind the slide content in Safari and Chrome on Windows. Specifically, this happens when player size is set to Scale player to fill browser window.

Does that sound like what you're seeing? What web browser were you using when you noticed this problem?

Dustin Bauman

Yes, I can confirm this is still happening, just updated to Build 3.31.19951.0 and the volume slider in Chrome is still a problem, if you scale the window size down it appears and as you scale the window to full screen view it cuts off the upper half of the slider, you can still use it though. This does not happen in Edge or Firefox. This happens with all project files, so not just one, and this doesn't happen in the preview panel.

Attached screen shots show, small window, medium window size and large window size - when it disappears.

Lauren Connelly

Hi Dustin!

Thanks for providing that image and confirming this issue is still occurring.

From previous cases, it looks like select animations cause this issue. Are you using the same animation in every course?

It would be helpful to take a look at your file. You can do that by sharing it here in this discussion by using the "Add Attachment" button. Or if you would prefer to share the course privately, use this link to share with our Support Engineers.