76 Replies
Leslie Shapiro

Yes, Evelyn, I'm with you. 

This javascript fix worked perfectly before, but in my latest publish the launch screen is back!  I suspect that maybe something changed in the latest Storyline upgrade/patch?  Can anyone from Articulate comment on whether that is the case?  I have double-checked my storyline.js file multiple times and the same text (Steve's solution above) is there. No idea why it suddenly isn't doing what it did before. 

Ashley Terwilliger

Hi Evelyn and Leslie,

I haven't heard of any other problems with users working with Javascript since updating to Storyline update 4, but if your Storyline file is not behaving as before there are a few things you'd want to check:

  • Work on your local drive (your C: drive).Working on a network drive or a USB drive can cause erratic behavior, includingfile corruption, loss of audio, and other unexpected behavior. 
  • You should also make sure the directory pathto your project files and your published output is less than 260 characters(for example C:\Articulate).
  • Avoid using special characters, accents orsymbols in your file names.
  • Conduct a repair of Storyline to resolve any issues that may have occurred during the update. 

If you're still having difficulty after checking those items, you may want to share your .story file here so that the community can take a look at the Javascript code you've set up, as we don't provide support for Javascript coding, but if you think there is something that occurred in update 4, we're happy to take a look at all your execute Javascript triggers. 

Steve Flowers

Hi Leon,

If you uncheck "Use Articulate Mobile Player..." it'll prevent the interstitial player screen from popping up. You'll still get a play button overlay but it's less obtrusive. Mobile goes straight to story_html5 now. There is an amplaunch.html file for android but everything seems to be handled in story and story_html5 for iOS.

Leon Geschwind

Sorry just saw this reply now. I have unchecked the Articulate Mobile Player and am only outputting in html5. The play button still pops up... is there anyway of modifying the code to get rid of that play button so it just launches directly to opening screen in SL2?

Thanks in advance,
Leon

Steve Flowers

Hi David - 

In SL1, there was a JavaScript hack to bypass the interstitial screen. In SL2, it's a little easier. 

At the end of your story_html5.html file add this within the end script:

document.addEventListener("DOMNodeInserted", function(event) {
if($(event.target)[0].className=="launch_interstitial"){
player.revealPostInterstitial();
}
});

This waits for that overlay to load and automatically closes it and initializes for iOS.

 

**Tested this in an emulator and it closes OK. But it resizes the slide as part of the process. Haven't tested on an actual iPad yet. It might cause sizing issues. YMMV.

Ashley Terwilliger

Hi Leon,

Hm, I looked on our end (by taking an educated guess at what your email address may contain) and I don't see anything wrong in our system. It appears that the emails are going through without any notices of bouncing or similar. Is it possible your company is blocking the emails or that the articulate domain needs to be whitelisted or something similar? 

Ashley Terwilliger

Hi Leon,

Notifications from the forums will come from heroes@articulate.com (our other addresses that you may want to put on the list include support@articulate.com, success@articulate.com or that domain in general.) 

Are you able to reach out to your IT team for assistance? Based on the email address I saw for you, I suspect it's higher than average security...or at least I would hope so. :-)