What is the function of the "Object" setting in a key press trigger

Nov 05, 2014

Apologies if this is already documented somewhere (please kindly point me there if you know...)

I'm using custom navigation in a project where the navigation buttons live on the master slide and clicks trigger a variable to toggle. The actual jumps are then managed with "when variable changes" triggers on the slides themselves. Works perfectly.

Then I wanted to augment the basic navigation by assigning key strokes (right key for forward, left for back, up for menu/home) so someone using the project in a live event doesn't have to spend mental juice to click on small buttons. So I added key press triggers to toggle my navigation variables on the master slide.

And got stumped when I found a setting "object" at the bottom of the trigger dialog. What is that setting for? How to use it? Why is it there at all? I should be able to just hit a button and Storyline do something independently of any objects, no?

I tried attaching the key press to the same buttons I'm using for the click triggers and alternatively assigning them to the slide.

Neither works. Or rather sometimes it does and sometimes it doesn't. Closest to a regularity I've found is that it is more likely to work when I just arrived at a slide using the click, but not when I get to a slide using the key press. And most of the time I can go backwards with the key when I got to a slide with a key, but not all the time.

This is all in storyline 2.

Am I missing something? Please kindly help!

4 Replies
Ashley Terwilliger-Pollard

Hi Kai,

I'm able to add a "click" trigger to a slide, and the object I assign it to is just the slide itself (doesn't have to be an actual object on the slide). I cannot leave it unassigned, as that doesn't allow the trigger to be created. 

If you're having difficulty with the trigger creation, are you able to share a copy of the .story file here with us? 

Kai R

Dear Mike, dear Ashley :-)

thanks for your kind responses.

Unfortunately I can't share the project as it is around 200MB in size and the content is confidential :-(

The weird behaviour I've seen is that the "keypress" trigger does work sometimes but neither always nor always not.

I was wondering whether there's any similar experience or whether this is a known issue.

@Mike: I'll keep experimenting with the assumption that the OBJECT setting is superfluous. Thanks for the insight!

If any further insights manifest, please give a shout!


Ashley Terwilliger-Pollard

Hi Kai,

You mentioned it worked "sometimes" - are you able to see any pattern to when that occurs? Such as particular browsers, when testing it locally, etc.? If you're not able to share the actual file here you could try to share a sample mock up that has the same behavior, or you can also send the file along to me privately here, (please include a description in that upload form and let me know here once you submit it so that I can ensure I grab the file) and you're always welcome to connect with our Support engineers. 

This discussion is closed. You can start a new discussion or contact Articulate Support.