What we’re doing to help you update your courses for browser auto-play settings (updated 12/06/2018)

Recently some common browsers, including Chrome and Safari, have started blocking auto-play of audio and video content on the sites you visit. That includes audio and video in e-learning courses that are hosted online.

That means that audio or video on the first slide of a course will not automatically play. It also means that videos and audio won’t work when learners suspend a course and restart on a slide that contains audio or video. Your content won’t be affected by this issue unless videos and audio are set to play automatically.

Unfortunately there’s nothing you can do to override the browser’s settings. That’s why we released updates for Storyline 360, Studio 360, Storyline 3, and Storyline 2 to automatically detect when this occurs and present the learner with a play button overlay. That user interaction is what the browser needs in order to play the audio or video. If your courses have a required user interaction on the first slide and no media, you may not need to republish to have the media autoplay.

We’re working on a content updater for Storyline 360, Studio 360, Storyline 3, Storyline 2 and Studio '13 that’ll let you mass update all your courses. In the meantime, you’ll need to republish your courses one at a time to fix this issue.

We know this is super frustrating, and we’re so sorry for the trouble. We’ll keep you posted on our progress.

UPDATE (12/06/2018): We've now created a tool that lets you mass update existing courses without republishing them. Currently, the updater works on Storyline 360, Storyline 3, Studio 360, Storyline 2, and Studio '13 courses. See this article for details!

157 Replies
Leslie McKerchie

Hey Jen,

Glad you were able to get the download to work for you. I appreciate the update.

At this time, yes, files will need to be republished. We’re working on a tool that’ll let you mass update existing courses without republishing them. 

If you haven't published your Storyline 360 projects and are staying up-to-date, you should be good to go :)

Alyssa Gomez

Hi, Jen -- If you published your Storyline 360 files in the last few days, you shouldn't need to republish with the recent update, unless you encountered one of the bugs that we fixed in the update. 

Hey, Joe -- We're still working on that updater tool. As soon as it's ready, we'll notify everyone here. You'll receive an email since you're subscribed to this thread.

Hello, Teresa -- We added support for Google’s new audio policy in the recent updates for Storyline 2 and Storyline 3. If you haven't done so already, you'll want to install the latest update of your version of Storyline to ensure your projects work when Google stops autoplaying audio in Chrome 70 in October. We’re also working on a tool that’ll let you mass update existing courses without republishing them...stay tuned for details!

Leslie McKerchie

Oh my goodness Marie! I'm so glad you chimed back in as it looks like we did not get back to you. Sorry about that!

Thanks for sharing the Image, video displaying the issue, and your .story file for us to look at.

Looks like you're up to date, but when I publish your course and upload to SCORM Cloud I do not experience an issue with the audio. Can you take a look at my published file here?

Leslie McKerchie

Hey Marie,

Thanks for popping back in to let me know how that link worked for you. If that link is playing correctly for you, then it may not be the browser. Although I did notice that my Chrome was a slightly different version (Version 67.0.3396.99).

Have you uploaded a newly published file to your LMS or are you viewing an older version perhaps?

If you publish and upload your output file to SCORM Cloud, do you experience the same issue or is the issue only occurring in your LMS?

Marie DesJardin

Hi, Leslie. My last 15 modules are brand-spanking new with the latest SL3 and Chrome versions I gave you. 

I uploaded 2 random (new, current) files to the SCORM cloud, and both played correctly. 

* My Chrome browser is as current as auto-update will get it (we are running the identical version,  67.0.3396.99).

* This problem occurs both for files that I play locally during testing, and on the LMS

* Users have reported this problem

Do you have any advice for me about handling the silent-audio page 1 problem, given that I am publishing in the most current version available? Our users use mostly IE (various versions set by our IT dept) and Chrome. 

Thank you!

Margaret Crawford

Is there alt text or screen reader verbiage to adjust how the play button that appears in Chrome is announced by JAWS? Right now, when I navigate to it with a keyboard, JAWS just says "Button. To activate press space bar." so it not descriptive enough to tell the user what the button is actually for. I do not find it in any of the Text Labels fields.

Ashley Terwilliger

Hi Marie,

To confirm, the courses on SCORM Cloud open normally and play the audio automatically but within your LMS the course opens without audio? Do you see the play button pop up prior to starting the course? 

Also, is the audio on the first slide or later into the course? 

If you're also seeing this issue in IE when viewing your course in the LMS, I'd also suggest reaching out to your LMS admin as there may be something blocking access on their end. 

Ashley Terwilliger

Hi Margaret,

I wanted to connect this with the other discussion where I recently answered you.  The play button that is now included to deal with the changes for browsers not allowing media to autoplay isn't something that can be edited at this time, so there isn't a way to change the alt text associated. 

Marie DesJardin

Hi, Ashley! I appreciate you getting back to me. 

* As I recorded in the video I sent to Articulate, the first slide contains audio. Chrome does not autoplay the audio, and no Play button appears. I need to click the slide to hear audio on slide 1.

* The first slide plays normally in IE 11 (our company-pushed browser)

* The problem is not specific to the LMS. I cannot play my SL3 stories locally in Chrome, separately or in Preview mode, without experiencing the problem I video-recorded for you.

* The problem is not resolved in the LMS, because some of my reviewers and students have reported it. I know that two of them were using Chrome.

We have 500 students taking my new, just-published course. Very few report the audio problem, so I expect Chrome users (not default IE users) are experiencing it.

I will attach my video again so you can see the exact behavior. Thank you!

Ashley Terwilliger

Thanks, Marie for sharing the video again.

Am I correct in that:

  • your published courses played correctly when uploaded to SCORM Cloud (by you or Leslie) and viewed in IE11 and Chrome? 
  • that the courses you've uploaded into your LMS also play correctly in IE11? 
  • that it's strictly Chrome playback, either locally or from your LMS where the users can't hear audio? 
    • When the audio is not playing, you also don't see the play button at the start in your LMS?

If all of those things are correct it seems like you're running into two things:

  1. Local playback of the content isn't something we recommend, especially in Chrome due to some of their security restrictions. This article lays it out in a bit more detail. 
  2. If the play button is not appearing, and you published it on the latest update, I'd check that you're also not viewing a cached copy of your content in the LMS. An easy way to confirm this is open the link in a Chrome incognito window. That should load it again and show you the newest version. 
    If the play button is still not there and/or learners are not hearing audio - I'd suggest checking with your LMS team. They'll be your best resource for figuring out the issue there since it did work in another environment. 

If you need anything else, or I'm misreading any of your earlier posts just let me know! 

Marie DesJardin

Hi, Ashley. Thanks for getting back to me. 

Your assumptions are correct. This is a Chrome-only problem.

- the article you linked to refers to Flash; I'm using HTML5 as my preferred format. I published in HTML5 only and repeated the test; same result (no button, no audio)

- the LMS cannot affect my local playback of files on my own computer. Our LMS has plenty of problems, but I don't believe this is one of them. I think it's Chrome.

- I opened an incognito window. Exact same behavior that you saw in my video.

I have never seen a Play button on Chrome. I looked through all the publishing and player options, and can't see what I could be doing differently. I would say it's my local setup -- but we have those other Chrome users who see the same behavior.

I appreciate you working with me on this. Any other ideas? Cheers.  

Margaret Crawford

Marie, I don't have a solution but I wanted to let you know troubleshooting this with our courses has been frustrating because not all of us get the play button either. We attributed it to the MEI (media engagement index) so Chrome "learned" that we wanted media to play from our LMS and other sites (like SCORM Cloud). It is perplexing that you would have to click the seekbar to unmute the audio since it looks like the timeline has started (or does it work if you click anywhere?). Though not your specific problem, we have had some funny behavior with our SL360 courses in Chrome lately (including major lag for media/fine in IE and media playing when it shouldn't) so I'm no help other than to commiserate. [My colleague and I have submitted support tickets for these.]

Tess Richardson

Marie, just jumping in here to say that I have been closely following your discussion and issue. I've experienced something exactly like what you describe in Chrome with the timeline advancing, but audio not working on the first slide unless you click in the seek bar (and no Chrome-supplied "play" button appears either).

I simply have not had time to do the kind of excellent troubleshooting you've done, so I've not been able to pin down the pertinent variables yet. Just wanted to let you know you're not alone! :)

Marie DesJardin

Thank you, Tess and Margaret! I'm in the startup phase of a new big project, so have some time to fiddle with this. My laptop is running Windows 7 -- could that be a factor? 

> It is perplexing that you would have to click the seekbar to unmute the audio since it looks like the timeline has started (or does it work if you click anywhere?). 

Margaret, the audio starts playing from the point I click in the seek bar. It won't play the whole audio unless I click at the beginning. Thank you for sharing your experience -- which is SL360 and not the SL3 desktop app, which I am running. 

Ashley Terwilliger

Hi Marie and Tess,

Thanks for that additional info and sticking with this!  

Marie, 

The local playback I linked to was specific to Flash, sorry if I missed you were HTML5 only! It was worth a shot though, as those two things could have had a similar enough behavior. 

When you're publishing and testing the local playback, did you use the same publish option of LMS? Can you try using publish to CD or even for web to see if there is a different behavior with that local version? When launching the CD version you'll want to use the file Launch_story.exe and when using the Web version look for the story.html file to launch it. 

I know you previously shared a .story file, but I'd like to try a zipped file you've published too as then we can see if it's truly how you're publishing is happening, the Chrome settings, or something else entirely. Can you follow your normal publishing method and then share that zipped folder here with us? 

Tess, 

I know you mentioned limited time to do some troubleshooting, but if you're able to share your .story file as well we can give that a test as we narrow down on Marie's issue. If you'd prefer to share privately you can upload to our team here. 

Marie DesJardin

Thank you for your patience, Ashley. I was able to run the tests this morning.

> When you're publishing and testing the local playback, did you use the same publish option of LMS?

Yes, it's the normal Storyline publishing process for LMS. I can View Project from within Storyline, or open the published files separately on my PC. Both of them by default open in Chrome with no audio or play button. I post the zipped version on my LMS. 

> Can you try using publish to web? ==> Same results as LMS above

> Can you try using publish to CD? 

This publish option works, both within the View Project window inside Storyline, or by opening the file via the file Launch_story.exe. The first page opens within the Launcher window (not Chrome) and the audio plays normally. 

> Can you follow your normal publishing method and then share that zipped folder here with us?

Attached. Thank you!