When Revisiting Some Quiz Questions, Prev/Next Are Replaced w Broken Submit Button. Users Getting Stuck.

We discovered this issue during beta testing of a new course yesterday and I'm baffled about how to fix it.

When revisiting a question slide that has been drawn from a bank, the Previous/Next buttons are sometimes replaced by a non-functioning Submit button.  This essentially locks up the whole course because there is no way to continue.

It does not seem to happen if revisiting the question via the Review or Retake buttons, only when the slide is revisited using the Previous button from the Results slide (backwards), or if revisiting (forwards) from the main menu back through the quiz.

I haven't messed around with the revisit settings and they all seem to be set to "automatically decide".

I'd rather not post this course publicly, but I could send it or a portion of it privately to your support team if that seems necessary.

Is this a known issue?

 

 

36 Replies
Bob Kaart

Completely unrelated, but a possible solution in the future is to step away from the default nav that Articulate offers, and to make your own custom buttons. I have seen buttons(default ones) appear and disappear before, and it gets pretty messy. 

Are the pages linear? Are the next/prev buttons triggered as "jump to next  slide"  or are they linked to specific pages?

It think it will be hard to see what the real issue is here without looking at the story file. 

 

Fiona Macelli

Thanks Bob, you've found the default Storyline nav buttons buggy then?  I'll take that into consideration for the next course.  I suspect this has to do with revisiting rather than with the next/previous buttons themselves. They seem to be set properly and the course branches but each branch is linear so they are triggered to jump to next/prev. 

On a quiz question, by default, a Submit button appears in place of next/prev (which is what you want on first view, but not on revisit). Storyline seems to be programmed to change to next/prev on revisit but for some questions, in some instances (seemingly randomly, but maybe not), it isn't changing to next/prev on revisit. When the only nav button is Submit for a question that's already been submitted, the course can't go anywhere.

I could remove the Previous button on each Results slide but then that limits the ability to navigate back to the content that appeared before the question draw, and if they revisit the course from the other direction (such that they'd be pressing Next into the question draw) they'll still get stuck.  I'm hoping one of the articulate staff has seen this kind of thing before and knows what's causing it so I can devise the best workaround.

 

Bob Kaart

I've been amending some of our old courses(made before my time) in SL1 and I have definitely seen things like buttons disappearing on revisit. I feel you have a lot more control when you create your own custom buttons, you won't rely on the program's default buttons as much.

I hope someone who uses this more often can help you out.

Fiona Macelli

Thanks Leslie. I've uploaded the file. Many or all of the question draws seem to be doing what I described above but I know that the one labeled 3 Business Case 1a is doing it for sure.  It may be happening only on the questions in the draw that you get correct. I'm not sure about this, but when I got all the questions wrong it didn't seem to happen.

Note again that this problem is happening only when you revisit using the navigation buttons, not using the Review or Retry buttons.  Thanks again for having a look!

Fiona Macelli

I thought I would update this post for others' reference.  I worked with Justin from Support for quite a long time on this (case #00645174) and it turned out to be a bug. Essentially, if you've used a question bank in each of two or more Storyline scenes, when previewing or publishing the course, you'll experience the behavior described in my original post when revisiting any question that you answered correctly, if you revisit the question via a previous or next button (not the review or retry buttons).

It's a big problem because it basically means that you can't use question banks in a multiple scene course.

To get around this bug, I moved all of the questions out of their question banks and placed them directly within the scenes.  It seems to be working so far.

Here's a basic file with all-default settings where I was able to recreate the issue.  For whatever reason, revisiting the first question set doesn't show the behavior described here, but revisiting the second question set does.

Jill Allen

I am experiencing this very issue.  I have multiple question banks in multiple scenes.  The quizzes work fine on the initial visit and upon review from the Results slides.  However, if the learner revisits the any quiz after the first quiz, they are only offered a Submit button that doesn't work.  Any update on this glitch?  If it is not fixed, what is the best workaround?  Do I need to pull all the questions out of my question banks?  Please assist as this is our most used course.  Thank you.

Leslie McKerchie

Hi Sabine!

If you are navigating to previously answered questions prior to the completion of the assessment, I would assume not.

If you wish for users to be able to freely navigate within the assessment, you may want to consider using the Submit All method.

Also please note that replying to the forums via e-mail attaches your signature. You are welcome to pop in and edit if needed.

Sabine Nolte

Hi Lesley,

Thanks, I'll better explain in detail:

We have a string of course pages and a randomised assessment at the end, then a results screen with "Review" and "Retry" buttons.

During the assessment (10 questions), the course table of contents is blanked out, but it is visible again when the results screen appears at the end.

If a user doesn't click "retry" or " review", but they click on content pages (maybe because they want to look something up), and then they click back on the Assessment page, they have to navigate through all the questions  (which have kept their previous answer selections) via the NEXT button. Eventually they get stuck, because there is no NEXT button, only a submit button that doesn't work. This always happens, but at different question pages within the assessment.

So there is no functioning button and no menu. Users are stuck. If they now close the SCORM window, will the result they have achieved still be sent? Do you know this from your bug investigations? What is the best thing to do here?

Cheers,

Sabine