XML File 1.0 not supporting characters that are supported in XML 1.1

Jul 30, 2015

Hi Team,

We just published a storyline 2 file in tincan.xml. Having uploaded the file into our LRS we faced an issue. This was in relation to invalid characters "" that were not being accepted. The minute they were removed our file successfully worked. Why is that the case because this should ideally work for XML 1.0 version.

Another option we tried was to change the header to XML 1.1.We feel this happens to be an Articulate bug as the file advertises itself as being XML 1.0, but the character is only allowed in XML 1.1. Changing the header to XML 1.1 it gets correctly parsed and works successfully as well.

Does this have to be done for all files that face this issue?

Awaiting your reply on this.




1 Reply
Ashley Terwilliger-Pollard

Hi Anjali, 

Thanks for reaching out here. Were those characters associated with a particular file or element of your project? I think we'd want to take a look at the .story file and how the characters appear and what behavior that exhibits in SCORM Cloud which is an industry standard for testing SCORM content. You could also look at testing in SCORM Cloud using the directions here. 

If you'd like to share the file with us, you can send it along here so that our team can take a look. 

This discussion is closed. You can start a new discussion or contact Articulate Support.