Challenge #112 - Issues with Videos

So, here's my lame attempt after being away from Storyline2 for some time and forgotten things. Absence does not make the heart grow fonder...makes me want to jump back in and keep it by my side on a regular basis (Storyline2, that is).

I had a couple of issues which is why I am also posting the .story file here in Storyline Discussions so that any of you wonderful members of this community can shed some light on it.

https://googledrive.com/host/0B4cWLl4F_TnfU0NOdG0wYUpNSUU

1.  The video on two of the layers seems to stop early.  It was working at one point?
2.  The videos are set to start automatically, but don't?
3.  Lastly, the arrows were supposed to be hidden until you go to the first layer and back to base.  The arrow is suppose to animate "wipe" to the next number?

Appreciate any assistance.  I hope to resolve this later when I have more time.

14 Replies
Heather Willis

The "hide layer when timeline completes" function is not working because the timeline is being run by the web object. My recommendation would be to set a trigger that states: Hide the timeline after a certain period of time and insert the length of the video + 1-2 seconds. Not sure if that is the best solution but is the one I would use. 

Heather Willis

On the last issue: It is going to have the same problem with not associated the timeline ending on the layer. You should set a "visited" variable. Once the layer has been visited, the arrow changes to normal. 

I will set this up in the Storyline file and send back to you. I already updated the videos.

Heather Willis

I was not able to hide the slide layer. If anyone has input on how to make that work, I would love to hear how it is done. I tried several things but was unsuccessful. I made the changes to with the arrows appearing and the video autoplay. The finished file is on Articulate Tempshare for viewing and I have attached the updated Storyline 2 file. 

The published file link is: http://s3.amazonaws.com/tempshare-stage.storyline.articulate.com/stp1a95tcvjlao51snubr71ior1uoh4/story.html

I hope that helps.

Daniela Slater

Heather, just some comments:

  1. When I saved the .story file and played it, the arrows did not work.
  2. When I played the tempshare link, only the first arrow worked.
  3. Also, do you know why the volume is so low?

I checked the build (settings) and both arrows were set to normal after visiting state of first two layers.

Heather Willis

I did the arrows again. Something must have happened with one of my triggers. The arrows will only work once published. I ran it in preview mode and they did not work but once I published they worked fine. 

Here is the tempshare link: http://s3.amazonaws.com/tempshare-stage.storyline.articulate.com/stp1a9bvien0l7g10nvoat1bjd8gd4/story.html

The volume was fine on mine...maybe a little low on the 2nd video but that should be driven by the YouTube web object. 

Let me know if I can be of further assistance. I love the challenge. :)

Heather Willis

I just tried it and both worked for me. I let the video play for about 5 seconds and then returned to the main screen. I have the first arrow appear after selecting 1 - Sorrento and the second arrow after selecting 2 - Tuscany. 

Both worked for me when I just played the file. Very strange that they did not work for you. 

Not sure how much help I am providing you, Daniela. I may just be providing more mysteries. lol

 

Daniela Slater

Heather, please note that I appreciate every post you have made.  It helps to know what works and what doesn't and for who.  It gives me a better idea of what might be happening at my end.  A BIG THANK YOU !

I will send it to support.  I am having other problems, like, Preview is now freezing on me?