Inserting/Embedding Flash files - SL3

Hello all,

I am having some issues with importing/embedding Flash files (SWF). When I insert as a Flash file or as a Video file, they enter the creation environment fine. You can use the "play" button on the ribbon or by inserting the Video Controls at the bottom. I have trolled through the many posts of Flash files and it seems people have had issues with versions, and inserting but nothing like this. 

I need to insert these files as they are part of the courseware I create/maintain. 

What occurs is that when you use the ribbon to Preview, the file will not open or execute; what is left is just a small banner with "swf" inside it. Depending on how you imported/inserted the Flash file, will depend on whether you have the option to click on the "swf" inside the box. The same result occurs when the file is published and you unzip and run the html file.

The file I have enclosed is a test file I use for different effects so please ignore the other ramblings. It is not pretty and nor is it meant to be. You will see that I have tried using both insertion options and also, I have tried using the Flash file in a layer. Please feel free to copy the flash file into another *.story file if you wish. 

On another note: I have also downloaded and inserted other sample flash files from the web and the result is exactly the same. There are 2 files attached:

1. Screenshot of the result

2. .story file

Please note: If you are wondering about the flash files (apart from the sample I downloaded), I am not sure when they were created or what version they were created with. However, as stated above, with the sample downloaded; the result is the same.

I thank you for your help in advance.

Thomas

1 Reply