Objects on Layers will not Scroll in Scrolling Pane

Hi everyone and happy new year,

I have a main graphic and i have put this in a scrolling pane as the idea was to have text boxes appearing when i click on different parts of the infographic. I put the text boxes on different layers but they do not scroll when i scroll up and down in the pane. 

I know how to do this using states, but i also need to lightbox to other slides so when i use states i am unable to do this. I have nearly all my hair pulled out at this stage trying ti figure this one out(There wasnt much there to begin with ; ))  so if anyone could shed some light on this for me it would be much appreciated.

Many thanks

 

11 Replies
Anne Seller

Hi Alan,

Have you tried inserting a marker on the image (to show the text when you click or hover over it) or using a hotspot to link to another layer instead? I revised your file to include both options - please see attached. That might be an easier way to go about it.

I hope it helps! 

Cheers,

Anne

Al Man

Hi Anne,

Thanks for looking at this for me, i have tried it this way as well but when i scroll down through my info-graphic the text box stays in its x y position. Strange that the scrolling pane doesn't allow objects on layers to scroll, i will battle on with this today Anne, thanks again for the help

Anne Seller

Hi Alan,

You’re very welcome! And it looks like Phil has given you a nice solution for the scrolling problem.

In case you might want to try another approach, I came across an interesting thread where David Mark asked about creating a zoom region that is clickable (i.e. making use of the zoom region tool):

https://community.articulate.com/discussions/articulate-storyline/clickable-zoom-region

Based on Ian Monk’s response to that thread, I created a version of your file where the user just clicks on a part of the image and then sees the close up view of that part of the image (where you could also include a text box with explanatory text, etc.). Of course, the original image has to be high-enough resolution so that the zoomed part appears clearly.

I’ve attached the file – perhaps this is another way to achieve what you’re aiming for?

And thanks again for posting this question – I learned something new today! ;)

- Anne