Orient shape to freeform motion path - looks off (example included)

Hello all!

While the new orient to motion path feature is nice, it seems a little off at the moment -- when using freeform motion paths.

Attached is an SL3 sample where an arrow should animate along a path that curves in different directions during the course of its' path.

Thought this would work fine with the freeform motion paths, too.  But it seems the orientation of the arrow does not stay straight after going around the different bends, and almost rotates all the way around.. in fact things get a little crazyyy  (shown in the example file, on the "blue" path)

So, I found the only/best way of having an arrow stay straight and orientated to the path is to make several "turn" motion paths, and line them up end-to-end  (example, "green" path)

motion paths

This workaround works OK...   although it's not perfect either and it doesn't have a consistent, smooth speed with the slowdowns at the start/end of each path.

I really thought this would be a great case where the "orient to motion path" would come in handy.

Would anyone who has mastered the "orient to motion path" feature be willing to share some tips and knowledge to keep an item straight on a freeform motion path?

Or, happen to know how to keep the same, consistent speed through each "turn" motion path?

5 Replies
Veronica Budnikas

Hi Jay,

You're right, when you use a freeform motion path the Orient to Shape to Path option goes a little cray-cray. The reason is that when you create a freeform shape (or line in this case) it ends up having tonnes of points--just about every time you move the mouse away from going straight it creates a point. To see this, go to PowerPoint, draw a freeform line and then select it and click EDIT POINTS. You'll see how many points have been created.

Anyway, for the Orient Shape to Path to work properly, you are better off using the built-in paths like turn or curve, just like you did. 

To remove the slowing down at the start and end of the path (the easing), just select the Motion path, go to Path Options, and under Easing, select Direction and then select NONE. This will remove all slowing down at each end (or you can remove it only at the start or at the end if you like). That should make this work a lot better.

Hope this helps!

Scott Kaye

Veronika beat me to the trip.  I use almost the exact same technique.  I very rarely make a freeform motion path because of the unusual behavior you point out.  I just try and keep the paths similar to some of the existing paths that can be drawn and use the path easing option to make sure the motion is smooth.

Jay Yearley

Thank you everyone. I appreciate your time and responses.  I did just end up using the "turn" motion path instead of the freeform.  I think I will submit a feature request, or at least let Articulate know about this kind of situation with the freeform paths.

Thanks for also pointing out how to set the easing to "none"..  This is very useful.  I knew there had to be some option to remove the easing from the paths, though I wasn't able to find it.

Thanks again everyone!