API NuSOAP/cURL Failure on script that worked fine for 2 years

Hi folks, I have a page that does the following in communication with the Articulate Online APIs. Here is just a little background:

1. Queries the Articulate Online database to bring back a list of available courses (just 8 courses), then displays them on the page.

2. Collects user information to create a user account, but first queries to see if the account exists. 

3. Registers the user for a course to send out an invite.

There is one API call on the page load, and at least three after the submit.

My set up has been working for the last two years and stopped working two weeks ago.  I have drilled down to catch the error, and this is what I am seeing for each API call: 

2017-07-26 12:10:25.170189 soap_transport_http: end of send() 2017-07-26 12:10:25.170234 wsdl: Getting https://cwerlearning.articulate-online.com/services/api/1.0/ArticulateOnline.asmx?wsdl - HTTP ERROR: cURL ERROR: 35: error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure

url: https://cwerlearning.articulate-online.com:443/services/api/1.0/ArticulateOnline.asmx?wsdl

I use NuSOAP for the cURL connections. I have worked with my hosting provider to rule out connections on that end and they say that Articulate Online has issues when it comes to SSLV2/SSLV3. I have even put my test script and NuSOAP on other machines and I see the same error. What should I try next? 

Here is the script that is running my test.
http://environmental-comm.info/form-orig-withtrycatch.php 

 

1 Reply