Attachments giving error in Review

I am trying to open a PDF that is uploaded into the resources section in a program published to Articulate 360 Review, but I get different errors based on browser.

Chrome: This XML file does not appear to have any style information associated with it. The document tree is shown below.
<Error>
<Code>AccessDenied</Code>
<Message>Access Denied</Message>
<RequestId>4E2B4E67BDB6CCA5</RequestId>
<HostId>
SbKgML4iLC6VMpzd2/2HzFWvET4bWADEks6fUQ4oBX5CGyTqj3qYus07+ijoxP6IsEboYj41kYs=
</HostId>
</Error>

IE: The website declined to show this webpage

 HTTP 403 
 Most likely causes:
This website requires you to log in.
 What you can try:
 Go back to the previous page.
 More information
This error (HTTP 403 Forbidden) means that Internet Explorer was able to connect to the website, but it does not have permission to view the webpage.

For more information about HTTP errors, see Help.

But when published to our local network and viewed it opens just fine,

10 Replies
Alyssa Gomez

Hey Kristi!

Are you working with a Storyline or Presenter project? Here are a few things you can try before we dig any deeper:

  • Is the file name long, or does it include special characters, accents, or symbols? Learn more about naming conventions in this Microsoft article. If so, try shortening the file name or remove the special characters, and relink the file to the Resources tab.
  • Where is the PDF file stored? If it is stored on a network drive, try storing it locally along with your Articulate project.

If you're still having trouble, let me know! 

Ashley Terwilliger

Glad to hear that Kristi! 

Just wanted to also give you a heads up that responding via email includes your signature here in ELH. You are welcome to visit the forum discussion and click on the "edit" below your post to remove that information. No worries on our part - just in case you don't want your information publicly! 

Martin Dean

Hi Alyssa

I am having the same problem.

I have a PDF that I am linking to, using the trigger 'JUMP TO FILE'.  When I publish to Review360, the same error that Kirsti had appears in my (Chrome) browser.

I (WEB) published to my local drive and noticed that the package has not picked up the documents that I want to link to. 

I must say I am really surprised that SL is trying to access my hard drive from the Review360 server, rather than taking a copy of the files and using a relative link to those files on the review server.

How then, do I link to a file unless I place that file at a URL?  This seems crazy.

Any thoughts?   

Martin Dean

Alyssa - here is some more info..

I followed the instructions to add my PDF to Resources.  This works ok. But I do not really want a resources tab in my programme.

I followed the instructions about linking to a document.  This told me to insert the code 'story_content/external_files/MyFile.pdf' in the trigger and replace myfile.pdf with the correct filename.  This results in the browser trying to open the following link (which is obviously trying to open a document on my computer): 

https://articulateusercontent.com/Mac/001dataMacBookPro/001%20Clients/001%20HP/001%20Speciality%20Accreditation/Material%20from%20Ina/story_content/external_files/SORTEDCURATEDLISTV10.pdf 

I note that the RESOURCES entry for the same file correctly opens this link:

https://articulateusercontent.com/review/items/T5q7l_TH0xmhtkvw/story_content/external_files/SORTEDCURATEDLISTV10.pdf

Of course it would be best practice for SL to ask if the file was required as an ABSOLUTE or RELATIVE link.

I hope you can advise.

Crystal Horn

Hi there, Martin.  This article describes how you can hyperlink to a file in your slides.  The file will become a part of the published output in the story_content folder, as you mentioned.  When a learner clicks on the file, it will either open in a browser tab from the output or ask the learner to save a copy first.

Check out this sample I published to Review 360.  Let me know how it behaves on your end!

The instructions you shared above refer to linking to an object that is already added to the Resources tab in the player.  It sounds like you don't want to add the object to the Resources tab, though.

Martin Dean

Hi Crystal

Many thanks for the prompt response.

I followed the instructions in the article in a new file (attached).  This had the same result as I experienced before.

However!

I wondered if this was a 'path' problem.  I am using a Mac and the file was in a client folder.  So I moved the file to a folder on the C:/ root.  This worked fine.

So, if anybody on this thread is using a Mac, I would suggest that SL can only successfully publish hyperlinked local files if they are at or near the root of your virtual C: drive.

BTW - I do think it is time that SL was made more compatible with the Mac.  It is frustrating to have to remember various 'quirks' of the SL product not working on this platform.  

Crystal Horn

Thanks for sharing your discovery, Martin!  I'm not sure which virtual machine software you're using with your Mac, but this article about Parallels describes disabling the shared profile setting so that all of your Windows and project assets are isolated to the C: drive.  Keeping everything on the C: drive will be one of the best tips we can share!