HTML output from Rise not displaying locally

Hi there-

I created a short course in Rise and then exported it locally to my machine.  I can launch the content by double-clicking on the index.html file on my machine (it opens in Chrome, my default browser) and all works as expected.

I zipped the file and sent it to my client, who unzipped it locally and tried to launch it.  The browser tab opens but nothing is displayed. Viewing the source info, we can see that there is data on the page.  This works regardless of the browser he's using.

My first inclination is that it's some kind of security setting in his browsers, but I'm not sure.

Has anyone else run into this? Any idea how to resolve?

Thanks,

Jeremy

5 Replies
Jeremy Negrey

He is able to review it if I use the Share link.

The file was unzipped -- the browser opens and the correct title is displayed on the tab, just no content is displayed in the window. I unzipped the same zip file on my machine and it opened correctly,

This is concerning because the plan is to embed this content directly within a web application as an on-demand help system, not host via an LMS, so I need to make sure all users will be able to see it.

Tom Kuhlmann

A couple of things to test:

  • What browser is being used?
  • Have him put it on a web server and not open locally and see if that helps. He may have something that blocks the files from playing locally.

If it's working for you and he can access it via the share link (and I assume any other server) than there's an issue at the user's end. I'd test it with others in the same organization to try an narrow down the issue.

If you still can't get it resolved you can try to contact Articulate support but if it's working the way it's supposed to, there may not be much we can do.

Cameron Stewart

I know you've stated that the file was properly unzipped by the client, but this sounds exactly like the scenario where a person opens the .zip file on their PC and then tries to play it, because it looks like it's unzipped but it's really not.

That aside, there might also be a pop-up blocker at play. Have they tried opening it in an alternate browser? 

Just a few thoughts to consider.