Please help! Rise course progress is not tracked by lesson in LearnDash

Oct 18, 2019

This is a shot in the dark, but maybe someone out there has gone through this and can help.

I'm using Articulate Rise to build by courses, then exporting them to Tin Can and importing them into LearnDash. I've also tried exporting SCORM format. The only difference with that is the exit buttons don't work, so I switched to Tin Can.

Most of my courses have anywhere from 4-6 lessons. I've noticed when I'm testing that when I go into a course and complete, let's say 2 out of the 6 lessons, then decide to quit - it does not retain my progress of completing the 2 lessons. I have to start with lesson 1 again. 

I tested this in SCORM cloud and it worked like I wanted it to. It has also worked in iSpring LMS and Docebo LMS systems. So I know it's not something wrong with my file. It's something on LearnDash's side, and my guess is I need a plug-in of some kind to resolve it.

Can anyone please help?

8 Replies
Saurabh Chauhan

Hi Alina,

I don't know how you're embedding your rise content in the LearnDash course? Means which plugin or code.

If you're exporting your rise content as xAPI, then you can test your content on the GrassBlade Demo site where you can upload your xAPI Content and use it in the LearnDash course. You can track progress reports in GrassBlade Cloud LRS.

The demo site is a combination of WordPress + LearnDash + GrassBlade xAPI Companion + GrassBlade Cloud LRS.

Also, for your concern about getting content resumed, where you left. It perfectly works with the GrassBlade xAPI Companion plugin. There are some pre-uploaded contents; you can try them to get a clear insight.

Pre-uploaded Rise 360 Content:

Login Details are available on homepage.

Thanks & Regards
Saurabh Chauhan - from GrassBlade

Mastery Network

Just in case anyone else comes across this post...I ended up going with Uncanny Owl's Tin Canny solution. The main reason being is because they have a great front end reporting function and the implementation is very easy.

When I tried Tin Canny at first, the "resume" function didn't work. However, after reaching out to their customer service team and Bluehost's advanced customer service, we were able to fix it. The problem had to do with mod_security. 

This is something that Uncanny sent me in our convos that might be helpful to someone else: "It seems that "Mod_security" is not allowing %, " or any other special character in URL which is used for URL encoding. These special characters are required in order for the Rise resume state to work."

I forwarded that phrase to Bluehost, plus a test link, and they resolved the issue.

I hope this helps someone else! This was a GIANT headache for me to figure out, so feel free to reach out to me on here if you have questions, and I can do what I can to help (as long as I'm still active on this site, that is). 

Alyssa Gomez

Hi, Janelle!

Is this problem happening in Google Chrome?

Chrome has deprecated a technology that was used by many LMSs to allow a course to communicate back to the LMS when the course window is closed. If your LMS hasn't upgraded their system, or if you're using an older version of your LMS that doesn't include an update to address this change, the course cannot communicate progress or completion properly. This causes learners to start over from the beginning instead of resuming a course or recording completion after they close the browser window.

Please reach out to your LMS and find out if they have released an update to address the Chrome changes. If you need support from us with the technical details, please let us know by starting a case with us here.

This discussion is closed. You can start a new discussion or contact Articulate Support.