Rise SCORM package / Moodle / iPad scroll issues

Hi guys,

Has anyone tried using a Rise SCORM package in Moodle yet, and if so, have you experienced any issues with how it displays on an iPad? I created a test course, exported as a SCORM 2.1 package and added it to my Moodle course but whenever you click on it, although it displays correctly, you can't actually scroll down. The moodle page as a whole shifts slightly, but the content of the Rise module doesnt appear to stretch beyond the bottom of the page and therefore you cannot scroll any further down....does that make sense?! :D I've attached a couple of images that (I hope) helps clarify things (Image 1 is viewing the course as a SCORM module in moodle, and that's as far as I can scroll down. Image 2 is the web view, and I can scroll down freely).

If also starts in the first lesson, not on the overview page. Is this how it's meant to load up when it's a SCORM module?

When viewing the Rise course using the share link, everything works fine, its just the combination of SCORM / Moodle / iPad. I have tried various different appearance settings for the SCORM module in Moodle but nothing makes a difference. Also, viewing it as a SCORM module on a desktop appears to add the content (when viewing in a separate window) inside a window with multiple vertical scroll bars (i.e. content, content container, window)

Any help would be greatly appreciated.

12 Replies
Alyssa Gomez

Hello Andy!

I don't have experience with Moodle, so I'll have to defer to the community on that. But I did want to mention that you may want to look at testing it in another environment such as SCORM Cloud which is an industry standard for LMS testing. You can review the directions here to help you go through that testing. 

Mike Olivieri

Hi Andy,

Both the scrolling & multiple scrollbar issues have been resolved. You'll need to export your course again and re-publish to your LMS. We'll be making more improvements to scrolling performance on iOS over the next few days as well. Thanks for your patience on this. 

Please reach out if you're still running into problems. 

Continua One

Hello,

We're experiencing this same issue with iPads and an iPhone 7s running the latest OS and Safari. It seems it started in the last week or so. 

- Browserstack emulator also shows the scrolling issue

- iPhone7 shows scrolling issue

- Multiple customers with iPad have called and experienced the inability to scroll

Our Rise courses were published in the last month so I'm assuming the previous fix is already present with those. These are not old courses.

Is anyone aware of a new bug? Perhaps an Apple update is causing this? 

I've attached a video of an iPhone 7 showing the issue.

Thanks,

Aaron 

Ashley Terwilliger-Pollard

Hi Aaron,

Thanks for sharing the video. Are you exporting for LMS or No LMS-Web only? You mentioned the latest iOS - is that iOS 10.3? Has anyone tested it on an earlier iOS? 

I'm not aware of a new bug - so I'd like to test your Rise export as well by uploading to SCORM Cloud (if you used an LMS export) or my web server (if you did Web only) to try and replicate it. If you're able to share the existing link to your course we can test that too! 

You can upload the export using the "Add Attachment" button at the bottom of the reply window. 

Ben Hancock

Hi,

I am also getting the same issue. Landscape on ipad will not let me scroll as it should, it appears pot luck whether it works or not. Portrait seems to work fine but the scorm course I have embedded the rise link (web object) into is designed to be viewed best at landscape, so although it works in portrait it is not ideal.

Is there a fix to this problem yet?

Thanks

Ben

Ashley Terwilliger-Pollard

Hi Ben,

Thanks for reaching out here. I wanted to check where you were hosting the Rise course? Have you also tested at SCORM Cloud to see how it behaves there? I know with Aaron before he didn't share a case number (nor can I find it) but he mentioned that it was specific to his LMS. 

If you see the same thing in SCORM Cloud can you share a copy of the Rise export and a link to the course in the LMS? 

Ashley Terwilliger-Pollard

Hi Ben, 

Are you embedding the content into Storyline so that you can publish for Review? Review for Rise is on the roadmap for later this quarter - so we'll keep you posted on that! 

In the meantime, to make sure the Rise content is working correctly you can test the Share link as a standalone URL on your iPad.