Unable to acquire LMS API

Hi, trying to upload my first Rise course onto our LMS (coursemill).

Have tried using the Scorm 1.2 and AICC settings but am met with an error message when trying to run the package.

error message:  Error unable to acquire LMS API, content may not play properly and results may not be recorded. Please contact customer support.

Does anyone have any pointers please? :-)

15 Replies
Katie Riggio

 Hi, Nigel. I'm happy to lend a hand!

We've heard folks run into this exact error before, and it seems to be an LMS-specific issue where some LMSs use a Java API object to load content. Since content created in Articulate does not require Java, we recommend these next steps:

If you still run into this behavior after those steps, testing the course in SCORM Cloud–an industry-standard tool for testing AICC, SCORM, and Tin Can API (xAPI) content–to see how it behaves there will be the next, best step. This will tell us if the problem is mostly related to your Rise or CourseMill output. Let us know if you need help with testing!

Mammoet Academy

Dear Katie,

I'm have the same problem just recently. The thing is that I tested it before and everything was running properly. No after the launch of our course we're having problems with the error mentioned above. But this error we only receive in IE11. See 1st attachement.  When clicking a few times it is possible to see the course, but you're not able to open the course. You can click on the button, but nothing happens. See 2nd attachement.

I even tested it in Scorm.cloud. In Chrome no problem, but in IE11 I don't receive the error, but I can't open the course either. The buton won't work. 3rd attachment.

Really need your help. 

 

Leslie McKerchie

Hello Kilmeny and welcome to E-Learning Heroes :)

Thanks for reaching out and letting us know you were able to upload in SCORM Cloud with no issue.

I took a look at the support cases for the users above and they experienced a similar result, but I've not seen where they've reached back out to share a resolution with the LMS.

Have you been able to reach out to CourseMill?

kilmeny west

I have asked this question to a Trevantis person....they state that a SCORM1.2 course built in Rise should load without issue. There was a problem however, using a "special character" in the course title. I fixed that in an earlier test version of the course and went on developing but now I am ready to test in Coursemill again and receiving the same 404 errors. Grrrr.... I was wondering if those special characters can be used in lesson titles or not? Have you heard of this being an issue?

 

Ashley Terwilliger

Hi Kilmeny,

Our team previously investigated and fixed an issue with Chinese characters in the course title. Those were causing errors at the time of export, so prior to uploading into your LMS. 

Have you tried removing the characters and uploading? If it's working in SCORM Cloud with those in, it'd be a good idea to check in with Coursemill again to see if they have any restrictions for those. 

Let us know what you find out! 

P.S. - It looks like your email signature came through when you replied via email. You can remove that if needed by clicking ‘Edit’ beneath your response. Here’s a quick Peek video if you need help.

kilmeny west

Hi Ashley,

Thanks for the tip re: email signature.  

I did edit the course title in a prior iteration and thought it was all fixed but am now experiencing the same error from Coursemill ( I am assuming this is now from a different error).  I will continue to troubleshoot and be sure to update the community if I find anything to share.