Wrinkle with SL file in Rise

Hello,

I have created small 1-3 slide SL files and have successfully imported them into Rise with the needed functionality several times. But the last 2 projects, I get a black screen with a play button prompt that I usually don't get (see pic below).

I solved this once by creating a blank slide right before the start of the presentation slide (only about .5 seconds long) that transitioned straight into the next. That worked.

But this time, when I try that, the presentation slide will play the visuals but not the audio, unless I click the slide. As far as I know, I haven't changed player settings or anything like that. It only does this when inserted into Rise. Previewing in SL looks and sounds fine. SL files is attached underneath. One scene is just one slide, where I get the black screen beforehand. Scene 2 has the blank slide "fix". You'll need to upload as a scene to review 360 and the insert in a Rise course to see it. I'd appreciate any help!

Thanks,

Brian

4 Replies
Crystal Horn

Hello, Brian. Check out this article which talks about what happens when you have slides that advance automatically to slides that have media. 

Essentially, most browsers need permission from the end user to play media. It will either be solved by the black screen with the play button (your first Scene), or by having the user click Next or another button to advance, rather than automatically advancing like in your second Scene.

Math Notermans

Basically you do need to edit your slides.min.js file to ensure to skip the default behaviour.
In this post quite properly described how to.
https://community.articulate.com/discussions/articulate-storyline/remove-play-button-on-html5-opening-screen-in-storyline-360?page=3

One thing to remember though is that due to the fact you want your SL file in Rise, and thus publishing straight to Review, you need to edit the slides.min.js file inside your Program Files folder ( C:\Program Files (x86)\Articulate\360\Storyline ) because when publishing to Review it uses these and publishes directly to Review.