How to Share Your E-learning Course for Free With Google Drive Posted Monday, August 26, 2013 at 5:00 AM

Add to Favorites

For a quick and easy way to share your published Articulate projects, you might want to consider Google Drive. You probably already know about Google Drive’s file sharing capability, but did you know that Google recently added a web hosting feature? This new feature means that Google Drive can host your published Articulate projects.

Watch this screencast to see how easy it is.

STEP 1: How to upload your published Articulate project to Google Drive:

1. Login  to Google Drive.

2. Create a new folder.

3. Set this folder’s sharing settings to “Public on the web

4. Upload the published output from your Articulate project.

5. Rename the appropriate launch file to index.html

STEP 2: How to find the link for sharing:

1. From within the folder containing your published content, copy the characters after drive.google.com/#folders/  from the address bar as shown below.

Host Published Articulate Projects for Free With Google Drive

2. Then, to get the link you to use for sharing with others, paste those copied characters to the end of http://googledrive.com/host/ 

Host Published Articulate Projects for Free With Google Drive

https://googledrive.com/host/0B-p5Xrlt8ArKaTlPd3RSOHdjSG8/

HELPFUL HINT: I have found that Google Chrome is the best web browser to use with Google Drive. Not all Google Drive features work by default in other browsers.

 

 

 

155 comments so far

David Dunbar

7 posts

Posted Monday, August 26, 2013 at 6:16 AM

Thank you Mike, this will help me a great deal, as I continue to develop my own portfolio . I also love the example you provide, and would like to use it as a starting point for my own online portfolio if that's OK? Itl ooks really good!

Dave Dunbar

David Dunbar

7 posts

Posted Monday, August 26, 2013 at 6:17 AM

Thank you Mike, this will help me a great deal, as I continue to develop my own portfolio . I also love the example you provide, and would like to use it as a starting point for my own online portfolio if that's OK? It looks really good!

Dave Dunbar

User Rank Mike Taylor

940 posts

Posted Friday, August 30, 2013 at 3:59 AM

Yes, by all means Dave! I'd love to see how it turns out.

Gordon Lam

150 posts

Posted Tuesday, September 03, 2013 at 12:16 PM

I just want to share that many sites such as google drive are blocked by corporate firewalls (like my firm's).  So if you have content you need to share with a corporate client make sure they have access.

Dagmara Glowa

1 posts

Posted Thursday, September 12, 2013 at 3:04 PM

This is excellent! Thank you so much Mike for sharing this tutorial - very helpful!

Rebekah Massmann

190 posts

Posted Friday, September 13, 2013 at 8:30 AM

Quick question. If you want to share a course only with limited audiences, will it still work if you make the folder's options where only people with the link can access?

User Rank Mike Taylor

940 posts

Posted Friday, September 13, 2013 at 10:12 AM

Hi Rebekah! It looks like it's either public and available for anyone or nothing. (At least I haven't figured out how to make it work for a limited audience yet.)

Catharine Kuber

2 posts

Posted Friday, September 13, 2013 at 12:02 PM

When I publish the file and upload it to Google Drive, I don't see a .html file. What step am I missing?

User Rank Mike Taylor

940 posts

Posted Monday, September 16, 2013 at 2:17 AM

@Rebekah I was playing around with this a little and found another way that might work for when you don't want to share it publicly.

1. Open the html file that launches the course. This should display the html code, etc  

2. Down toward the bottom right use the Open button to open it using the Google Viewer which gives you a different view of that html code.

3. This page should have a Preview button at the top which for me displays the course. Once it is displayed you can try to copy/paste that URL and see if others can access it.

Here is mine:  googledrive.com/.../index.html

User Rank Mike Taylor

940 posts

Posted Monday, September 16, 2013 at 2:21 AM

Hi Catharine! If you publish to the web format and then upload everything in your output folder you should see an html file that launches the course. For Storyline it's story.html and for Presenter it is player.html

Geraldine Hayes

2 posts

Posted Thursday, September 19, 2013 at 4:09 AM

Mike

I uploaded a short Storyline presentation and shared the link with colleagues.  It had six slides, two of which were short videos.   Of nine people who gave me feedback -

1 Five were unable to view the videos, but could see the still slides

2 One person could view nothing after the first slide

3 Five were unable to view a second time

4 One person found that after the 3rd view, the video no longer played

I wonder if you have ideas what the problem may be?

User Rank Mike Taylor

940 posts

Posted Friday, September 20, 2013 at 4:29 AM

Hi Geraldine! Are they accessing this from behind a corporate firewall? That's often my first thought for things like this. Were the videos inserted into your presentation or embedded/linked? If you uploaded everything from the output folder and everything is shared as public it should work in theory...we know how that can be sometimes right? 8-)

Are  you able to share your link?

Geraldine Hayes

2 posts

Posted Monday, September 23, 2013 at 6:38 AM

Thanks, for the reply, Mike. No. they are not behind a firewall.  The videos are inserted into the presentation, and everything in the output folder is shared as public.  Unfortunately, I cannot share the link because it is company specific. It seems to be browser incompatibility as it works in some browsers and not others.

User Rank Mike Taylor

940 posts

Posted Monday, September 23, 2013 at 7:05 AM

Great point about the browsers...seems like it's built for Chrome which probably shouldn't be a surprise I guess. 8-)  Some of the functions or Google Drive only work in the Chrome browser and I also wonder about the bandwidth they give you which might impact the videos.

Tri Hue Nguyen

8 posts

Posted Tuesday, September 24, 2013 at 11:40 AM

Mike,

Thank you very much for this post. I can make it work after several trials and error.

1. My google drive URL is drive.google.com and not by default googledrive.com (I am living in France, so I don't know if there are specificities :-()

2. By default drive convert the files into Google document format and therefore there was no suffix to index.html but index instead

3. When I paste drive.google.com/host/'suffix of the folder', there was an error "404. That’s an error. The requested URL was not found on this server. That’s all we know."

Lastly, when I enter googledrive.com/host/'suffix of the folder', and hurrah, it works.

If you could give me some further explanations, it would be great.

Anyway, thank you very much for the sharing.

Regards,

Tri Hue

User Rank Mike Taylor

940 posts

Posted Tuesday, September 24, 2013 at 12:44 PM

Hi Tri Hue, let me take these in order.

1. Mine is the same way...I'm not sure why the make us change the url from drive.google.com to googledrive.com but I have to do the same thing.

2. There should be a setting to turn off the convert to google document format ( click Option (the gear icon) and Upload settings. There, uncheck the option Convert uploaded files to Google Docs format.)

3. Same as number one above...we have to convert the drive.google.com URL to the googledrive one....sorry for the confusion.

I'm glad to hear you've got it working  

Sharon Page

5 posts

Posted Wednesday, October 09, 2013 at 1:41 PM

A very clear tutorial! Thanks!

Posted Monday, October 28, 2013 at 6:11 AM

Will this work witha  captivate file? Does anyone know?

User Rank Mike Taylor

940 posts

Posted Thursday, October 31, 2013 at 11:20 AM

Hi Lissbeth! Yes I believe it should work with any type of web-friendly content. So as long as it is published for the web you should be all set.

Laura M

109 posts

Posted Thursday, October 31, 2013 at 11:39 AM

I have done this before successfully with Studio '09 (thank you so much for sharing the tutorial!), but for some reason when I publish in '13 for the web, I'm not seeing a file called player.html.  Is it possible the file is called something different now?  Any idea what I might be doing wrong?  Thank you!

User Rank Mike Taylor

940 posts

Posted Thursday, October 31, 2013 at 11:55 AM

Hi Laura!  In Studio '13 you'll want to look for "presentation.html"

Laura M

109 posts

Posted Thursday, October 31, 2013 at 12:28 PM

I tried renaming that and then one of the other files and neither worked the first time, but it's working now.  Thank you so much for the fast reply!

Tina Shoup

5 posts

Posted Thursday, November 14, 2013 at 5:29 PM

Mike, I did the step by step tutorial and I keep getting an error 404 message no matter what I do.  I have tried to upload different folders in Storyline and I keep getting the same error message.  I have Windows 8 which has caused me more headaches than I can even name so I don't know if that has anything to do with my issue.  Any advice?

User Rank Mike Taylor

940 posts

Posted Friday, November 15, 2013 at 2:22 AM

Hi Tina! I don't think Windows 8 should cause any troubles, although I do find it easier using the Google Chrome browser. Do you see that all the output files and folders have been uploaded? Did you rename the launch file to index.html? Set the folder to be shared publicly?

Chris L.

11 posts

Posted Monday, November 18, 2013 at 11:21 AM

Mike,

I'm having the same problem as Tina.  Everything from your tutorial - google chrome, etc.

I keep getting the 404 error.  I'm also using Windows 8. I renamed the story.html file to index.html.

Any help is appreciated...thanks mike!

User Rank Mike Taylor

940 posts

Posted Tuesday, November 19, 2013 at 2:21 AM

Hi Chris! I just tried this using Chrome on Windows 8 and it worked fine. Maybe double check that the sharing option for the folder and all the files is set to "Public"?

Chris L.

11 posts

Posted Tuesday, November 19, 2013 at 6:26 AM

Hi mike,

There doesn't seem to be an option for "public", but it is set so everyone at my company can view.

Options are People are {my company}, people at {my company} with link, and private

What does the 404 error mean? It says files not found on this server..

Thanks!

User Rank Mike Taylor

940 posts

Posted Tuesday, November 19, 2013 at 6:32 AM

Are you using Google drive within Google Apps for your company? I think that might be the challenge here. I know others have had trouble getting it to work within Google Apps. It seems that it only works with accounts that have the option to share as "Public on the web".

Paul Alders

263 posts

Posted Tuesday, November 19, 2013 at 12:32 PM

Thx Mike,

This will clean up my Dropbox file ;)

Dennis Price

31 posts

Posted Monday, November 25, 2013 at 9:36 PM

Hi guys

I believe the problem is in the settings. Sometimes the default upload setting is to convert all files to Google Docs format. (Check out the little gear icon?)

D

User Rank Mike Taylor

940 posts

Posted Tuesday, November 26, 2013 at 2:21 AM

Ah yes Dennis! Great catch...to check your upload settings in Google docs, click the gear icon up at the top right, go to "Upload Settings" and make sure  the "Convert uploaded files to Google Docs format" is unchecked.

drive.google.com/.../edit

Leslie Noggle

1 posts

Posted Wednesday, January 29, 2014 at 9:16 AM

Thanks so much for this! I just tested it and found it super easy. I've been trying to decide on the easiest way to get content to students, and I think I like this better than the LMS/SCORM package option for the activities we don't need to track. Now I'll just be able to tweet or post to Facebook!

Posted Friday, February 21, 2014 at 5:23 AM

Hi Mike - what a great idea this is!

I am having some trouble making it happen though and wondered if you would double check me?

I am using a Studio '09 Web output, I changed player.htm to index.htm, i have the folder shared to Public, but when I enter the URL - drive.google.com - I am just seeing the folder contents.

Any tips to send me back to check on?  I think this is a great option to be aware of and want to be able to have a working example in my back pocket!

Robert Lengacher

122 posts

Posted Friday, February 21, 2014 at 5:31 AM

Hi Penny,

I looks like you may have missed step:

"Then, to get the link you to use for sharing with others, paste those copied characters to the end of http://googledrive.com/host/  "

Robert Lengacher

122 posts

Posted Friday, February 21, 2014 at 6:13 AM

Also you might need to use the advice in one of these steps about naming:

"Rename the appropriate launch file to index.html

For a Storyline course, rename the story.html file.

For a Presenter presentation, rename the player.html file.

For a Quizmaker quiz, rename the quiz.html file.

For an Engage interaction, rename the engage.html file."

Robert Lengacher

122 posts

Posted Friday, February 21, 2014 at 6:56 AM

I was able to view it just fine by following my first comment above, since you already took care of the naming step (sorry I didn't read your original post carefully enough:).

Posted Friday, February 21, 2014 at 8:28 AM

Robert, you could view my course content? or my folder?

When I try drive.google.com/.../0ByMn4lmM9sBWT1EtX0tHU3UwNE0 I get

Not Found

Error 404

I will try stepping through the process from the beginning.

Robert Lengacher

122 posts

Posted Friday, February 21, 2014 at 8:34 AM

Penny, the devil's in the details:)

The link you currently have starts with "drive.google.com", but the link that works is slightly different:

http://googledrive.com/host/

Notice that the non-working version has a period between "drive" and "google" and they are reversed compared to the working version.

Here's the version I used to get it working: googledrive.com/.../0ByMn4lmM9sBWT1EtX0tHU3UwNE0

Rod G

6 posts

Posted Saturday, February 22, 2014 at 11:50 AM

For mobile... do you have to rename the story_html5 file as well? I couldn't get it to work I wondered what you would rename it to? Thanks!

User Rank Mike Taylor

940 posts

Posted Monday, February 24, 2014 at 7:17 AM

Hi Rod! You could rename the html5 file to index.html instead of the presentation.html  Or you could link directly to the html5 file by adding it to the end of your path.

googledrive.com/host/0B1nJ62N5DgDhR1puaVplX1JQN2c/presentation_html5.html

Gary Williams

13 posts

Posted Wednesday, February 26, 2014 at 5:41 PM

Hi Mike,

slightly off topic so apologies. I looked at your demo file on google drive and really like the social media interaction you created where the banners scroll out when you hover over them. Can I ask, how you have done this. I have tried to create this effect by setting a hover state but dont seem to be able to replicate it. Could you explain ?

User Rank Mike Taylor

940 posts

Posted Thursday, February 27, 2014 at 2:39 AM

No problem Gary. Those use object states which are triggered to change when the mouse is hovered over the initial icon. The normal state image is the logo only and the mouse over state image is the full wide version including the text. (I also checked the "Restore on mouse leave" option.  I also added a Fly In animation on the mouse over state image. Here's a screenshot of what that looks like. https://db.tt/jPZgVQH6

Mohammad Hassam

76 posts

Posted Wednesday, March 05, 2014 at 8:27 AM

This is great! Thanks for sharing with us.

Posted Thursday, March 06, 2014 at 1:36 AM

Thank you.  I successfully uploaded my first ever storyline project.  Your help is much appreciated.

Terry Wang

61 posts

Posted Friday, March 07, 2014 at 10:01 AM

Hi Mike,

After files were uploaded google drive, they look like the following without extension name *.html, I tried to change file name many times, but it didn't work.

(Articulate 13 Presenter):

presentation

presentation_html5

User Rank Mike Taylor

940 posts

Posted Saturday, March 08, 2014 at 3:10 AM

Hi Terry..can you check and see if you have the setting turned on that automatically converts your files to a Google format? Make sure conversion is set to off in the popup upload dialog box like the one shown here: lifehacker.com/convert-files-to-google-docs-format-to-save-space-on-go-1412063260

Dennis Price

31 posts

Posted Saturday, March 08, 2014 at 5:09 PM

How do I switch of the email I get for every comment made? I opted in previously but can't seem to opt out.? (I am opting in to this comment because I need to be notified of the answer of course :))

Paul Alders

263 posts

Posted Saturday, March 08, 2014 at 7:06 PM

Hi Dennis, you can switch of the email by unchecking the checkbox 'email me future comments. Next to the submit button.

Thanks

Paul

Dennis Price

31 posts

Posted Sunday, March 09, 2014 at 1:44 PM

Blank comment to unsubscribe then: done . Thanks

Terry Wang

61 posts

Posted Saturday, March 15, 2014 at 5:00 AM

Hi Mike,

Thank you for providing the following information, it did work!

"Make sure conversion is set to off in the popup upload dialog box like the one shown here: lifehacker.com/convert-files-to-google-docs-format-to-save-space-on-go-1412063260"

Kendra Grant

5 posts

Posted Tuesday, March 18, 2014 at 4:32 PM

Hi!

Great explanation. My only problem is all the html files are reading as docs in my google drive. When I look in my folder on my computer they are html but get converted. All the icons were doc images. Any suggestions. I'm just using the 30 day trial right now but don't think that is the problem.

Thanks for any help you can give.

Kendra

Robert Lengacher

122 posts

Posted Tuesday, March 18, 2014 at 8:25 PM

Hey Kendra,

You're probably using the default link that Google Drive gives you for your folder, which starts with "drive.google.com/folderview..."

Be sure to change it to googledrive.com/.../..." with the ... representing the string of character's described in Mike's original video.

Robert Lengacher

122 posts

Posted Tuesday, March 18, 2014 at 8:30 PM

Oops, looks like the most important part of my reply was hidden by the forum system. The beginning of the link should be "googledrive.com/host/..." instead of "drive.google.com/folderview..."

Hopefully the message board won't "mess" with this version.

Kendra Grant

5 posts

Posted Wednesday, March 19, 2014 at 6:38 AM

Hi!

Thanks for the reply.

I changed the file name, changed the folder to public, used the correct beginning link and I'm in Chrome. All the icons for the html files read as docs (even have doc icons) - they don't have any extensions. I noticed one story file is missing (can't tell if it is shockwave or html without the extension.  I went in and changed the name of the file anyway (from story to index) -   Here's the link - googledrive.com/.../0B-fIjwsm-ORueTVMVWJtTklXT3M

Robert Lengacher

122 posts

Posted Wednesday, March 19, 2014 at 8:10 AM

Kendra,  

I looks like you have a few files missing, specifically the story.html file that should have been renamed as index.html. Without that, your browser won't know which file to automatically launch (in a sense) when it sees this directory of files. I was able to get your project to launch using this link: googledrive.com/.../story.swf

You can either share the link above for users to access the module if they have Flash. Otherwise, it might be easier to remove all the files from the Google Drive folder, republish your project, rename story.html as index.html and upload them into this same folder.

Kendra Grant

5 posts

Posted Wednesday, March 19, 2014 at 8:13 AM

Thanks for the help! I appreciate it. This is just a quick demo file for a group project I'm working on so I'll use the link you sent me and play with the files a bit to see if I can't get them to work. It is strange as all the files are correct on my hard drive. They're just not transferring over correctly.

Thanks again!

Kendra

Paul Alders

263 posts

Posted Wednesday, March 19, 2014 at 4:13 PM

Hey everyone,

I combined my 'Google Drive portfolio' with Pinterest. Follow these three simple steps

www.eyespirations.com/.../share-your-articulate-portfolio-with-pinterest

User Rank Mike Taylor

940 posts

Posted Wednesday, March 19, 2014 at 6:50 PM

Kendra, can you check the setting that converts files to the Google Doc format and make sure that is OFF? You can turn it off in the popup upload dialog box like the one shown here: lifehacker.com/convert-files-to-google-docs-format-to-save-space-on-go-1412063260

Rebekah Massmann

190 posts

Posted Thursday, March 20, 2014 at 7:29 AM

@Mike, I'm  just getting around to trying your solution for setting files private and then sharing the link directly...seems they must have updated something on their end to take away this option. The "Preview" button you referenced is now grayed out, and if I mouse over it, it says it's available for public files only. Can you verify on your end just to make sure I'm not missing something?

On a separate note, can you recommend any services that would allow us to have secure data while sharing the published link and the course working? It doesn't have to be free. We're trying to get some kind of link to load into our LMS for published for web content (not the tracking/SCORM side).

User Rank Mike Taylor

940 posts

Posted Friday, March 21, 2014 at 5:39 AM

Rebekah if I share with specific people I see the preview link but for me it previews the html source code instead of the actual content.  For secure hosting, have you checked out Amazon S3? It is very reasonably priced and might work well for you. You can even try it out for free. http://aws.amazon.com/s3/faqs/  (We host a ton of courses on there too.)

Greg Smith

12 posts

Posted Friday, March 21, 2014 at 8:53 AM

Hi Mike, my company also uses Google Drive as part of Google Apps and am getting the 404 error as well. Do you think this is something that the developers are looking at or would opening a case help?

User Rank Mike Taylor

940 posts

Posted Friday, March 21, 2014 at 10:01 AM

Hi Greg! It seems not to work in the Google Apps version...or at least I haven't figured how to do it in there yet. That would be something for Google to address. I have access to both versions but only share courses like this via my personal Google Drive account.

Rebekah Massmann

190 posts

Posted Monday, March 24, 2014 at 8:56 AM

Mike, in my research I came across that option, and I'm looking into it. However, my concern is still whether the courses are available to anyone searching for them, or if it's controlled to only via the link.

Specifically, I viewed a blog post (www.articulate.com/.../how-to-use-amazon-s3-to-host-presenter-courses) about sharing content via S3 (though admittedly this is from 2008, so I'm not sure what has changed since then) and noticed in the comments: "As far as I can see we there is no way to host on S3 without revealing all to the world.”

Does this mean the content is publically searchable and available on the web? What has your experience been with hosting Articulate content?

Thanks!

User Rank Mike Taylor

940 posts

Posted Monday, March 24, 2014 at 12:01 PM

Rebekah, I saw a couple technical articles that made me think it was possible to share privately via S3 but they were a bit beyond me. We aren't concerned with our courses being private so I haven't tried it yet. I'll see if I can find out any more details and post back here if I do. Maybe someone else can chime in with some insight.

Rachel Anderson

7 posts

Posted Thursday, March 27, 2014 at 1:52 PM

Thank you SO much for this! Definitely a life saver!

Kendra Grant

5 posts

Posted Sunday, March 30, 2014 at 8:22 PM

Thought I'd put in an update. My files weren't uploading to Google Drive correctly (no extension). I went in to Settings - Upload settings - and unchecked Convert unloaded files to Google Doc format. Problem solved!

User Rank Mike Taylor

940 posts

Posted Monday, March 31, 2014 at 4:13 AM

Thanks for the update Kendra. Glad its working for you!

Gustavo Angulo

26 posts

Posted Tuesday, April 01, 2014 at 7:35 AM

I uploaded the files. The adress of the folder is: drive.google.com

But the file index.html appears like a document. I cannot open it.

I can open the .swf file.  Any ideas?

User Rank Mike Taylor

940 posts

Posted Tuesday, April 01, 2014 at 7:42 AM

Hi Gustavo! Make sure you use the path described in the tutorial that starts with http://googledrive.com/host/    then you'll append the folder ID to the end of that.   You'll also need to make sure the option for converting to the Google format is turned off.

Jessica Schwab

5 posts

Posted Thursday, April 03, 2014 at 11:16 AM

Hi! I really want to get this to work, but for some reason no matter what I do, I get the 404 error.

I have followed the steps several times, and from many browsers, including Chrome, but I'm still stuck. :(

I was wondering if perhaps there were any actions with the actual publish settings that might be causing it not to work. Any thoughts?

User Rank Mike Taylor

940 posts

Posted Thursday, April 03, 2014 at 11:54 AM

Hi Jessica! For this you'll want to publish to the web format. Is that what you're working with?

Jessica Schwab

5 posts

Posted Thursday, April 03, 2014 at 12:16 PM

I wish I could say I wasn't, but I was. I just can't figure out why it won't work for me...

Greg Smith

12 posts

Posted Thursday, April 03, 2014 at 12:19 PM

Jessica are you using Google Drive on your own or does your company use it? Sounds like you're having the same issue I'm having.

Jessica Schwab

5 posts

Posted Thursday, April 03, 2014 at 12:22 PM

Hi Greg! I am using it on my own. At first, I couldn't even get the content folder to upload. However,  I switched to Chrome and it came over, but still no luck on working properly.

User Rank Mike Taylor

940 posts

Posted Thursday, April 03, 2014 at 12:26 PM

Good point Greg. I don't think it will work with the Google Apps version. Jessica did you check to make sure the setting for converting it to the Google docs format is turned off? If you like I can try with your files? Just zip them up and share if you can?

Jessica Schwab

5 posts

Posted Tuesday, April 08, 2014 at 11:21 AM

So, I gave up for while....but I had a coworker help me today and she got it to work!

What helped me:

When you output, if it's just for viewing on the computer, don't publish with HTML5 as an option.

If you need it to be viewed via mobile device, publish and append HTML5 file name to the end of the folder link as mentioned above.

I also renamed my story.html file to index.html BEFORE uploading to Drive. Not sure if that made a difference, but I figure it can't hurt to put it out there.  

Karyn Romeis

9 posts

Posted Friday, April 11, 2014 at 7:44 AM

Like one of the commenters above, I tried this with my google drive within our company's space and it failed miserably. I tried it with my personal account and it works perfectly.

But I now have a different question. As far as I can see, it hasn't been asked above (although I might have missed it). If I want to make it possible for people to also view the module from mobile devices (assuming for the moment that the devices have the necessary app), do I need to rename the story_html5 and story_unsupported files to Index_whatever? Or will it figure itself out?

User Rank Mike Taylor

940 posts

Posted Friday, April 11, 2014 at 8:02 AM

Hi Karyn! It should automatically adapt to the correct file based on the device you access it with. If you like you can link it directly to the presentation_html5.html  Just add the file name to the end of your path.

For example,  

googledrive.com/.../presentation_html5.html

You can also test that it adapts using this default link. (It worked for me on my ipad when including the HTML5 output without the ipad app option)

googledrive.com/.../presentation.html

Posted Thursday, April 17, 2014 at 7:07 AM

This thread rocks - thanks to Robert and Mike - I reread today & was able to avoid operator error - works brilliantly!

jonathan kinlay

6 posts

Posted Wednesday, May 07, 2014 at 1:11 PM

Hi - unable to get this to work.  So far:

1) checked to make sure that upload settings are correct

2) renamed to index.html

3) got the tag after /folders and appended it to googledrive.com/hosts/

4) Also opened with with google drive viewer and tried that url

5) no corporate firewall

6) super admin privileges

Error 404 in all cases

Laura Lowden

72 posts

Posted Thursday, May 08, 2014 at 12:10 PM

I got it to work using the Google Apps for Education.

1. Uploaded all files (had to go back and upload the story_content folder) making sure NOT to convert.

2.  Named the file using the tag after folders/ and added it to googledrive.com/hosts/

3.  Added the index.html at the end of the URL

4.  Tested in Google Chrome and it works...

This may be deleted after a bit of time, but here is the sample link for others to try.

Folder:  drive.google.com/folderview

Storyline Link:  googledrive.com/.../index.html

Hope this helps someone else.  Thanks, Mike, for the directions above!

Posted Thursday, May 08, 2014 at 1:35 PM

Laura, which google apps for education did you use?

Laura Lowden

72 posts

Posted Thursday, May 08, 2014 at 1:40 PM

I used my school system's Google Apps for Education.  I had the option to make it public to the web.  I saw in some of the above comments that some people didn't have that option.  Maybe that was an admin decision?  

Posted Thursday, May 08, 2014 at 2:55 PM

Mike

This has been a great thread and I was super excited to try it. I have followed all of the directions and I am having one issue that I have not seen come up. I am able to get the link open but it seems to be stuck in the upload cycle. It doesn't start the course. It opens to the player screen and remains in the cycle. Yes I am working in Google Chrome, no doc conversion and the file name was changed. "index.html"

googledrive.com/.../0Byi-9jCZrsfRREtsMDdkMTFvMzA

Any ideas what I missed or need to do?

Laura Lowden

72 posts

Posted Thursday, May 08, 2014 at 5:18 PM

Lissbeth, at the end of that add a /index.html

googledrive.com/.../index.html

Posted Thursday, May 08, 2014 at 5:39 PM

Laura, at the end of the URL?

Posted Friday, May 09, 2014 at 4:39 AM

I tried it and I am still in the loading cycle. Don't know what else to do?

User Rank Mike Taylor

940 posts

Posted Friday, May 09, 2014 at 4:57 AM

@Lissbeth I'm getting the same thing. It sort of seems like not all the files/folders from the published output are there. Can you compare your local published folder with your Google Drive folder? If that's not it and if you can share the zipped version of your published output I can take a look and give it a try too?

Also, there is one other way you can launch your course without needing to change the file  name to index.html

1. Create a new folder in Drive and share it as "Public on the web."

2. Upload your published output folders/files to this folder.

3. Right-click HTML file (player.html, presentation.html, etc) and choose "Open with Google Drive Viewer"

4. Click the "Preview" button in the toolbar.

5.  Share the URL that looks like "www.googledrive.com/host/..." from the preview window and anyone can view your web page.

Gustavo Angulo

26 posts

Posted Friday, May 09, 2014 at 6:32 AM

Here i introduce you a project that i am working

www.googledrive.com/.../0B7i52ew4f84NMDVwX0xSV0YzQkE

There is some bugs yet.

Posted Friday, May 09, 2014 at 6:55 AM

Mike,

You were right. I was missing some files. I did however have to go in and delete all of the files and start the process over again before it would work. Thank you so much. This is truly exciting for me.

User Rank Mike Taylor

940 posts

Posted Friday, May 09, 2014 at 7:08 AM

@lissbeth Yay!!! I'm so glad to hear it is working now. I love it when a plan comes together! 8-)

Rebekah Massmann

190 posts

Posted Friday, May 09, 2014 at 7:10 AM

Submitting a comment to unsubscribe from the comments. Sorry!

Posted Friday, May 09, 2014 at 7:52 AM

For anyone else that comes after. When you publish your project, before uploading it to google drive, make a copy of your html file and rename it to the format that you need. I needed index.html.

Now you can go ahead and upload the course to the google drive and the link will work beautifully.

Thank you to everyone for all your help. This has truly opened another door for me in completing projects and sharing with my clients.

Mike, nice reference to the "A" team.  

Posted Friday, May 16, 2014 at 8:19 AM

I would rather use Dropbox since I have a corporate sign on to the service rather than my personal google account.  Are there instructions to making the Storyline course launch in Dropbox?  I cannot find anything and other options are not viable as needing a CC for Amazon and the tempshare will not complete loading my file at 99%.  Most of my elearning courses will be large simulations that need to be reviewed by SMEs before I post them to our customer facing website.  

Posted Friday, May 16, 2014 at 8:24 AM

Hi Heather, Not sure if this will help, but here is David Anderson's tutorial for using Dropbox: http://www.screenr.com/80Ls

Jessica Schwab

5 posts

Posted Friday, May 16, 2014 at 8:38 AM

Heather - you might try using Tempshare with Firefox. It seems to give me trouble if I use ie.

Kristin J

5 posts

Posted Tuesday, May 20, 2014 at 8:25 AM

Hi All -

Has anyone figured out how to post to google drive limited to just company associate's viewing and not public?

Thanks for your help,

Kristin

Joy McGinty

11 posts

Posted Tuesday, May 20, 2014 at 9:17 AM

Mike, this is truly fantastic! I have been trying to find a way to share my Storyline projects on the web without having to use an LMS host for some time now and had given up! I just came across your post/video and couldn't be more thrilled. Many, many thanks!!!

A Haq

1 posts

Posted Wednesday, May 21, 2014 at 8:17 AM

Hi Mike,

Is there a way where we can track student progress and time spent like we can on moodle? What would be the way around this?

User Rank Mike Taylor

940 posts

Posted Wednesday, May 21, 2014 at 9:01 AM

Hi A! This doesn't do any type of tracking. That is typically handled by an LMS like Moodle, etc. One way to track student completions without an LMS would be to embed a web form like the one shown in this community discussion community.articulate.com/.../25512.aspx

Melissa Morrison

23 posts

Posted Friday, May 23, 2014 at 6:44 AM

404. That’s an error.

The requested URL was not found on this server. That’s all we know.

This is the error I get.

Lauren Batzer

4 posts

Posted Friday, May 23, 2014 at 6:50 AM

I can't get my course to play.  I believe I am following all the directions - renaming the file, sharing with public, unchecking upload as Google format.  The only thing that I see that seems to be different than what everyone is sharing is that  when I am in google drive I have .../?authuser=0#my-drive/...  Could this be the reason the course wouldn't play with googledrive.com/.../0B8ijL_7IapM3Ml93OFZjQjMxNWs

User Rank Mike Taylor

940 posts

Posted Friday, May 23, 2014 at 7:31 AM

Hi Lauren! Are you using your personal Google account or an organizational Google Apps account?

Lauren Batzer

4 posts

Posted Friday, May 23, 2014 at 7:35 AM

I am honestly not sure Mike.  It is an account set up for our work, but I don't know how it was created.  I want to guess personal, but I am not sure.

Lauren Batzer

4 posts

Posted Friday, May 23, 2014 at 7:53 AM

Mike, I decided to try putting the files on my personal Google account.  I didn't see "authuser=0" anywhere in the url, but the new url still wouldn't play - googledrive.com/.../0B4V90hChLwDvU0tFYUFNbTNfWkU

User Rank Mike Taylor

940 posts

Posted Friday, May 23, 2014 at 7:57 AM

Unfortunately it doesn't work with Google Apps which probably what you have if it was setup for you through your company. If you're looking for other options there is a link above using Dropbox or if a temporary option might work you could always use our Tempshare tool (It is good for 10 days) . tempshare.articulate.com

Posted Friday, May 23, 2014 at 9:02 PM

Hello,

I've tried the above suggestions to upload my first Storyline course and still get error 404. I'm not quite sure where I am missing something. My course is rather large but I think I got the files downloaded into a new folder I set up in Googledrive.

I did the following:

Uploaded files to GoogleDrive

Set them all the "public"

Renamed the story.html to index.html

Added the code to the end of  https://googledrive.com/host/

Tried adding /index.html at the end, tried not adding it as well

Tried using this URL:

https://googledrive.com/host/0B1dT1uwqbA3EajVidFJiaUw0a0E

This is such a cool idea that I hate to give up on it now.

Thanks in advance for any suggestions! Love these forums!

Junaid Mangera

5 posts

Posted Monday, May 26, 2014 at 1:20 PM

Hi

Excellent Video and article.

I wanted to know is it possible to the course to blogger, if so how. Alternatively can the articulate be embedded into the blog.

User Rank Mike Taylor

940 posts

Posted Tuesday, May 27, 2014 at 2:33 AM

@Junaid I know there are ways to host courses in Wordpress as outlined here: multimedialearning.com/articulate-elearning-course-wordpress-lightbox

I assume there would be something similar for Blogger or try using an iFrame www.articulate.com/.../how-to-embed-storyline-content-into-a-web-page

@Darlene Couple of the 'usual suspects' to check:  you copied all the files AND folders from your output folder? Made sure that the setting to 'Convert' files on upload to Google was/is turned off?

Kristin J

5 posts

Posted Wednesday, May 28, 2014 at 10:33 AM

Hi All -

I got a course to successfully load to google drive and place great for a few hours.... However the audio only lastest a few hours.

Has anyone experienced this and know how to fix it?

Thanks

Kristin J

5 posts

Posted Wednesday, May 28, 2014 at 10:33 AM

Hi All -

I got a course to successfully load to google drive and place great for a few hours.... However the audio only lasts a few hours.

Has anyone experienced this and know how to fix it?

Thanks

Kristin J

5 posts

Posted Wednesday, May 28, 2014 at 10:35 AM

Hi All -

I got a course to successfully load to google drive and place great for a few hours.... However the audio only lasts a few hours.

Has anyone experienced this and know how to fix it?

Thanks

Kristin J

5 posts

Posted Wednesday, May 28, 2014 at 10:36 AM

Hi All -

I got a course to successfully load to google drive and place great for a few hours.... However the audio only lasts a few hours.

Has anyone experienced this and know how to fix it?

Thanks

Laura M

109 posts

Posted Wednesday, May 28, 2014 at 1:17 PM

Hi there,

I've been using this tip successfully since it was first posted! However, I've just run into a new issue and going back through the comments, I don't see anyone else with this same problem, so I figured I'd post and see if anyone could help:

I have everything uploaded, folder and files are set to public, files are NOT being uploaded as docs, and I've changed the presenter.html file to index.html. When I create the https://googledrive.com/host link all I have is a blank white screen, however the tab in Chrome displays the correct name of my course. The Articulate loading circle never appears. Any ideas? The files did seem to transfer fairly quickly, so I'm wondering if something is missing that I can't see (I've compared the files I have and they match other courses I'm hosting that play just fine). I've tried publishing and uploading the files numerous times.

Thank you!

User Rank Mike Taylor

940 posts

Posted Thursday, May 29, 2014 at 2:40 AM

@Kristin That is very strange. There shouldn't be any time-related changes to your files after you upload them.

@Laura It definitely sounds like something isn't  quite right or some files are being properly uploaded. Maybe try it in a new folder and double check that everything including all the sub-folders are shared as PUBLIC?

Laura M

109 posts

Posted Thursday, May 29, 2014 at 6:26 AM

Thanks for the reply, Mike. :) Unfortunately, after publishing the course to a new folder on my computer, as well as creating a new folder on Google Drive I still can't get it to work. I wound up trying the Tempshare program suggested above and it's working perfectly! I can't believe I hadn't heard of that until now. Another awesome resource!

Sarah Street

53 posts

Posted Thursday, May 29, 2014 at 6:58 AM

Excellent clear instructions, thanks. I've at last been able to share my input on one of the weekly challenges thanks to this!

Posted Wednesday, June 11, 2014 at 3:33 AM

Hi everyone

I have managed to publish my course to Google Drive, but for some reason the triggers I inserted to open Word-documents and pdf-documents aren't working. When I click on the links, I receive a 404 Error that says, "The requested URL was not found on this server. That's all we know." Has anyone experienced this problem and know how to fix it?

Thank you!

User Rank Mike Taylor

940 posts

Posted Wednesday, June 11, 2014 at 3:52 AM

Hi Maristi! Where are your documents being stored? Did you also upload them to Google Drive? Depending on how you inserted your links you may need to update them to point to the right place.

Posted Wednesday, June 11, 2014 at 4:10 AM

Thank you, Mike! I think that might be the problem. I'll go and update the links and try again.

Mike Denney

3 posts

Posted Wednesday, June 11, 2014 at 1:10 PM

Thanks Mike! I was having this exact problem, but your tutorial saved the day. Just wanted you to know a year or so more later, it's still helping us out!

Posted Tuesday, June 17, 2014 at 1:24 AM

Thanks Mike, Thats saves a lot of time and money

Best regardas,

Evgeny

Colleen Woods

11 posts

Posted Saturday, June 21, 2014 at 2:47 AM

Hi - so glad I found this buried in your system.... I have asked support a number of times how to do this... they said it could only be done using FTP.... etc etc...

WOW - thank you

Posted Tuesday, June 24, 2014 at 7:21 PM

Great post, thanks Mike. I struggled for hours until I came across this tutorial, then I had my test course up in 10 minutes.

Guy Fraser

2 posts

Posted Wednesday, July 02, 2014 at 8:49 PM

I found this post hugely helpful. Worked like a charm for Captivate 8 HTML5 files. Thanks very much.

Posted Wednesday, July 02, 2014 at 8:56 PM

Guy what steps did you take since you say it works with captivate? I've been using it with Articulate files and I haven't tried a captivate file yet.  

Guy Fraser

2 posts

Posted Wednesday, July 02, 2014 at 9:07 PM

Hi Lissbeth,

I published the captivate as an HTML5 ouput. Then I opened Google Drive in Chrome browser and created a new folder with the same name as the HTML5 output folder.

Then I took the HTML5 output folder from captivate, opened it, and dragged all the folder contents into Google Drive. I didn't need to rename the index.html file, as there was already and index.html file in there.

After that, it worked exactly like Mike's instructions - share the new folder to public, select the index.html - copy the unique part of the url, and paste it to the end of the googledrive.com/host/ url.

There's a setting in captivates publishing settings that causes some issues - "Scalable HTML content". If you ensure this isn't ticked, it should work no problem. If you have any issues with it, let me know.

Posted Monday, July 28, 2014 at 1:26 AM

Hi Mike,

I just want to know if I can add multiple folders of my storyline on google drive?

I was able to got a link from my first folder, but when I add another articulate it can show any ..it doesn't preview...Please help!

Thanks!

Primie

User Rank Mike Taylor

940 posts

Posted Monday, July 28, 2014 at 5:12 AM

@Primie, if you want to add another course you can put it in a different folder of its own. They don't all need to be in the same folder. Is that what you want to do?

Posted Monday, July 28, 2014 at 7:39 AM

Hi Mike,

Thanks for the response. I uploaded it on different folder. Fortunately I was able to got the link now. But still thanks for the advice.. ;)

Giang Duong

1 posts

Posted Monday, August 11, 2014 at 7:08 AM

Great video with clear instructions! Highly useful for our work! Thanks a lot Mike!

All the best,

Giang

Jack Hyland

4 posts

Posted Tuesday, August 26, 2014 at 1:46 AM

Partially works for me  - unfortunately embedded YouTube videos don't work.

Jack Hyland

4 posts

Posted Tuesday, August 26, 2014 at 3:45 AM

...but videos from file added to Storyline work fine

Laura Payette

26 posts

Posted Thursday, August 28, 2014 at 4:08 PM

I struggled with getting this to work and discovered, based on Lissbeth's comment, that for me I had to change story.html too index.html before dragging the folder over to Google. No idea why this order of operations made a difference, but it did!

Also, I don't have a clean URL like Mike does when I go to copy the end for hosting. Instead of seeing drive.google.com, I see drive.google.com. No idea whether that has some influence or not. ???

User Rank Mike Taylor

940 posts

Posted Friday, August 29, 2014 at 6:10 AM

Hey Laura! I'm not sure if it's related to this or not but Google has made some changes recently that could possibly have an impact.  The URL business is a bit clunky. I just manually change it.

Melissa Jorge

19 posts

Posted Monday, September 15, 2014 at 1:34 PM

Hi! I have been using Google Drive to create links but recently Google made some updates and I have not been able to create links.  Any work around to this? Or any suggestions of other ways we can create free links?  Thanks!

User Rank Mike Taylor

940 posts

Posted Tuesday, September 16, 2014 at 6:06 AM

Hi Melissa! I saw that Google made some updates and I just tried this with a newly created account and it still works for me. Under the settings button there is an option to "Experience the new Google Drive" and you do NOT want to do that. It breaks this hosting feature.

Tamara Seals

19 posts

Posted Wednesday, September 17, 2014 at 1:15 PM

I'm having the same problem.  I had a working link before I went to lunch and when I came back, I get an error page.  I checked my other links that have been working and they are not working either.  I have not clicked on the new Google Drive.  Any other thoughts?

clavicula f

6 posts

Posted Wednesday, September 17, 2014 at 1:38 PM

I suggest everybody to use Dropbox. It has the same, more reliable feature and it's a also handier. Just put your files in public folder (dekstop or web app), rename yourpresentation.html to index.html (like in Google Drive), right click to index.html and Copy public link. That easy.

Tutorial here: www.hastac.org/.../hosting-content-using-dropbox-public-folder

Tamara Seals

19 posts

Posted Wednesday, September 17, 2014 at 2:23 PM

I tried Dropbox but the presentation does not play.  I just get a white page.

Lesley Lewis

10 posts

Posted Wednesday, September 17, 2014 at 4:22 PM

I seem to be having the same problem. I checked my links just this morning and now they all give me a 403 error. I also checked dropbox however in order to share the files there, you have to upload it to a public folder and unfortunately i don't have a public folder in my account nor can I enable it since I need to have either a pro or business account to do so. Any other ideas?

Jill Staut

2 posts

Posted Wednesday, September 17, 2014 at 6:51 PM

Yikes - I am having the same problem.  After lunch today my project now throws a 404 error.  I guess that's one way to learn your content is being accessed.  My email box blew up after.  Unfortunately I can't figure out how to correct this.  I am hoping someone finds a way to get this corrected.  I did not update to the new drive, either.

Jay Yearley

33 posts

Posted Wednesday, September 17, 2014 at 7:54 PM

Yes, unfortunately it doesn't seem to be working currently. If anyone finds a way to get it going, please feel free to share!

Jack Hyland

4 posts

Posted Thursday, September 18, 2014 at 1:58 AM

FYI - I've tried doing this with Microsoft's OneDrive using the same instructions as above but it doesn't work

User Rank Mike Taylor

940 posts

Posted Thursday, September 18, 2014 at 3:48 AM

I wonder if Google is rolling out changes gradually. I just created a new account to test this and it is still working for me. I even tried it with the new version of Google Drive. I'll keep digging to see what I can find out.

It might be worth double checking that nothing changed with the Sharing options, etc and that is still "Public on the Web"  I also saw that someone had 2 index.html files and had to delete one to make it work. Keep us posted if you discover a solution.

It looks like new Dropbox accounts can't get the Public folder functionality with a free account either. What a bummer!

@Jack I don't think this is possible with OneDrive

Lesley Lewis

10 posts

Posted Thursday, September 18, 2014 at 2:51 PM

Just an update, I just tried re-uploading and re-linking my files again using the same google account ( i changed nothing) and it seems to work now. Hope everyone else is as successful.

Tamara Seals

19 posts

Posted Thursday, September 18, 2014 at 2:55 PM

Yes, I didn't do anything but tried it again today and it is now working.  Yeah!

User Rank Mike Taylor

940 posts

Posted yesterday at 3:28 AM

Glad to hear it is working again. Hopefully it was just a technical hiccup of some sort and will keep working for everyone from now on.