Drag Objects not snapping

Hi All,

My client reports that although drag & drop items snap to their respective targets perfectly when viewing Story file or in Review, after they upload a SCORM file to their LMS, the "snap" function doesn't work.

Is "snap" not supported in SCORM? I am not sure which version of SCORM they've used to publish.

Could this be a function of their LMX platform?

Any thoughts appreciated.

13 Replies
Joshua Crigger

Hi Charles,

Thanks for reaching out. The snap functionality of the drag and drop question feature is supported in SCORM output. I was able to test exporting my Storyline 360 project to SCORM 1.2 and uploaded this to Moodle for testing and found it to work great in Firefox, Safari, Edge and Chrome.

Here is the test link if you want to try it out: https://articulate.moonami.com/mod/scorm/view.php?id=532

Under Drag & Drop options, I had selected to have this snap to the center as seen below but this was only my preference. 

Screenshot

Could you share more information as to what settings you have selected? What LMS your client is using?

I'll be standing by!

 

Charles Radanovich

Hi Josh, thanks for the reply.

My client said she output both 1.2 and 2004 but was told that 2004 works best. I've reached out to ask if she actually uploaded and tested the 1.2 version as well as the 2004. At this point I don't know what they've done.

This is a division of a large company just transitioning their education to the eLearning platform and this is they're first project. It involves several different modules created by myself and a larger e-learning company who reps the Articulate software and does production as well.

I think when she refers to being told 2004 is best, that info is probably coming from the company internal IT people, not the Articulate rep company. I'm not sure.

They are using an LMS platform called Dupral, but that's really all I know.

Can you tell me about Moodle? Is that something I can utilize for testing myself? I really don't know about it, being new to this. I have worked for quite awhile for this client but as their PowerPoint provider.

My settings in the Story file match yours except I don't have items return to start point or delay drop states until submit. They each snap to a hotspot and show correct/incorrect/retry after submitting. The quiz works fine in Storyline and in Review.

Thanks for your insights,

Chuck

Joshua Crigger

Hi Chuck,

Sorry about the link. I have added guest access and you should be good to use that now.

Testing on SCORM Cloud would be good. Loopback with how that goes. I have not used the Drupal LMS integration but if we can test and this works in SCORM Cloud then we can narrow down the problem a bit further as you stated.

As for which is best SCORM 2004 / 1.2, their places. In general, though we would suggest  SCORM 2004 as it is able to read and write, as well as provide more metadata and tracking options over ver. 1.2n and the larger suspend data limits. Here is a great article if you would like to learn more: https://scorm.com/scorm-explained/business-of-scorm/scorm-versions/

Hope this helps

Charles Radanovich

Hi Josh,

Just to follow up, I made the LMS zip using SCORM 2004 and uploaded it to SCORM Cloud.

It works just fine. I forwarded the link to my client so their IT people can try to figure it out from here.

The funny thing is there is a text based "fill-in-the-blank" quiz that is a custom drag-drop setup using target hotspots as well and it works fine for them. It's essentially the same setup as the one they say didn't snap for them.

I'll let you know if there's further resolution on their end.

Charles Radanovich

Hi Josh, I'm back...

I recently exported text to Word for my client to distribute to various markets to translate.

They sent back the first of about 13 languages and I see the custom line and paragraph spacing is all gone.

I checked the Word document that they sent back to me with the Story file and it has it's original spacing, the way I sent it.

I just tried the import myself and got the same result -- my custom line and paragraph spacing is all trashed.

I know there have been issues with this for years, but is this still a known problem? This represents a lot of work I wasn't anticipating.

Thanks, Chuck

Alyssa Gomez

Hi Charles,

It sounds like your custom paragraph spacing settings were lost after you imported the translated Word document, is that correct?

Our team is investigating this problem, and I'll certainly add your experience to our report. 

I apologize for all the extra work this has added to your plate! At this point, I haven't found any workarounds for this bug. If we do discover something, I'll be sure to let you know.

I have this thread tagged to be updated as soon as we get any new information. 

Charles Radanovich

Hi Alyssa, yes the paragraph and line spacing both are trashed.

There are threads about Word import for translations going back many years. Can you tell me if a fix is in the pipeline for this?

My client's corporate parent company specifically purchased this software to move from PowerPoint to e-learning and they are global, so this is a big issue.

I would need to input text at a 1 (default) line space to avoid this, but that is just not feasible for the kind of content they develop.

It seems to me that if the Word doc preserves the font/size and spacing, Storyline should do the same. It does keep the font/size formats, just not the spacing!

Charles Radanovich

Thanks for the update. I have also started a new thread since this one is really not on this topic.

the name is Translation import from Word loses formatting

I am hoping for a bug fix soon as my client is very unhappy. Their purchase decision was very much based on easy translation. They publish in 28 languages so you can imagine the extra work this bug is causing.

Can someone please let me know if a fix is in the pipeline? and when to expect it to be ready.