Allow seeking set to NO on slide layer not working

Hello,

When I set Allow seeking to NO on slide layer , the timeline is still showing.

I have set the layer to:

-Hide other slide layers

-Allow seeking: No

When I click on the button to see the additional information on the layer, while the timeline hasn't finished, I see the timeline continuing...

Is there a way not to show the timeline on the additional layers?

 

Thanks,

Julie

10 Replies
Julie Frappier

I read the following: If the seekbar on the base layer is draggable (Which in my case it is), then the seekbar on a slide layer will be draggable unless you select Allow Seeking: No. With that setting, the seekbar is ignored and will not visibly progress. - Which is not the case.

What am I missing?

Thanks,

Julie

Ren Gomez

Hi Julie,

Selecting the Allow Seeking: No option will not remove the seekbar from the base layer, it just won't allow the user to control the playback of that layer.

There's not a way to remove the seekbar on slide layers. You'll have to remove the seekbar from the player entirely if you prefer not to show it. Hope this helps!

Jennifer Bircher

Hello! Maybe I am missing something, but I have set the Allow seeking option to NO on a layer, but I can still drag the progress bar when that layer is displayed. I thought that option would "freeze" the seekbar on the layer so that it cannot be dragged. The only option selected in the layer properties dialog is to Hide other slide layers. Any suggestions? Thanks!

Jennifer Bircher

Hi Becca - thanks for your response and sorry for the delay! I'm not able to share the original file, but I reproduced the issue in a small file (attached).

I think the functionality I'm experiencing is by design, although it seems confusing to me. As I mentioned, when the layers are set to NO seeking, I can still drag the seekbar, which plays the audio from the base layer. So I'm assuming Storyline is "freezing" the layer seekbar functionality, but is NOT freezing the base layer seekbar functionality. The base layer seekbar is therefore active, so users can drag it.

If the above is correct, I'm basically looking for a way to freeze the entire seekbar when users are viewing a layer. Otherwise, if they drag the seekbar, they will get audio related to the base layer, which is not in alignment with what they are seeing on the layer. Thanks!

Maria Costa-Stienstra

Hi GuyKat.

When you choose Yes in the Allow Seeking option, the layer's content is synchronized with the seekbar. For example, learners can use the seekbar to rewind and fast forward if the layer has a video.

When you choose No, the user can still interact with the seekbar, but it won't control the layer's timeline. 

If you don't want the user to be able to use the seekbar, then the current option is to remove it from the player, as Ren mentioned above.

I hope this helps!

Jennifer Bircher

Hi all, and my apologies for not following up on what I learned from the engineering team. They confirmed my thought that, by design, the base layer seekbar is still draggable when the current layer's seekbar is set to No seeking.

I was hoping to "freeze" the base layer seekbar after the learner experiences the base layer and moves on to Layer x. But no can do. The way it works now is that if learners are on Layer x and manipulate the base layer seekbar, they hear the base layer audio but are seeing the (non-audio) Layer x visuals. Potential for confusion there, imo. I am planning on submitting a feature request. Thanks!