Auto play of vimeo videos

Hi everyone

We are embedding videos using Vimeo embed code. This all works ok, but I can't get the Vimeo videos to play automatically. This means that anything that is synchronised with the slide's timeline goes out of time with the video because the video waits for the user to click on it to start it.

Any help would be appreciated.

David.

21 Replies
Ashley Terwilliger

Ah, sorry for the confusion Theresa - but this discussion was in the Storyline section of ELH. Since you're struggling with the embed code for a Vimeo video I'd love to take a look at what you're using and I can add that to a Presenter course to share with you. Do you have code or a link to the video that you can share here? 

Also, here's a quick tutorial on how to embed videos into Presenter '13.

Beth Haselhorst

Hello.

I used to have success with the above code for autoplaying vimeo videos, but not anymore.

Until very recently, I successfully made Vimeo videos autoplay when they are embedded into Storyline by adding ?autoplay=1 after the video ID like this: (which is how I believe the file Alyssa Gomez attached above works as well):

<iframe src="https://player.vimeo.com/video/267295311?autoplay=1" width="999" height="562" frameborder="0" allowfullscreen=""></iframe>

For some reason, this has stopped working. The video appears to want to autoplay because the pause button is activated, but you have to click the pause button and then click play to make the video play.

Does anyone have any idea what might have changed that using the code above no longer works to autoplay and if there's anything else I can do?

Vimeo instructs you to click Share on your video > Show Options > Select Autoplay. Then get the embed code. That has never worked for me, but the above has… up until now.

Any help would be greatly appreciated. We have several courses that pull in Vimeo videos like this on our LMS.

Thank you!

Beth Haselhorst

HI Ashley. Thanks for the response. Videos are not on the first slide, but it does appear to be a Chrome issue. Videos autoplay in Internet Explorer. The link you shared above said the December update should fix this (as long as videos aren't on the first slide, which mine aren't). Unfortunately, my storyline 360 is up to date and it's still happening. I went ahead and created a new course just now to test from scratch. Any other suggestions? 

Thanks so much! 

Beth Haselhorst

Hi Alyssa.

I've attached the story file with the embedded vimeo video that isn't autoplaying. If helpful, here is the Articulate Review version of the course: https://360.articulate.com/review/content/b7bcb443-6af4-4d37-9b95-852216c3ea4b/review .

The second slide has the video. It autoplays in Internet Explorer, but not in Google Chrome.

Thanks so much for any help you can provide!

-Beth

Mike Song

H and thanks Lauren.

However, the browser that I use is irrelevant. The browser my clients use is what matters here.

What is the single best workaround mentioned in the thread? I am not clear on that.

Warm regards,

Mike Song | CEO | GetControl.net | 203-457-0444 | ms@getcontrol.net
See Keynote Topics and TV Appearances: www.getcontrol.net/speakers

Seth Ozen

This was mentioned before.
Autoplay is currently restricted in the following:

Safari version 11+ (Desktop)
Chrome version 66+ (Desktop/Mobile)
iOS (Safari, other mobile browsers, apps)
Firefox 66+ (Desktop/Mobile)

There is no way to stop these autoplay restrictions. You can mute your video to circumvent this restriction but, it will require users to click the Unmute button instead of the Play button, which, in turn, defies the whole purpose to begin with.