Delete Content on Slide

Oct 08, 2014

I JUST started playing around with Storyline, and no matter what I do I can't figure out how to remove content. I inserted a video to practice, and if I select the picture and hit "delete" or "backspace" nothing a happens, if I right click there is no option to delete either. How do I do this??

19 Replies
Phylicia Christian

Hello,

I'm using a PC. When I right click on the video, I have these options:

Cut

Copy

Paste

Button set

Drag and drop

Preview

Set poster frame

edit video

Bring to front

Bring to back

rename

save as picture

size and position

format

There is no option to delete or remove, and I still can't delete by using the keyboard

Emily Ruby

Hello Phylicia!

You can use the cut option to remove it, but you should still be able to select the item and use the keyboard delete key.

I tested another file and am able to delete videos with no issue.

Have you tried the repairing Storyline that I linked above?

you can also attach your file here if you would like us to take a look.

Jim McKay

No, running on a PC.  There is no delete option in the menu or when I right click.  For some reason I never thought of clicking on an item and then using the delete button.  That works fine.

I can delete with a right click in story view mode but when I am working on a slide there is no option.  I always found that odd.

Ashley Terwilliger-Pollard

Hi Jim,

Within story view, you'd have the option to delete and that's the entire slide (or scene depending). But on an individual slide itself, you can use the cut option while right clicking or the delete key (the latter doesn't always work for me on the Mac, but works natively in Windows). 

Sarah Bowes

Hi Ashley, I am having issues with deleting content on the slide as well. I have been using the Cut option, but it is not working. The only workaround I have found is to make the object layer invisible. 

It does seem to be a glitch of some sort. See attached file, and see slide 1.12 and 1.14 for icons or elements I have made invisible and wasn't able to delete. 

Thanks. 

Adam Lavery

If anyone has to ask how to delete something then this can't be anything other than poor UI design!

Just encountered this with a button. Select it and hit delete and it starts deleting the contents. Right-click, no delete option and cut is disabled. Only way I found to delete it is to select it in the timeline and cut it. I don't want to cut it - I want to delete it! And when editing the text, the cursor is almost invisible so no idea you're editing  the text. 

Just follow standard UI practice then anyone working on Windows or Mac (a Mac is a PC too!) will know what to do. Madness!

Adam Lavery

Not for a button it doesn't. Try it. Just spotted that if you hover over the edge of the button until you get a move icon then right-click gives more sensible options. But still no delete - just cut.

The point is to follow normal practice. When I right click on something I expect to get an appropriate context menu. Shouldn't need to know to right-click a specific part of something to get the appropriate options.

As I say, anyone having to ask such a basic question means the UI is lacking.