Exit Course buttom in Windows

Hi everyone, i have a big problem. I set a button to exit the course, but I can not make it work on Windows. When I upload in Moodle and pressed the "exit" is displayed the following "The content has ended. You may close this window". does not close the popup screen

Anyone know how to configure it to run on Windows?

Thank you very much!

8 Replies
Ashley Terwilliger-Pollard

Hi Maria,

Sorry to hear about the odd behavior with your course - but the "exit course" trigger is one that is known to cause issues as described here based on the browser security, or even the LMS. You may want to review those troubleshooting steps and see if any of them help with your particular issue.

Chris Burkholder

Ashley,

I am trying to make the popup window close as described above when closing a LMS project.  I found the solution to change the configuration file as stated in your link.  Is there a way to set a default in Storyline 2 so that the configuration: EXIT_BEHAVIOR = "ALWAYS_CLOSE_TOP".  This would save me a lot of time from having to change the configuration file on each LMS package I create.

 

Thanks,

Chris

Ashley Terwilliger-Pollard

Hi Chris,

Unfortunately that is not something you can change as a default within Storyline, and you'd need to change it within the package each time as you mentioned (which as a reminder we can't offer support for modifications to the published output). 

As far as making it a default though - you can always share your thoughts on that in the form of a feature request here! 

Sarah  Newsom

I am having a similar problem, but only intermittently.  In my LMS, in IE, when the user selects the close course option on the LMS Player, it opens a popup that says "The webpage you are viewing is trying to close the tab.  Do you want to close this tab?".  If my user says Yes, the LMS completely closes.  If my user says NO, it closes the course.  In Chrome, there is no popup.  I opened my configuration.js for a course that has this popup in IE and a course that does NOT have this popup in IE.  They both have var EXIT_BEHAVIOR = "SCORM_RECOMMENDED"; as their setting.  Why would the popup appear with one course and not the other?

I changed the properties for the course that is giving the popup to "ALWAYS_CLOSE"; then to "ALWAYS_CLOSE_TOP"; and the course reacted the same way with the popup.  Thoughts?

Debs Churcher

I don't suppose there is any update on this?  I have the same issue and despite changing it in my configuration.js (software file) - when I then publish, this is ignored and reset to 'SCORM_RECOMMENDED'.  I then have to change it in the scormdriver.js after publish before zipping and uploading.  What is the point of having a configuration setting if you're unable to change it - am I doing something wrong?  Hopefully someone can help :)

Jean-Christophe Goyette

The best way to solve this problem is to unzip your SCORM file (into a new folder to keep everything together), go to lms folder, open the scormdriver file in Notepad, scroll down to the var EXIT_BEHAVIOR part, swap it to ALWAYS_CLOSE_TOP, save the file and THEN re-zip the SCORM files into a new one.

The reason why I used this is because some computers/machines don't have admin rights... and editing the main configuration.js file requires these. Given that Storyline uninstalls and re-installs itself for each update, that's the next best thing...

Right now, the main issue is that you need to edit and save the Configuration javascript file, just to change one variable. That file is considered a source file, which requires admin access to edit (depending on your job if you have them or not), and it doesn't help that the file resets itself everytime there's an update. I don't see people calling tech support just to change one little variable.