Storyline 2: Where's the setting to prevent video compression?

The "What's New" list for SL2 says I can keep videos from being compressed during publishing. But I don't see how. The Publish Quality window looks the same as in SL1, with the Video Quality slider only going to "9"/"higher quality." 

So where can I set it to HIGHEST quality, i.e., don't compress it?

48 Replies
Mike Enders

Hi Judy,

To not have your video be touched at all, the video has to be .mp4 (encoded with the h.264 codec). If the compression dropdown isn't available, it's likely that your video is in a different format. For example, let's say that you inserted a windows media video,. Storyline will need to convert to .mp4 so that the video will play on the widest range of devices. As a result, compression will happen during the conversion.

Mike

Brian Batt

Judy Nollet said:

Thanks for the link to more info, Brian. As I said previously, it seems that Articulate is making the no-compression feature user-UNfriendly. It's easy to ask for .mp4 videos, but if I have to start requesting special compression profiles... :-(


Hi Judy,

Most mobile devices can handle MP4 videos with a baseline, high, and main profile. Once you venture outside of those profiles, the mobile support on both iOS and Android devices dwindles considerably.

When we implemented the feature in Studio '13, we tested hundreds of MP4 videos. Looking back at my notes, we only found a few videos that weren't encoded with those three profiles. Instead of having those files not play in your output, we encode them.

Mike Enders

Hi Judy,

Sorry for the frustration. I wanted to offer up a great primer video on video containers, codecs, and formats. It should help explain why Storyline converts everything into the h.264 codec.

I think you'll find that asking for the h.264 codec isn't a unique request for most video producers. Most tools even have that as a preset for rendering.

Mike

Josh Clayton

I am having the same issue. MP4 file but no option to avoid compression.  

I originally tried with a Storyline 1 file that I opened in Storyline 2.

Then I tried reinserting the video.

Then I tried creating a new project in Storyline 2.  

No luck.  I will check with our videographer, but I'm pretty sure it is the correct codec.  Any other tips or workarounds?

Josh Clayton

Hi Ashley,

The option is greyed out for me, just like Judy Nollet.  I confirmed it was MP4 with correct codec and Articulate Platinum Support was able to recreate the issue.  Cleo said "I was able to replicate the issue you reported. After the video was imported in Storyline 2, the compression option is disabled and set to "Automatic."

He then advised me to to reconvert the video using HandBrake (http://handbrake.fr/), which is a free tool. He gave me a video screencast on how to use HandBrake to convert videos to be used with Articulate software: https://player.vimeo.com/video/145574235

He thought there may be something with the Final Cut Pro H.264 codec.  To me, this is unacceptable and Storyline 2 features have to work with Final Cut Pro without workarounds.  I have dozens of videos that need to be converted.

Can we get confirmation this is a known bug and a timeline to fix?

Ashley Terwilliger

Hi Josh,

I checked in with a few of my colleagues, and it seems that the codec is less of the issue, and it's more associated with the profile it was created with. You'll need to have an MP4 that is created with the correct profile. The three most common MP4 profiles: baseline, main, and high. If the Compression property is grayed out in Storyline, it means your video was created with a different profile

According to that wikipedia article linked, there are 22 different profiles, so I'd look into what profile they were created with in Final Cut Pro. 

If you have a case number you could share with me here, I can check into the case you were working on with Cleo as well. 

Josh Clayton

Hi Ashley,

Our videographer went to film school and has never heard of profiles.  A quick look in Final Cut Pro makes it very difficult to find a profile setting and a google search didn't help either.  Can you give some insight into 1) How to determine what profile the video is in? and 2) How to set profiles so they work with Storyline 2?

Thanks.

Josh Clayton

I think I have isolated the issue.  

Running them through handbrake didn't help until I went to Tools>>Options and set MP4 file extension from "automatic" to "always use MP4."  Then when I imported them to Storyline 2, they were recognized as MP4 instead of M4V.  Hopes this helps you isolate the problem and make it work with MP4 videos created in Final Cut.  

Theodore Svoronos

For the record, Screenflow's mp4 export explicitly stated that it was H.264 with a Main profile, and still the option was not available. Running it through Handbrake as Josh suggested fixed the issue, but this sure seems silly given that Screenflow has settings that adhere exactly to what the Articulate folks have required.

Jay Sprout

Why not just give the user more control (with this and many other Storyline features)? When I export MP4s with the h.264 codec, the files are way too large (not compressed enough, for my taste) but if I compress or optimize the video myself I have to live with however Storyline chews it up with its "automatic" compression.

Cassidy Furnari

Hello,

I am reading a lot about how an MP4 video needs to have been made in a certain profile or be encoded with the h.264 codec in order to access the video compression menu. Can someone explain to me how to tell what profile the video was created in or if it is encoded with the proper codec. I was sent these videos, and am not very up to date on video editing.

Thank you