Timeline starts on Slide 2 but Media does not when published

I have tried a number of solutions from other discussion threads without luck.

This was not an issue when slide 2 was slide 1, however when the project was opened it would start with a play button. It was suggested that I add a title slide without media on it so that the module just starts when opened. Now when it goes to slide 2 the timeline starts but the audio and video media do not. It works fine in Preview, the issue is only after it is Published.

If I pause and play the media will start but be off from the timeline. If I go back to the slide or skip to it, it will play normally. 

I tried using a trigger to have the media play when the timeline starts on the first text box  which did not work and I inserted a new object off to the side and changed the trigger to play media when the timeline started on the object but that did not work either

Please help. 

2 Replies
Maria Costa-Stienstra

Hi, Amanda, and welcome to E-Learning Heroes! ✨

Thank you for sharing your .story file!

Some modern browsers no longer allow audio to autoplay. If you have audio on the first slide or set it to advance automatically (which is the case), the browser will expect the user to click. 

Here is the workaround:

  • Set the first slide (or the slide that comes before the one with the audio) to advance only when learners click a button or interact with it in some way.

Since you left the Next button on your first slide, you can see that the audio will play as expected if the user clicks that button before the timeline ends.

Let me know if this helps!