Triggered state not working

Jul 23, 2021

 I'm trying to rotate a rectangle so it pivots like a see-saw. I changed the state of the rectangle (by adding another invisible shape over it in the new duplicated state, grouping them, and then rotating). I added a trigger (when the timeline reaches cue point 1). Nothing happens. I've tried multiple versions and almost started to create layers, but I'm sure there's a simple explanation.

Can someone take a look at my slide and please tell me what I'm missing? I've taken everything out except those two simple elements. Could it be that we can't make an object rotate in States??

Thank you!!

5 Replies
Walt Hamilton

Your problem is the group. 
I used a group in SL once, and it worked the way I wanted. I think it was in 19... No, wait. I'm thinking of another program, Maybe ... Well, it doesn't matter; the point is that groups don't work in SL. Pretty much you can use groups, or you can have triggers and states that work, but not both together.

I think you are overthinking this. I created a rectangle, duplicated it, and rotated the duplicate. I copied the rotated version, edited the non-rotated version, and created a new state. In the new state, I deleted the original rectangle, and pasted the rotated version. (The secret is that I had to rotate it outside of editing the states.) You may have to adjust the position. I named the state Selected, so you can click it and see the change of state without having to write triggers, but it still works with the cue point.