"Allow drag after completion" feature not working after software update

I am facing this issue recently. I have been using the player feature "Allow drag after completion" for my videos in my projects from more than a year but after the recent storyline update , this feature is not working. I even created a new project to test and tried but no success. Please help.

40 Replies
Lauren Connelly

Hi everyone!

I'm happy to report back to this discussion with an exciting update! We released this fix in Storyline 360 Update 40 (Build 3.40.22208.0) today! 

The fix is for the bug where learners couldn't drag the seekbar when revisiting a slide even though the seekbar was set to "allow drag after completion."

Now all you need to do is update Storyline 360 in the Articulate 360 app.

If you're interested in seeing all the other goodies included in this update, head over here to see our Storyline 360 release notes. 

Erik Abasciano

Hi,

I was almost really happy. Maybe its just me. I did do a quick test when I first heard the news but only locally and it worked. But then I uploaded to our LMS.

The problem I am running into is the allow drag after completion does work after you view a slide but as soon as you close it down and try to go back and review that same module, the allow drag feature doesn't work.

I tested it in Scorm Cloud just to make sure it wasn't an issue with our primary LMS which is SAP Litmos.

I posted two test using the same settings; One with 3.35 and one with 3.40.

After you close the 3.35 version and reopen it works fine. If you close and reopen 3.40 it defaults back to what it was doing prior to this latest update.

I will try to post the links to the two tests in Scorm Cloud

3.35 test:

https://cloud.scorm.com/sc/InvitationConfirmEmail?publicInvitationId=8d14772e-95e4-4cf7-8d07-d664485c45a4

3.40 test:

https://cloud.scorm.com/sc/InvitationConfirmEmail?publicInvitationId=f331b4a9-15c3-4fdf-bb64-055ef77ef9aa

Please let me know if anyone else is running into the same issues?

Thank you,
Erik

 

Lauren Connelly

Hi Erik!

Thank you so much for adding the links! I've tested both and I can see the difference between 3.35 test and 3.40 test.

However, I think this issue might stem from the setting in 3.40 test rather than an error with Storyline 360 Update 40 (Build 3.40.22208.0). I've recreated a project using Update 40 and I didn't come across a similar snag with the seekbar.

In the course, I set the Resume behavior to Always Resume. I also added two variables that marked each slide complete when the timeline ended. Do you have the Resume behavior set to Always Resume?

You can see my test here! I've also attached the .story file to this reply.

Erik Abasciano

Hi Lauren,

Thank you for the detailed follow up. I truly appreciate it. Adding the set triggers with the variables for each slide wouldn't be the funnest thing to do but I would definitely deal with it if I could get it to work.

I did have it set to always resume, slides were restricted. The differences I saw in the file you provided from the way ours is setup, besides the added variables, is we have slides set to automatically proceed after slide completes and I saw you selected when revisiting, resume saved state.

I think you had the right idea with showing and explaining so I provided what I was trying to do here.

I also attached the modified version of the file you provided to see if there was something I was doing wrong and maybe you could get it to work as described.

I did publish our latest program using 3.35 and it worked out great but I would love to use the latest version if possible.

I tried a bunch of different things to allow the previous slides to be viewed if they are automatically advancing.

Thanks again for all your help and detailed follow up.

Erik

 

Lauren Connelly

Hi Erik!

If I understand correctly, you're hoping the timeline starts over when a user revisits the project rather than the playhead appearing at the end of the timeline.

Unfortunately, the playhead will always appear at the end of the timeline because a course is marked "Complete" when the timeline ends.

I'd like our Support Engineers to take a look at both of the files to understand what the difference is. Do you mind sharing your files by using this secure upload link? Our team will take a look and share their findings!

Erik Abasciano

Hi Lauren,

Thanks for looking at it and yes I will upload the original two test files I did. One using 3.35 and one using 3.40.

But no it doesn't have anything to do where the playhead is appearing. The example I sent back won't allow you to go back to review slide 2 and 3.

After you sent the storyline file example and the video explanation with the added variables, all I tried to do was to add a few more slides and make it work the same way it works with 3.35.

This is the file I sent back. It was your file with a few changes. 

You provided an example of two slides with the variables added but both slides were set to be user advanced.

I added two additional slides. First slide advances by user, second and third are set to automatically advance, four slide is slide advances by user. I changed navigation to restricted. I added the variables to each slide and published.

When published, the first time you watch it works. When you reopen it to review. Slides 2 and 3 can't be reviewed. It kicks it forward to the last slide.

I don't think I provided the published version the last time, I just showed it in the video.

https://mpitraining.articulate-online.com/3085233680

But I will upload the original two tests i did using the same settings in 3.35 and 3.40.

Thanks again for the help.

Erik

Erik Abasciano

Hi Lauren,

Thank you for providing me the info to send over to the Customer Support Engineer team.

They looked into the issue and responded very fast. They were able to replicate the issues I have been having that correspond with this forum. They are going to look into if further but as a workaround right now, going back to version 3.35 is the way to go again.

I do appreciate you keeping us updated along the way and then trying to look into what was going on with my issue after it looked like it was fixed.

It looks to me they are almost there with the fix, sense the allow seekbar does work in 3.40 after the first time its reviewed. The only thing left is to keep that feature enabled when going back or reopening the course to review a training.

Thanks,
Erik

Vincent Scoma

Hi Erik,

Thank you for sharing this update with us! I am glad to see that Geovry was able to provide some guidance here. We'll be sure to reach back out with an update on the issue reported as soon as we have more details to share! 

Thank you again for reaching out and letting us know! 

Lauren Connelly

Hi Kelley!

I'm happy to help! Have you set the When Revisiting setting to Resume to Saved State? If not, that would be our first recommendation. If that doesn't do the trick, would you mind uploading the .story file so we can take a look? You can attach it to this discussion or upload it privately in a support case.

Roger Jennings

This bug still exists in 3.55.25975.0

Even though we have selected "Allow drag after completion", you can drag the video scroll bar in advance of the first play being completed. We have relied heavily on this setting in the past. As we begin updating old courses, this is a problem.

The bug exists if we build a net-new course as well.

Erik Abasciano

Hi Roger,

Since this was a big issue for us and it took more than a few versions for the fix to be finally applied, I try to pay attention to this post just in case it happens again. So when I saw your post, I did run a generic test. First locally and then posted a scorm version on scromcloud so I could be sure that it works the way we run them. And I found the drag after completion seems to be working, at least the way we have it setup in the settings. 

I would like to try to help if I can, I do not work for Articulate but I understand how frustrating this was when it didn't work for us and all the different ways I was trying to explain it and trying different work arounds but then realized a show and tell was the best. At the time I took screen shots of all the settings, made a simple version and posted the screen shots of the setting on test version and posted it on scormcloud for them to review and provided them with the original storyline file. 

Then there was a fix about a version or two after. But at the time we had to run a version of Storyline that was four updates or maybe even five behind before it was fixed.

Here is my test version running the latest update on posted on scormcloud. https://cloud.scorm.com/sc/InvitationConfirmEmail?publicInvitationId=c17f715c-37af-46e2-be28-408cd5818386