The audio stopped working in-between course on iPad

Hi Everyone,

I have created courses in articulate Storyline 3 update 4. When I view it from a PC or Laptop the audio is playing fine. When I view it on an iPad, the audio is completely stopped from any screen (not particular screen) and onwards audio stopped working.

I'm trying to figure out why, but stuck. When I refresh the browser, then audio is playing fine. This issue happened every review and I am not able to complete the review on iPad.

  • Use: Storyline 3 update 4.
  • I Pad: A 1475
  • I pad Version: 11.4(15F79)
  • Audio file format used: MP3 and WAV.
  • Browser :  Safari(Ipad).

Please suggest me any solution for this.

18 Replies
Katie Riggio

Hi, Akash. Really sorry you've come across this audio issue on an iPad–I'd love to help out!

I see a logged issue where our team is looking into the following behavior: audio not playing on iPad/iPhone when resuming a course using Safari, and your setup sounds similar with a slight difference.

Mind sharing your .story file with me, so I can take a closer look? I'm happy to test it on my end and let you know what I find. If you need to share the project privately, use this upload link. :) 

Katie Riggio

Really appreciate you sharing your project with me, Akash! I published your course to Web using Storyline 3 (3.4.15731.0) in which I could hear audio when testing the HTML5 output on an iPad Air (11.4.1) in Safari and Chrome.

Have no fear, though! I've escalated your case to our Support Engineers with my testing notes attached so we can keep digging. Someone from the team will be in touch shortly, and I'll be sure to also keep this discussion updated–I'm itching to know what's causing this! 🔎

Katie Riggio

Hey, Akash–and those following along!

Circling back here to note that we've got audio doesn't play on iPad/iPhone when resuming a course in Safari logged as a possible bug. Seems that the issue occurs when the learner resumes a course to a slide that has audio, but the audio plays on slides with video. 

One available workaround is to set the Resume-On restart property to Never Resume. Fingers crossed this option can work in the meantime while our team digs deeper.

Thanks again for working through this oddity with us! You're in the right place, and we’ll post all updates here once we have them!

Akash Jambhorkar

Hey hi Katie,

Thanks for the suggestions.

This issue is not related to the resume-on state. I am not exiting the course in between my review. Every time I reviewed the course in a single attempt.

Audio stopped playing from any screen or suddenly stopped when I clicked the buttons to reveal the pop ups/suddenly stopped on the screen.

Thanks

Akash Jambhorkar

Ashley Terwilliger

Hi Libby, 

I'm sorry you're team has run into the same issue. In the reports we've seen and confirmed, the audio was only not playing while viewing in Safari on an iPad/iPhone after the learner had resumed the course. Does that match what you've experienced? 

If not, could you let me know a bit more about your course setup? What version of Storyline are you using? What's the iOS of your iPad/iPhone? What happens with the audio? 

Libby Lussenhop

Hi Ashley,

No, the error is happening across all of our modules when being viewed from the first time (and from the first slide). We have cleared caches and cookies and tried all the local fixes that we can. The problem is that the audio simply is not playing at all throughout the module (whether voiceover, music track, or clicking sound effect).

We tried a fix in which we manually triggered audio to start with the timeline on the corresponding slide, and this partially resolved the issue only on the standard iPad but it's extremely inconsistent and still doesn't always work. Sometimes the audio will play, and sometimes it still won't. Sound effects (triggered by a click or other interaction) are similarly unpredictable and are generally not working. No audio works at all on an iPad Pro that we are also using to test.

We are using Storyline 3. All iOS are at the latest updates.


Libby Lussenhop

Hi,

I can't share a .story file because it's proprietary client work, but here is a video capture of the behavior of modules functioning inconsistently on iPad: https://vimeo.com/thescenemagic/review/284026583/9e2543205b

We're getting to a point with this issue where we will need to abandon Storyline altogether if there's no solution this week. Please advise ASAP. We're clearly not the only team seeing these serious problems.

Ashley Terwilliger

Hi Libby,

Thanks for sharing the video, and that demonstrated how it's not working on a Resume, which is an issue our team is looking into. In that instance, we've seen it only while resuming and if you're using the Safari browser, have you tried any other browsers such as Chrome?

You also mentioned from the first viewing that's it's not playing any audio, and it's inconsistent between devices? I understand if you're not able to share your file, but since it's the best way for us to demonstrate the problem and document a defect, we'd happily accept a .story project or link to the course shared here privately if you change your mind. Our team can also sign an NDA if needed.

We'll keep you posted on the issue I mentioned about resuming a course, and I'm sorry for the problems it's continued to cause. 

Lauren Connelly

Hi Vaibhav!

We'll want to grab a few details to understand exactly what you're running into!

Here are a few troubleshooting questions to get us started:

  • Which version of Storyline are you using? 
  • Which iOS version are you using?
  • Are you seeing this with every course or just one?
  • Are you viewing the course in Safari or another app?

Once we gather more information, we'll be ready to investigate further!

Ashley Thirtyacre

We are experiencing something similar (inconsistently).  For us, the audio and closed captioning work fine initially and then if we briefly get called away to another task (even if briefly for 5 minutes) and resume (even without ever exiting out of the course), the audio and closed captioning will occasionally no longer work (not consistent but has occurred in a variety of tests with different users, and different iPads). Additionally,  the audio volume button does not appear when using the iPad.  
Storyline 360 v 3.40
iPad: Software Version 13.5.1 
Safari 

With the same course, this does not happen on a Samsung Tablet.  Any insights would be greatly appreciated. 

Vincent Scoma

Hi Ashley,

Thank you for providing those details! 

When using an iPad and a different web browser, does the audio resume correctly when returning to the course? Or does this issue only happen in Safari? 

If you can share your file with us, we're always more than happy to help troubleshoot! You can share files in this thread here, or you're always welcome to share them privately here. We'll let you know our findings and will delete it after having a closer look!