Can't Skip 'Correct Answer' Slides on 'Custom Review' Slides

I cannot seem to effectively skip 'correct answer' slides during the review quiz sequence on Storyline360. I am using a custom 'review quiz' button and custom review slides that I built out using the methods suggested by Nicole Legault in her post 'How to Create Custom Review Layers for Storyline Quizzes'.

 

My hope was that I could develop a way to allow quiz takers to take the quiz and review the incorrectly answered questions; similar to the function in the native Review Quiz sequence that is available in Storyline – which allows you to set the review slides to show only those with incorrect answers submissions.

The Issue

During the review, the correctly answered questions slides are still showing and not being skipped. There is also a period where the entire question slide – including the submit button and an image, meant to be hidden – is shown before the 'Custom Review' layer is shown. Lastly, there is a "break-time" slide periodically through the quiz that I'd like to skip during the review process.

How My Triggers Are Set Up

How I used variables/triggers to identify correct/incorrect answers for a custom "show incorrect answers only" function: I set a trigger to change a custom variable for each question (i.e. Q01, Q02, etc.) to 'true' (correct) if the correct answer's radio button is selected when the user clicks the 'submit' button. 

How I used triggers to show the review layer and skip incorrect slides: I set a trigger to skip correctly answered question slides if the variable (i.e. Q01, Q02, etc.) is set to 'true'. If the question was incorrect, the 'Custom Review' layer on each question would show if the 'ReviewSlidesViewed' variable is set to 'true'. 

How I used triggers to show the custom review layers on each question slide during the review quiz function:  The 'Custom Review' layers are viewable when the 'ReviewSlidesViewed' variable changes to 'true' when the 'Review Quiz' button is clicked, as well as jump to the first question slide.

Any help solving this would be GREATLY appreciated. This is my first time building any eLearning programs and using Articulate/Storyline – and I am really stuck. I've attached the file for reference. Please help!

6 Replies
Ren Gomez

Hi Anthony,

Thanks for reaching out and sharing your file! There are few things I'd like to clarify with Nicole's video that I think will help!

  • Review Layer: If you rename your question layers to Review, then the built-in functionality in Storyline will show this layer if you use a Review results trigger in your Results slide. So I recommend removing the triggers and variables associated with these layers and renaming them from 'custom review' to just Review!
  • Results Slide: Currently, you have a Jump to trigger on your Review Quiz button. You can remove this and the related variables trigger. Then add a new trigger to Review Results. This will give you the option to review only incorrect questions.

I hope these tips help. Let us know if you have any other questions!

Anthony Rose

Hey Ren,

Thank you for your response. I tried your suggestions on a duplicate file and unfortunately, I'm still seeing the correctly answered slides during the review process. 

I should mention that I am using custom buttons on each Review layer to navigate to 'previous' and 'next' review slides – as well as hide the 'submit' button that submits selected answers on each question slide. Does this impact or override the 'Review results' flow?

Below is a screenshot of the trigger set for the 'Review results' trigger assigned to the Review Quiz button on the Results Slide:

Thanks for taking time to help me with this issue!

Anthony Rose

Hey Ren,

Thank you for your response. I tried your suggestions on a duplicate file and unfortunately, I'm still seeing the correctly answered slides during the review process. 

I should mention that I am using custom buttons on each Review layer to navigate to 'previous' and 'next' review slides – as well as hide the 'submit' button that submits selected answers on each question slide. Does this impact or override the 'Review results' flow?

Leslie McKerchie

Hi Anthony,

Thank you for reaching out and sharing what you are still experiencing in your project file. 

I was able to take a look and noticed that the selected answer was not displaying during the review either. However, if you adjust the slide properties to Automatically Decide vs. Reset to Initial State, this should correct the issue you're seeing:

Anthony Rose

Hi Leslie, thank you for that suggestion. I've made that change to all of the slides, however I am experiencing the same issues. Could the use of custom navigation buttons on the review slides with the same tigger (jump to next slide when user clicks 'next' button) cause the 'review incorrect answers only' function to not work? If so, how can I get around this?

Lauren Connelly

Hi Anthony!

Great question! For the question to be submitted, they'll need to press the custom "Submit" button that you have. If a question isn't submitted, then it won't show up when reviewing the quiz. I also changed the Submit Results on the Results Slide to appear at the top of the Trigger list. Please test the file and let me know if that makes a difference!