85 Replies
Mateusz Szuter

Ok seriously staff, for once be OK with your customers.

THIS. IS. 9. YEARS. BUG. 9. 9. YEARS. In 4 different versions of your software! Do your job and fix it! In very first place everyone of us, customers, users, want bug free software, not new (and sometimes broken also) functions, just... please, can everything work as it should? Can once you please not ignore things your users are reporting you?

Here's my insight. I hardly think that is the image itself problem. I've started with 4 story files. 1st and 2nd are based on the same story file (I've done 1st first, then copied and made it as separate 2nd project), 3rd is some other project, 4th is fresh project.

I can easily copy anything from project 3rd and 4th to any other project - no problem.

I can copy images from 1st OR 2nd to project 3rd and 4th.

I CANNOT COPY ANY IMAGE BETWEEN 1ST AND 2ND. It always ends with 'blank' placeholder. Something in the original project file went wrong, and made it for 1st and 2nd story file unable to copy images between them.

To test further - I've duplicated the 3rd non-problematic story file.

I can easily copy images between them 3rd and 3'rd story. Let's dig deeper.

I've deleted everything from 3'rd file (the duplicated one), saved it, reopen and... you probably guessed right - everything I try to copy from original 3rd project is now blank in 3'rd project.

So I went even deeper. Once again duplicated 3rd to 3''rd. I've found the screen where there's a picture only once used in the whole project. I've deleted it in 3''rd. Saved, reopened. Now I copy that one instance of image from 3rd project to 3''rd. IT COMES BLANK. Every other image copy alright.

So to check it once and for all, I do fresh Untitled project 1 (UP1) and paste random two images on two different screens. I duplicate it to UP2. I delete slide with picture in UP2. Save, reopen. I can copy Image 1 (undeleted) from UP1 to UP2. I cannot (blank placeholder) copy Image 2 (the one I deleted in UP2) from UP1 to UP2.

Conclusion: When you have particular image X in your story file, and you delete it from whole project and after that you try to copy that image once again into your story file from another story file, it will produce blank placeholder instead of the desired image. Some information of the image must stay inside the story file after deleting and software goes crazy when you try to recopy it inside.

After deleting the second image from UP2, I've extracted .story file using 7zip. In story/media folder there is our deleted picture, the thumbnail and normal one. Deleting it and repacking the story file however doesn't solve the bug. Won't dig deeper as that's not my job.

Exception: Using my 1st and 2nd project from the beginning (not the fresh UP1 and UP2), where 2nd is newer project and has some new assets inside which wasn't present in 1st, I still come across blank placeholder when try to copy fresh image from 2nd to 1st.

To pin this down took me 30 minutes and another 30 to write down that post as clearly as I could do... you had 9 years. Can you please at least eliminate that bug? AND PLEASE, don't try "submit support ticket" me. I know that post is in a little aggresive tone, but seriously I'm tired of "submit ticket" excuse in every other topic, when users which pay not a small amount for your application get flushed down with "submit ticket" when reporting any kind of bug.

Looking forward to your answer.

 

Lori Dresner

I also just ran into this issue (and this this thread) today. I need to copy and paste some images from a PPT file to a Storyline file, and I ran into the blank placeholder issue, despite trying multiple copy and paste methods. After seeing several threads about the issue, it seemed my only resort was to import the slides, so I did that, and it works, but it's pretty time consuming to import and then have to parse out what I need, as I'm updating many images in this Storyline file. I'll likely need to do this again for future projects. Will there be a fix for this?

Eitan Teomi

This is really just a rudimentary request. The only workaround, which is importing slides from different projects, is a clumsy solution and adds multiple steps to a simple copy/paste or drag/drop need. The issue is becoming even worse when the image to copy/paste is an image with separate states.

There has to be a way to fix this long standing issue.

Lori Dresner

Absolutely. Lately, with so many things I've been trying to do in Storyline, I've encountered some type of bug, and I don't even do anything that complex in it, just basic training courses with text and images, typically. This is just the latest thing, and I always search and come across multiple threads with people having experiencing the same thing. Customer service has helped me out several times in resolving my issues, but it can just be tedious to hit a road block with so many things and now just something as simple as copying and pasting. 

Lori Dresner

So this isn't good. The import feature was working yesterday, but today when I've tried to import slides today from PPT, I'm now receiving an error message that the presentation failed to import. I've already experienced a separate issue with something else trying to get PPT and Storyline to connect without success, so this seems as if it's probably related. And I just tested the copy and paste feature, and the blank placeholder issue is still occurring. I'm wondering how I'm going to get the images I need moved into this Storyline file without having to save them all individually and then insert them in. I really hope there's a fix for this soon.

Ren Gomez

Hi Everyone,

I appreciate you all chiming in that this longstanding bug is still affecting your work, and I’m sorry for the frustrations it’s causing.

To help clarify, the main issue mentioned in this discussion is the consistency in copying objects from one Storyline file to another.

Our team has found it challenging to replicate due to the random nature of when the bug appears. Sometimes we see the placeholder, and other times the object appears as expected. I even tried to replicate the process Mateusz recently laid out and successfully pasted the image multiple times.

Nevertheless, we’re tracking this bug and will continue to share your experiences as we work through the steps to get it prioritized. To help you plan, it’s unlikely to be fixed in the next few updates, but please continue to let us know when it occurs or connect with our support team to help dig deeper into the issue.

Lori - If you're also seeing issues connected to Powerpoint files that are not correctly importing into Storyline, I'd love to have you work with our Support Engineers and will have them reach out. The majority of the time, those situations are user or file-specific and quickly resolved with the help of our Support team. If it's determined to be a larger issue, we'll report it and circle back to this discussion. 

Ed Gen

I'm using SL360 and had a file that became buggy (this happens more than likely) so I needed to copy and paste all slides to a fresh file ... only to see that this 9+ year problem/bug is STILL not resolved??????

I get it, paying someone to fix this will not generate new sales/subscribers to Articulate's income statement, but give us a break here!!