57 Replies
Jeanette Brooks

Hi Benny! The default Invalid Answer message is something that Storyline generates automatically - it doesn't come from the Feedback Masters, so that's why you're not seeing it in your slide master layouts. But here are some things that you can do to customize it:

  • You can change the Invalid Answer text by customizing Storyline's text labels (the Invalid Answer text comes from items 17, 18, & 19)
  • You can also change the colors on the pop-up (check out this job aid if you need help identifying which parameters to change). 
  • If you'd like to completely change the visual design of the message, you could use the method shown here. It involves creating your own slide layer for the Invalid Answer message, and using a trigger to tell Storyline when to display that layer. It's a little more work, but it might give you the customized look that you're after.

Hope that helps!

Brian Dusablon

Jeanette Brooks said:

Hi Brian - try changing the parameter called Editor>slide text to white and see if that gives you the look you want.


Thanks Jeannette. That worked, but I was hesitant to change that setting because it would change default "slide" text to white. What is the definition of "slide" in this color setting?

simon norton

I have been struggling with making this work, even following the video in jeanie's post. It was working and has now stopped!

I have found another solution; you can disable a custom submit button (we were using a custom one anyway) and only enable it when you click on a response. This would ensure that the user has made a choice, as they cannot un-tick a box. The invalid answer screen will not show at all in this case, so it doesn't have to be edited. 

The only draw back with a custom submit button is hotspots don't work that well, and the storyline view turns into a horizontal nightmare!!!!

Ashley Terwilliger

Hi Simon,

If the set up was working, but stopped - was there anything that changed in the way you were working with your Storyline file? You'll want to check that you're following these guidelines: 

  • Work on your local drive (your C: drive).Working on a network drive or a USB drive can cause erratic behavior, includingfile corruption, loss of audio, and other unexpected behavior. 
  • You should also make sure the directory pathto your project files and your published output is less than 260 characters(for example C:\Articulate).
  • Avoid using special characters, accents orsymbols in your file names.
Manuel Lienemann

Hey guys,

first of all thank you very much Jaenette. The video you've mentioned helped me a lot.

But now I was wondering if there is a solution for Drag & Drop and Matching Drag & Drop. I've already tried to change the states to"Drag over" instead of  "Normal/Selected". But this didn't work for me:

Trigger 1

Show "Invalid Answer Layer" when "user clicks" "Submit Button".

Conditions: 

If "Rectangle 1" is "not equal to" "Drag Over"

OR If "Rectangle 2" is "not equal to" "Drag Over"

OR If "Rectangle 3" is "not equal to" "Drag Over"

 

Trigger 2

Submit interaction "Drag and Drop 1" when "user clicks" "Submit Button".

Conditions: 

If "Rectangle 1" is "equal to" "Drag Over"

AND If "Rectangle 2" is "equal to" "Drag Over"

AND If "Rectangle 3" is "equal to" "Drag Over"

 

Thank you

Selene Redigonda

I have a problem in Storyle 2. When reverting the layout in Arabic to R-L, the styles got lost in the title.tTe colour changes from white to black. When I revert the layout back to L-R it is white again. I checked the styles mentioned above and the title text is white.
Do you know how to fix this bug? 

Selene Redigonda

I have a problem in Storyle 2. When reverting the layout in Arabic to R-L, the styles got lost in the title.tTe colour changes from white to black. When I revert the layout back to L-R it is white again. I checked the styles mentioned above and the title text is white.
Do you know how to fix this bug? 
 

Selene Redigonda

This is a sample from the course. We only left one slide with questions. The problem appears when non of the answers is selected. The pop up looses the format. The title changes from white to black. But it should be white. (See screenshot with incorrect color)

We discovered that what is cousing the problem is the player option to revert the text from Left to Rigth to Rigth to Left. (See screenshot with correct color)

We tried to apply the color again in the "Advanced color editing" tab after the R-L option was selected, but nothing changes. The curious thing is that the colors are correct in that options, for the title it says white, but in the published version and the preview it looks black. Also, the text is not aligned to the rigth as it should be and there are no tools to control this.

Leslie McKerchie

Thanks for the details, images, and project file Selene. That is certainly helpful.

I do see where we have an issue reported for the formatting not applying correctly on the invalid answer prompt when R-L is chosen.

I will add this thread to the report.

I wanted to share some information on how we define bugs and how we tackle them when they occur.

JC Goyette

Please excuse my ignorance, but may I know why SL3, with the latest 2017 update, still does not allow users to customize the "Invalid Feedback" prompt as easily as the "Correct Feedback" and the "Incorrect Feedback" prompts? No 3rd "Invalid" layer appears with the question slides.

Is there a specific reason why SL3 does not have a "Invalid Feedback" feedback layout in the Feedback Master menu by now? For instance, I can edit the "Correct Feedback", "Incorrect Feedback", "Try Again Feedback", "Review Feedback" and "Thank You Feedback", but cannot do a single in-software modification for the "Invalid Feedback" using regular layers. I need to create my own and rig it with variables to make it show if the user does not answer the question.

Are there plans to address this issue in the near future, as it probably would save a lot of time and effort if a proper layer would be given?

Wendy Farmer
JC Goyette

I need to create my own and rig it with variables to make it show if the user does not answer the question.

Hi JC

Yes I agree there should be a layer in the feedback master but you can format the Invalid Answer through the player options.

See attached PDF for how to format colours/fonts etc

The text can be changed through the Player > Text labels option