evaluation questionnaire

Hi All,  I am using 360 Storyline to create an evaluation questionnaire. On slides 1.2  to  1.6 (The fie is attached)  the user selects an option, which hides the other answers and the next row drops down.

My problem is at the end of slide 1.6, 

The fourth and sixth rows are not working as they should.

When I select an answer in the fourth row it does not retain my selection.

When I  select an answer in the last (fifth) row  a popup box appears saying " Invalid Answer, you must complete the question before submitting."  Which prevents me from progressing to the next slide. Even though I have selected an option.

I have rechecked the code and cannot find the error. I would appreciate a fresh pair of eyes to please help fix my error.

Regards,

Carmelo

5 Replies
Maria Costa-Stienstra

Hi, Carmelo.

Thank you for sharing your .story file!

Here's what I noticed in slides 1.5 and 1.6:

  • In Slide 1.6, you didn't have any choice listed in Form View, so I added the radio buttons 11, 12, and 13:

Windows 10 (1) 2021-09-23 at 10.00.27 AM

  • I also changed the initial state for buttons 8, 9, and 10 to be hidden on that same slide, so they followed the same pattern you had throughout your project.
  • On slide 1.5, the feedback layers were not connected in Form View (see below), so I copied them from a previous slide:

Windows 10 (1) 2021-09-23 at 10.03.20 AM

After those changes, it looks like everything is working as expected. I am attaching the edited .story file here.

Screen Recording 2021-09-23 at 10.06.49 AM

Let me know if you have additional questions!

Carmelo Moschella

Hi Maria,

I have added two text boxes and applied coding that will not allow the user to progress to the next slide. They have to submit an answer to proceed. The coding I think is correct but is not working. Could you please have a look and advise why it is not working. 

Thank you,

Carmelo