Help - Retry Quiz button not working correctly Storyline 3

Hi there

I am having a lot of trouble with the retry quiz button in my eLearn course.  I want to user to be able to retake the quiz if they don't meet the 100% pass grade.  When you click the retry quiz button in the published course it should reset the results and then take the user back to the first slide in the scene to retake the quiz.  

The button triggers are set to reset the results and then go back to the first slide (in that order) however it doesn't work correctly when published.  

I have tried making a new button, moving the button to the base slide/failure slide, changing the formatting on the button, etc all to no avail.  Only when you press the button repeatedly in quick succession it will eventually work, however this is not an acceptable solution for my learners to smash the button repeatedly until it eventually works. 

Am i missing something here?  I am at my wit's end with this.  

Please help!  

Many thanks

Carrie 

10 Replies
Crystal Horn

Hi there, Carrie.  Thanks for sharing your file, it allowed me to confirm the issue you're experiencing.  

The retry button is not immediately jumping back to the quiz when there are locked questions in the question bank.  We've noticed that it takes around 7 clicks to return to the beginning, even though the results are reset immediately.  I'll add your discussion to our report so we can notify you of any changes.

In the meantime, a workaround is to unlock the questions in the bank.  Will that work for you?

Crystal Horn

Sure thing, Carrie!  I noticed that some of your questions are locked in sequence to each other in your question bank draw, or locked to the top or bottom.  Check out the little lock icons here:

Select one of the locked question slides in your draw, click the LOCK QUESTION button, and choose the Remove lock option.  Let me know what you see!

Maureen Matsumoto

Hi Crystal, 

Unlocking the questions does not work for me. I have a few that need to be in a specific order, while the rest can randomly appear.

Is there a fix for this yet?

I am importing the Storyline block into a RIse course. I tried using quiz banks, but there is a buffering effect between quiz banks when attached to a Rise project.

Thank you,

Maureen

Ren Gomez

Hi Maureen,

Sorry to hear you're running into this issue! I don’t currently have any updates on the retry button, but you are now subscribed to this conversation which means as we share updates here, you’ll automatically be notified.

Do you mind sharing your .story file with our support engineers to see if we can replicate the buffering? I'm curious as to how big the questions banks are and if we can offer any changes to the settings that could help improve the loading.

Ren Gomez

Hi Maureen,

That is correct! The Storyline file that you used to import into Rise 360 is the file that will help us test the issue. I see in the case that we've received it and my teammate, Gerald, will reach out after he takes a look at your file. You're in great hands, and I'll follow along as well!

By the way, it looks like you may have replied by email where your contact information came through. This Peek video will show you how to edit it out if you’d like!

Daryl Meissner

I don't know who needs to read this but I had this problem too where the retry quiz button did nothing. In my case I had several knowledge checks that do not count towards the final score but that do have a results slide each.  For most courses there is only one results slide.  When you add the retry quiz button the reset trigger automatically gets added, but by default is "unassigned". When there is only one results slide this does matter. But when there are more than one results slide you need to update the reset trigger to the specific results slide you are adding the retry quiz button to.