Non-breaking spaces in text.

Hi,

I have a course with large chunks of texts that need to be justified, and one-letter words cannot be at the end of the line. In HTML I did this using non-breaking spaces after them, I wish to do the same in Storyline, but inserting a nbsp does not work, the word stays at the end of the line. Are the any ways to solve this problem?

22 Replies
Brett Rockwood

To my knowledge there is no way to do a non-breaking space. It is one of a number of typographic functions that have yet to be implemented, e.g., proper tabs, em and en dashes, text wrapping or filling odd shapes. I know that more sophisticated text support has been a common topic on the forum and suggest you make a feature request. The more requests they get about items the likely they are to implement them. (Stepping down from my soapbox...)

Gerry Wasiluk

Two workaround options in the interim that might be very painful to do but should work . . .

1) Have the text set up in another program, like Word.  Take a screenshot and insert that into Storyline as a graphic.

2) Create your text in HTML pages and insert it in Storyline as local web objects.

Judy Nollet

If Michel's suggestion doesn't work, you can also type SHIFT+ENTER where you want the line to break. That will insert a soft return (i.e., start a new line without starting a new paragraph). It's labor intensive if there are a lot of instances, and you might have to go back later and delete the soft return if any text editing impacts the wrapping. But it does allow you to control exactly where the lines wrap.

Brett Rockwood

Michel,

Thanks for that tip on non-breaking spaces. I'm happy to say that Storyline 2 addressed many of typographic limitations — though not all — and you can now enter en and em dashes:
en dash (–) "Alt+0150"
em dash (—) "Alt +0151"

Still waiting and hoping for proper tabs, tables, and text wrapping...

Darren Goossens

Hi John

 Thanks for the response, I appreciate your taking the time to answer.

 But no, does not work regardless of Num Lock setting. I have tried inserting Alt-0160 with and without Num Lock and using Insert -> Symbol and choosing character 0160 from the character map. Just does not work. I get a space, but it's a breaking one, I've tried inserting a nonbreaking space in a word document and then copying and pasting that into the Articulate document (this works in PowerPoint, for example) and that does not work either.

 Pasting from Word using the different options (like Keep Source Formatting) does not work either.

 If I paste a nonbreaking space in from Word (or PPT) and then copy and paste it back from Articulate into Word  (or PPT), it turns into a regular space. So Articulate is somehow converting it to being the wrong character. FWIW, en rule "Alt+0150" works fine.

 I did not express my disappointment without having a fair go at solving the problem, I assure you.

 I installed the program two days ago, so it is completely up to date.

Thanks anyway.

John Say

Hi Darren,

Thanks for compiling your testing notes! You certainly had a fair go at solving the problem. I had another go myself and experienced the same behavior – my sincere apologies!

You are correct that non-breaking spaces do NOT currently work in Storyline 360. 

I have since found a few other feature requests submitted via our feature request form, and I've logged an additional feature request in your behalf. You're in the right place, and we'll post all updates here once we have them!

Ashley Terwilliger

Hi Jacek,

What version of Storyline are you using? We're well past Updates 1 and 2 in all versions: 

I'd recommend always working on the latest update to ensure you have all those fixes and items in place. 

Darren Goossens

That's a good idea. I guess any character would do, as long as the colour matches just right.

Dr Darren Goossens
Science Writer and Editor, Training Manager |  Biotext

Trevor Pearcey House (Block E) Level 1
34 Thynne St
Bruce ACT 2617
t 02 6282 2280
m 0474 122581
e darren.goossens@biotext.com.au
www.biotext.com.au

The Australian manual of scientific style (AMOSS) is now available at sciencestyle.com.au

"I cannot speak well enough to be unintelligible." Katherine Morland (Northanger Abbey, Jane Austen)

Arith Hsu

It looks like the issue of non-breaking space is not working, is actually related to Modern Text which is based on Microsoft's DirectWrite API

If you change your Storyline to use classic text (by going to Design tab -> Fonts, and un-check "Use Modern Text"), then the non-breaking space should work properly. 

But for sure Modern Text style provides a better text rendering result, so if you decide to change it back to Classic Text, the side effect would be losing all the benefits introducing from Modern Text.

(Classic Text is using Microsoft's Uniscribe API)