Numeric Entry not defaulting to blank - but worked earlier this year

Dec 01, 2022

Morning everyone,

First please note I have read every discussion on numeric entry and being blank going back to 8 years ago.

Here is my issue.  I created a course in January 2022 - where I had 10 videos and after each video the learner had to enter a score based on that video - so I have variables NE1 to NE10 - these work perfectly, the numeric entry field is blank, learners enter in their number and it totals.

I recently have been tasked to create this again for a second module, but this time the module has 11 videos.

So I created the numeric entry field it is identical to the other slides but it keeps defaulting zero.  And I can't fix it and my subject matter experts are not liking the fact  the last one is showing a zero as it is confusing. 

I have grab the scene (removed the videos for you).  I am not sure if this bug is back, over the course of the readings, I saw in different versions it was fixed then it was a is it possible it is a bug and it is back?

You will see on the Total score slide how the NE1-10 are displayed in the column, I like that look, so no sure why NE11 shows a zero there as well, but I assume it is connected to the fact I can't seem to default it to blank.

I keep looking at my other slides, but it looks like they just auto default to blank, so there is not much I can do.  I need this to launch in mid-December I am hoping there is an easy fix.  

Thanks for your time

I published to review as well so you can try it and see how NE11 shows a 0 but every other one is blank which is what I wish for. 

9 Replies
Jürgen Schoenemeyer

here is the fix

.story -> attachment

you have created you 11th variable the wrong way

you have probably created the variable here with "+"

this is usually correct

but this special numeric variables are generated differently

add a new "Numeric Entry Field" to any slide

result a new variable with the special "0" behavior

now you can rename it



Teresa Vanderpost

Thank you very much, I wonder when this started happening, as it worked so well back in January?  So my new issue is I am now in my original file (I gave you a small piece of my large module) I deleted what I had for NE11, and I built it the way you showed above and this works, but now my Submit interaction trigger is broken and I can't select "numeric" . I tested the slide and the field now is blank but now I can't submit.  Thoughts?  Everything else works now but this part.  I can't delete it or recreate it but the interaction "numeric" doesn't come up as an option.