"Object reference not set to an instance of an object"

Hi - I am getting this message when trying to save a Storyline file that had saved successfully earlier today. From reading the few other conversations on the topic, I am not seeing anything that looks to promising for being able to get out of this without losing my most recent work. Everything related to the file is on the same local hard drive where the file resides, so it isn't a portable drive issue.

Thanks for any quick advice anyone has to offer -- that is, other than to save more often! ; )

33 Replies
Ashley Terwilliger

Hi Camilla, 

In addition to the files being located on your local drive, the following things are good practices to follow to prevent some unusual behavior:

  • You should also make sure the directory path to your project files and your published output is less than 260 characters(for example C:\Articulate).
  • Avoid using special characters, accents or symbols in your file names.

If you continue to be unable to save it, the file may have become corrupt and one solution for a corrupt file could be to import your Storyline file into a new project: Importing From Another Storyline Project

If this behavior continues on multiple files, you may also want to conduct a repair of your Storyline software. 

Ashley Terwilliger

Hi Ed,

If it's something with the one particular file, it may have some corruption issues that are causing the problem. I'd suggest making sure both your PPT and your .story file are located on your local drive, that the directory path to your project files and your published output is less than 260 characters (for example C:\Articulate), and that you've avoided using special characters, accents or symbols in your file names. 

You may want to also follow the suggestion here to import your Storyline file into a new project - and you may want to also do a similar process with your PPT file. 

If you're still having difficulty, are you able to share the troublesome PPT and Storyline file here with us or share with us privately? 

Camilla Suduth

Ashley - Thank you for your earlier reply. The special character and directory path issues weren't issues in this instance, so it must have been more along the corrupt file line. Whatever it was, I was able to save out parts of the file and then reassemble it. I've been working in the same original file since with no problems, but I will keep the software repair option in mind if it crops up again.

Thanks again for the follow-up. 

Christopher Spencer

Thanks Ashley. I was able to do a repair for Storyline and that seemed to solve the issue. I will tell you though the it all started after I did an uggrade to Studio 13, and then found it was not compatible with Stroyline. I had to uninstall Studio '13 and reinstall Studio '09. at which time the import process began failing. All good now.

Till Then

I was getting the same error converting a PowerPoint 2010 file into a course. Moving the file and removing accents characters from the name did not resolve the issue. 

I was able to resolve the issue by creating a new course with a single blank slide. I then set my Story Size and then clicked 'New Slide' and select Import from PowerPoint. The slides from my PowerPoint 2010 file then imported without the error. 

Also saving the PowerPoint file as PowerPoint 2003 PPT and then coveting also worked. But of course that not ideal!

David Greig

Does the error message (Object Reference not set to an instance of an object) mean something specific that I can fix?

In my case, the message has nothing to do with importing a file. Rather, it has to do with a screen recording.

When I initially captured the recording, it went into its own scene. So far so good--the file was still saveable. However, when I moved the recording into an existing scene, suddenly this error message is generated and the file is no longer saveable.

David. 

Ashley Terwilliger

Hi David,

In the previous instances in this thread, it typically dealt with importing of files and some issues of file corruption. To get started, you'll first want to confirm that you:

  • Work on your local drive (your C: drive).Working on a network drive or a USB drive can cause erratic behavior, includingfile corruption, loss of audio, and other unexpected behavior.                                                    
  • You should also make sure the directory pathto your project files and your published output is less than 260 characters(for example C:\Articulate).
  • Avoid using special characters, accents orsymbols in your file names.

Additionally, I'd conduct a repair of Storyline just to be safe.  If you remove the screen recording from the slides/scene (don't worry, it's still saved in the project under the "record screen" button and can be inserted later) are you able to save the file? 

Kathy Waits

I am also having the same issue when recording a demo, and then moving the slides to a new scene.  This has been happening for a while (versions 1 and 2).  I have tried repairing, reinstalling, renaming the project, etc.  Nothing works, and this is the MOST frustrating issue that I have with Storyline.  Always losing work because of it.  I don't understand why this issue cannot be fixed.

 

Ashley Terwilliger

Hi Kathy,

The original issue in this thread is a bit older, and based on Shimaa's recent post there was some confusing about what was happening - so in regards to your issue, I know you mentioned going through all the normal troubleshooting steps - but when do you see this error message regarding the object reference? Or if you're not seeing that could you share a bit more about the issue you're running into? 

Ashley Terwilliger

Hi Kathy,

When you create the screen recording and then cut/paste - are you doing this within the same .story file or from one file to another? If it's in the same file, instead of having to cut and paste, could you choose where to place the recording screens at the insertion point instead of copying/pasting? If doing it in separate files, could you look at importing those slides in? 

Kathy Waits

I am cutting and pasting from within the .story file--which brings to light another matter since you mentioned it.  I am selecting a slide as an insertion point, and then clicking Insert > Record Screen to create my recording.  Once I have finished recording, I receive the window asking where I want to place the recording.  I pick the correct scene, but it always places it at the end of the scene (I normally create all of my regular slides first, and then create the demos...so there's always slides after my insertion point).   I receive the "object reference" message when I attempt to cut and paste within the scene.

Ashley Terwilliger

Hi Kathy,

It i'll always insert it at the end of the scene you're  in - not where you have placed your slides. But instead of copying and pasting, what about selecting those slides and changing their location by dragging in Story view? I think the copy/paste behavior is causing some unintended consequences. 

Sarah Linden

I have no idea how this fixed the issue, but I received this error when Storyline was running really slow and I tried to save the file (my computer fan was running pretty hard, and the screen would temporarily freeze). I tried saving the file to a new location (desktop) and I successfully saved the project without receiving the error.

Just thought this might help for someone out there!